SMPlayer xv kimenet hiba

 ( BotoroiB | 2015. november 23., hétfő - 21:53 )

Ubuntu 15.10 64 biten egy i5-6500-as processzort használok.
A problémám a következő lenne:
Az SMPlayer hibásan működik az xv kimeneten, a videó minden esetben az előtérben marad, nem lehet, rá semmilyen ablakot húzni, mert kék foltok maradnak vissza amíg fút az MPlayer. A videót nem lehet átméretezni sem. Ha átállítom a kimenetet gl, vagy gl3-ra a probléma megszűnik, viszont, a videó képkockái néha érdekesen szétcsúsznak egy vízszintes vonal mentén, különösen a nagyon pörgős részeknél, ami nagyon zavaró. A probléma ugyanígy fennáll VLC esetén is.
A kérdésem, hogy lehet-e valamit kezdeni ezzel, azon kívül, hogy használjak gl kimenet?
Érdekes, hogy a Firefoxon a youtube videók simán mennek.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

mplayer -vo help

Nézd meg mit ad és próbálgasd, melyik műxik jól!

............
Tegnap nem csináltam semmit, ma folytatom, mert nem lettem kész vele! :)

már végigpróbáltam, az xv-n kívül a többi működik (pl. gl3, gl, x11, sd, gl_nosw), de megvan a "vízszintes" vonal hiba bennük is.

Videokártya driver csere?
Van(volt) úgy hogy mplayer a videokari driver miatt nem ment teljesképernyőn.
Erre elindulni?

............
Tegnap nem csináltam semmit, ma folytatom, mert nem lettem kész vele! :)

Frissítettem az intel linux graphics installerel az alábbiak szerint, de a hibák továbbra is fennállnak:

Added:
intel-gpu-tools:amd64 (1.12-1)
libunwind8:amd64 (1.1-4)
libva-drm1:amd64 (1.6.1-1)
libva-egl1:amd64 (1.6.1-1)
libva-glx1:amd64 (1.6.1-1)
libva-tpi1:amd64 (1.6.1-1)
libva-wayland1:amd64 (1.6.1-1)
libva-x11-1:amd64 (1.6.1-1)
vainfo:amd64 (1.6.1-1)

Upgraded:
i965-va-driver:amd64 (from 1.6.0-1 to 1.6.1-1)
libva1:amd64 (from 1.6.0-1 to 1.6.1-1)
va-driver-all:amd64 (from 1.6.0-1 to 1.6.1-1)

Persze, kapcsold be a vízszintes szinkronizációt. Szerk.: vagyis a függőlegest. :)

:)

Ha a vsync kapcsolóra gondolsz, akkor azt már próbáltam, és nem használt.
Viszont sok kísérletezés után rájöttem, hogy a tearing probléma megoldható gl alatt, ha a window managerben bekapcsolom a szinkronizálást, és a compozitort, akkor talán náha egy nagyon kicsi tearing van csak. Viszont ha kikapcsolom a Compizt, akkor a gl ugyanúgy rossz. Érdekes, hogy az xv akkor már nem zavarja az ablakokat, kivéve a lejátszó saját menüjét, rá lehet bármit húzni, viszont átméretezni továbbra sem lehet..

Nem konkrét kapcsolóra gondoltam, hanem a szinkron tényleges elérésére. Mivel több szoftveres rétegről van szó, az összesben együtt kell elérni a jól működő szinkronizációt.

A VLC ablakát sem lehet átméretezni?

Az átméretezés semelyik kimenettel sem működik?

:)

A gl kimenetek azok mennek mind vlc, mind mplayer alatt. Ha aktív a compiz és a szinkronizáció, akkor minden ok. (Talán néha egy nagyon kis tearing van, de elhanyagolható) Gl alatt átméretezhetőek. Viszont ha kikapcsolom a compizt, akkor újra van tearing.

Az xv viszont mindegyik helyzetben és lejátszóval hibásan megy. A videó átméretezhetetlen minden esetben. Ha kikapcsolom a compizt, akkor legalább az ablakokat nem zavarja, a videó háttérbe küldhető, ráhúzható egy másik ablak úgy, hogy a tartalmát kiszínezné. Viszont érdekes módon a lejátszó menüje továbbra is a videó "mögé" kerül.

szerk.:
inkább a gl kimenet esetén úgy fogalmaznék, hogy nem szűnt meg teljesen a tearing, csak csökkent, videója válogatja..

Esetleg még megpróbálni 32bites rendszert?
Ha van lehetőség, üres partició.
Driver gyanús szerintem.

............
Tegnap nem csináltam semmit, ma folytatom, mert nem lettem kész vele! :)