MikroTik rb2011uas-2hnd-in avagy hamarosan felgyujtom :)

 ( FBK | 2014. január 20., hétfő - 1:01 )

hello,

az volna a gondom, hogy 5.26 --> 6.7 upgrade es bootloader upgrade utan az eszkoz tobbet nem bootol...jelen esetben odaig jut el, hogy ha nyomva tartom a reset-et folyamatosan akkor a kijelzon felugrik az ether boot majd ha az eth1 interfeszbe dugok egy kabelt akkor loading kernel es itt el is hal az egesz...ha siman inditom akkor kernel boot from nand a vegtelensegig.

ha minden igaz akkor ezen a netinstall segit, kerdesem, hogy ennel a tipusnal feltetlen szukseges serial cable?

es valami tapasztaltabb mikrotik -es roviden leirhatna step by step h mit csinaljak vele, mert lassan tenyleg bedobom a cserepkalyhaba :-D

kosz

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Üdv!
Én tftp keresztül próbálkoznék.
http://wiki.mikrotik.com/wiki/Manual:Netinstall

Itt van egy leírás!

Ubuntu 12.04, Kernel:3.8.3, AMD Phenom 2 x4 955BE , OCZ-VETRTEX3 SSD

de ebben szo sem esik a tftp-rol ;[

--
FBK

Két lehetőséged van ahogy én nézem vagy a link szerint kezded ahogy nézem a második hogy megprobálod bootolni tftp segítségével mint ha network instalt csinálnál. Szerencsére az én mikrotik-em még nem került ilyesfajta helyzetbe.

Nézegetve a link leírását az is egy netboot rendszert használ.
Ubuntu 12.04, Kernel:3.8.3, AMD Phenom 2 x4 955BE , OCZ-VETRTEX3 SSD

+1
Ezzel már sikerült életre keltenem jópár eszközt.

@Jaci:

pontosan, hogyan is, lecci par sorban vesd le, hogyan csinaltad.

koszi

--
FBK

- Rádugod a géped direktbe az eszközre
- Kikapcsolod a tűzfalat
- Engedélyezed a Net Booting-ot
- Ha sikeres a kapcsolódás megjelenik a software id meg a többi adat. (ha nem Tik reboot, ha továbbra sem, konzolon megnézni mi a baja)
- Ha kapcsolódott: kipipálod, hogy melyik csomagokat akarod feltölteni, majd install.

De tök jó a link, le van írva minden, amit kihagytam volna az is. És screenshotok is vannak....

Konzol kábel nélkül szerintem esélytelen.

A boot folyamat első eleme a belső nand, ha abból hiba nélkül kiolvassa a kernelt akkor onnan fog indulni.

- bédugod a soros drótot (mintha Cisco kompatibilis) átállítod a boot folyamatot
- futtatod a netinstall szoftvert a gépen
- reboot a routernek
- seperc alatt újraírja a nand-ot

Itt a leírás: http://wiki.mikrotik.com/wiki/Manual:Netinstall

Vagy mégsem: "Consult RouterBOARD.com and specific RouterBOARD User Guide to find reset button location and usage instructions". User guide-ban keresd hogy kell a reset gombot nyomni ethernet boot-hoz. Nekem mikor kellett egyszerűbb volt soros konzolozni mint reset-et nyomogatni :)

a console kábel sokat segíthet a dolgon - legalább látod, h mi történik pontosan az eszközön.
Ezzel tudsz csinálni NAND format-ot és firmware upload-ot is.

koszi, mindenkinek, este nekiesek aztan majd beszamolok az eredmenyrol ^^

--
FBK

Szia!

Annyit még hozzátennék, hogy ennél a tipusnál ahhoz, hogy netboot aktiválodjon, nem kell konzol kábel, elég a reset gombot nyomva tartani bekapcsoláskor, és addig nyomva tartani amig az activity LED villogása meg nem szűnik, innentől fogva automatikusan netboot módba indul el.

Üdv
Sanyi

igen, ezt en is tapasztaltam, de ilyenkor sem jelenik meg semmi a netinstall -ban.

vagy milyen ip cimet vegyek fel a gepen a NIC -nek?

--
FBK

DHCP server legyen abban a hálózatban, ez fontos, mert tapasztalatom szerint anélkül nem működik.

Üdv
S

az mihez kéne? a routerboard default NEM DHCP-ről bootol, hanem PXE-ről.

ezt most en se vagom. ?

--
FBK

Viszont a PXE paramétereket a DHCP szerver adja neki - ha adja. De ezért a legtisztább a netinstall-t szeparált hálózatban csinálni (közvetlen kábel a gép és a board között, semmi más) és a netinstall sw adja a DHCP/PXE-t, ehhez kell beállítani az "enable netboot" opciót és beállítani egy board-nak kiosztandó IP címet (ami persze stimmel a gépen beállított fix IP-hez és alhálóhoz) - nekem legalábbis így működött mindig tuti stabilan.

szó szerint ez van a manualban, és müködik is :)

teljesen uj problemaval kuzdok, a netinstall -t megoldottam, win 7 x64 -rol nem mukodik, only xp, vagy van valami a gepemen ami miatt nem megy...

tehat 6.7 -es routeros felmegy bebootol, ha bele sem modositok a konfigba, akkor is reboot es soha tobbe nem bootol, kijelzo: loading kernel from nand konzol: starting... (kinlodasbol volt bootloader upgrade is, de az sem segitett)

szerintetek? visszagariba?

--
FBK

Igen, szopjon más vele.

+1 :D

--
FBK

A 6.7-esre történő felhúzás nálam is csinált érdekességet ennél a sorozatnál. Próbáld meg a firmware-t is frissíteni (System->Routerboard) a 3.10-es változatra. Esetleg úgy, hogy visszateszel egy régebbi RouterOS-t előtte.

--

kincza

3.10 van fent...utana ment a 6.7 :(

--
FBK