wireshark modul

 ( bAndie9100 | 2013. április 25., csütörtök - 13:08 )

Találtam az n2n protokoll-bújtató VPN protokollhoz wireshark modult - legalábbis ez annak tũnik:

https://github.com/meyerd/n2n/tree/master/n2n_v2/wireshark

Hogyan fordíthatnám be?

Próbáltam Win-en:

Makefile.nmake(7) : fatal error U1052: file '..\..\config.nmake' not found

láthatóan kell neki az a config fájl, mert ha kikommentelem, hiányolja még több hibaüzenettel.

Linux-on cmake ezt dobja:

Unknown CMake command "register_dissector_files".

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Milyen linux, wireshark milyen verzio, az csomagbol vagy forrasbol felrakva, wireshark-dev csomag vagy forditasban developer dolgok benne vannak?

Idézet:
wireshark-dev

jahogy az is kéne hozzá...

felrakom, lehet h abban van a hiányolt file.

egyébként

GNU/Linux 3.2.41-2~bpo60+1 i686
Debian 6.0.7
wireshark 1.2.11
repóból csomagból

~~~~~~~~
http://www.youtube.com/watch?v=VbUVqODL1nE

a wireshark-dev -ben nem látok olyan fájlt, amire közvetlenül szükség lehet.

leszedtem a forrást [http://anonsvn.wireshark.org/wireshark/trunk/], bemásoltam az n2n könyvtárat a plugins/ könyvtárba.

cmake még mindig nem érti a register_dissector_files-t.
nmake-nak pedig még mindig hiányzik valami:

az n2n könyvtárra:
NMAKE : fatal error U1073: don't know how to make '..\..\epan\libwireshark.lib'

a trunk/, vagy epan/ könyvtárra:
Makefile.nmake(10) : fatal error U1052: file 'win32.mak' not found

~~~~~~~~
Linux 3.2.0-0.bpo.4-486
Debian 6.0.7

up

~~~~~~~~
Linux 3.2.0-0.bpo.4-486
Debian 6.0.7

Konkret valaszom nincs, nem teszteltem ezt de korabban lua support megvalositassal igen es abbol kiindulva azt mondanam ujabb verzioju wireshark kellhet, illetve ahogy nezem ez a dissector valami python supportot igenyel: http://wiki.wireshark.org/Python
Szoval szerintem probald meg ujabb, legalabb 1.4-1.5 verzioju wireshark-ot forditani python support-al (>2.5 python), vagy nezd meg esetleg wheezy-ben levo wireshark-ot, hatha benne van gyarilag a python support, vagy azt ujrafoditani vele (felteve ha tenyleg az hianyzik neki).

akkor keresek újabb vagy másik verziót.
python-t nem úgy tũnik, hogy igényelné, az n2n modul C-ben van.
azután jelentkezek.

~~~~~~~~
Linux 3.2.0-0.bpo.4-486
Debian 6.0.7