Kindle 3.3 (3 - keyboard) jailbreak, Duokan telepítése

 ( anon7002197 | 2012. január 17., kedd - 18:44 )

Tisztelt HUP tagok!

Szeretnék egy Duokan firmware-t telepíteni a Kindle 3 Keyboard olvasómra. A leírások általában nem teljesek, csak keveset említenek.
("Install jailbreak, install Duokan")

Tudna valaki írni egy rövid howto-t, hogyan telepíthetem fel az angol változatot?

Telepített firmware: 3.3

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Innen --->IDE.

A jailbreak most már tiszta. Duokan leírás továbbra sincs. Az egyedüli amiket Google dob és a topicban is említenek, egy régi, default angol nyelvvel érkező változat. Tudtommal az újakból már van angol verzió, de nem tudom, hogyan telepítsem őket.

Igen, sajnos ez is a régivel foglalkozik. :/

(Minden howto, minden oldal, azt az egy blogbejegyzést linkelgeti, a régi angolra beállított Duokan verzióval.)

És az új(?) telepítése annyira különbözne a régitől?

Blogbejegyzés: 2011/05/20

(Amúgy meg azért is érdekelne a telepítés módja, mert jó lenne mindig kipróbálgatni az újabb és újabb kiadásokat.)

Üdvözöllek, én is nagyon sokáig kerestem a tökéletes megoldást, mert hasonló cipőben jártam anno, mint most Te.
Nos a történet lényege nagyon egyszerű, de mire erre rátaláltam az nem az....
Szükség van a jailbreak-re (én a 0.5.1-et használom) és utána fel kell tenned a launchpad nevű programot.
Akkor láthatod, hogy létrejött egy launchpad nevű mappád, ebbe létre kell hozni az aktuális duokanod installálására hívatott parancs init. Ezt úgy tudod elvégezni, hogy megnyitsz egy jegyzettömböt a számítógépeden és az alábbi szöveget illeszted bele:

[Actions]
;; run Duokan installer
F D = !sh /mnt/us/DK_System/install/liteinstall.sh &

Azért ellenőrizd, hogy az általad felmásolt DK_System install mappájában valóban liteinstall.sh van-e mert megeshet, hogy csak instal.sh, értelemszerűen a névnek egyeznie kell, tehát ha nem az akkor átszerkeszted azt a részt és úgy mented a kindle launhpad mappájába duokan.ini néven. (Tehát arra ugye nem tértem ki, hogy leszeded azt a duokant amit ki szeretnél próbálni, nekem a lite verziókkal is sikerült a folyamat sikeresen.)A megfelelő bin-t is betettem a gyökérbe, de ne lepődj meg ha lesz egy update error is, viszont amikor ezt a lépést kihagytam nem volt tökéletes a telepítés. Szóval ha mindezzel megvagy, akkor a kindle főmenüjében lenyomod gyorsan egymás után: shift-F-D ha sikerült, nekem sem megy mindig elsőre, akkor megjelenik alul a három jel valamint a succes felirat. Ezután nincs más dolgod, mint újraindítani a kindle-t. Várj türelmesen, majd mikor megjelenik a duokan felirat, nyomd meg a Q-ot folyamatosan, ezzel szépen elindul az alternatív kezelőfelület szeretet könyvolvasónkon.

Tehát pontokba szedve:
1. jailbreak és launchpad felrakása
2. duokan DK_System mappája másolása a kindle gyökerébe
3. douken ini létrehozása
4. kindle menüben aktiválni a shift-F-D gombokkal
5. újraindítás, és a felvillanó menüképernyőnél Q-t nyomni.
Ui: A 212-es duokent nem tudtam sikeresen felrakni, de azt megelőző verziókat igen a 3.3-as kindlemre.

Remélem segítettem, üdvözlettel: Kobudera!

Update: délután: 14:22

Csak nem hagyott nyugodni a dolog, és sikerült felraknom a legfrissebb duokent, mégpedig az én rendszeremmel lehetett valami, mert mostmár vígan duruzsol. Pár napig követem a fórumod, ha elakadtál vagy sikerült jelezzed. Köszönöm!

Köszönöm a leveles értesítést, és a hozzászólást.
Neki is láttam letölteni a legújabb jailbreak-et mint első lépés.

Ez egy Kindle 3 keyboard (wifi, reklám nélküli).
Ezt töltöttem le: kindle-jailbreak-0.10.N.zip
Ezt másoltam be: update_jailbreak_0.10.N_k3w_install.bin

Miután bementem Settings -> Update menüpontba, kiköpte, hogy hiba történt.
Olvastam, hogy van amelyiknél így kell lennie. Oké, gondoltam felrakom Launchpad-ot.
Lehúztam a legújabbat amit találtam hozzá. Felraktam. Ismét update. Ismét fail.

Itt már látszódnia kellett volnia valaminek. De semmi.

Nekem ugyanilyen kindlem van. Én nem is próbálkoztam a 10N-el, mert írták, hogy az nem elég kiforrott sok embernek. Szóval azért ajánlottam azt ami biztosan működik, a másik kínai emberkéét az 5.1-et, tehát az nem elavultabb hanem más szerzőé. Amúgy kérlek rendesen részletezd a mondanivalód, mert azt sem rtem, hogy a launchpadot nem tudtad már felrakni vagy a duokant... Ráadásul a launchpadhoz csinálni kell egy doukan init-t és ugye aktiválni kell a kindle főmenüjében a shift+f+d gombokkal...

Nos valójában meddig jutottál el?

Mikor írtad a hozzászólást, megnéztem mégis melyiket szedjem. Nem akarom brickelni az olvasómat.
Az oldalakon az új N-eset írták, az előző elméletben a 3.2.1 -es FW-re van. Nekem 3.3 van telepítve, ezért szedtem le azt, amit.

Utána felraktam a gyökér könyvtárba a megfelelő -w változatot, és Settings-ből nekiláttam a frissítésnek. Ez azonnal hibát eredményezett, és újraindult a Kindle.

(Tehát a Launchpad-ig elméletben el sem jutottam.)

Nos, ha mint mondtam én sokat olvastam utána, megfelelő oldalakról, de a lényeg, hogy gyakorlatban is lezongoráztam... Nem mindig megbízható a 10N-en... De mindegy is, nekem működik a gyakorlat ahogy leírtam, msn-ned dobd el privátban, javaslom folytassuk ott.

Látom nem akarsz msnen értekezni, rendben akkor nem tudok segíteni... Mint mondtam a lite verziókban nincs benne a doc támogatás, és ez engem zavart. Viszont meglepő dolgot vettem észre. Képzeld el, feltettem először a régi duokant, a zt ami támogatja még a doc-ot, aztán fogtam felmásoltam az új telepítőjét, felülírva benne a régebbi két fájlt, amit lehetett, majd telepítettem. Ezt pár oldalon olvastam, hogy javasolják, csak azt felejtették el leírni, hogy miért. Én azért tettem, hátha így majd az új duokan "megörökli" a doc olvasási képességet. Ezzel szemben nem! Viszont meglepő volt az eredmény, amikor választani kell a felugró duokan képernyőn akkor nem kettő gomb van hanem 3:
Q: duokan (új)
A: duokan (régi)
Z: kindle

Hát meg is lepődtem, így mindegyik rendszer jó tulajdonsága megmarad. :)

Nem nem akarok értekezni, gépközelben sem voltam. Küldöm a címem.

Vártam az msn címet, de nem jött még.. na majd ha lesz kedved. :)

Pedig én küldtem. HUP-os üzenettel. Rányomtam nevedre, Kapcsolat.

Amúgy meg nem is értem miért olyan nagy szám ez a cucc, pl. nálam nem is támogatják ezek az újabbak a DOC-ot és djvu-t....