Az Európai Beruházási Bank 25 millió euróval támogatja a MariaDB fejlesztését

 ( trey | 2017. május 10., szerda - 11:35 )

Az Európai Bizottság bejelentette, hogy az Európai Beruházási Bank (EBB) 25 millió euróval segíti a nyílt forrású MariaDB fejlesztését. Ez az első alkalom, hogy az EBB finanszírozza a MariaDB-t. Részletek a bejelentésben.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Ez feltehetően jókora lökést ad a fejlesztésnek.
Remélhetőleg van valamilyen biztosíték arra is a támogatási szerződésben, hogy ne vehesse meg egy új Orákulum! (Oracle)
--
Tertilla; Tisztelem a botladozó embert és nem rokonszenvezem a tökéletessel! Hagyd már abba!; DropBox

Haha nekem is pont ez jutott eszembe. Most jól kitömik aztán jön az ora lol...

--
GPLv3-as hozzászólás.

Amelyik megint ad egy halom pénzt az eredeti fejlesztőnek, aki forkolja mondjuk MyrtylDB néven az akkori állapotot. Hol itt a gond? Mindenki jól jár, de leginkább a fő fejlesztő.

=====
tl;dr
Egy-két mondatban leírnátok, hogy lehet ellopni egy bitcoin-t?

Még, hogy az open source-ból nem lehet megélni! Meg lehet, csak nem bohócokat kell a projektek élére tenni pénzügyi vezetőnek.

--
trey @ gépház

Úgy látom, hogy az Ubuntu repóban a MariaDB szerepel ugyan, de nincs bejelölve támogatottnak. A MySQL viszont támogatott, bármit is jelentsen az.

Mi volt a célja az Oraclenek a MySQL megvételével, a konkurencia eliminálása? Akkor most bosszankodhatnak. Nem olyan könnyű elsorvasztani, mint az Informixet.

--
ulysses.co.hu

Nem hiszem, hogy csak a mysqlt, magában megvették volna...
--
blogom

Nem az Oracle vette meg, srácok...

Továbbá meg vagyok győződve róla, hogy ha az Oracle lett volna a kérő, akkor nekik nem lett volna eladó a cég - sőt, valószínűleg a másik oldalról is igaz ez (az Oracle se akart volna ilyet céget megvenni).
Másrészt már a Sunos időkben is látszott, hogy "nem jött be" ez a felvásárlás (ahogy a Sunos felvásárlások jelentős része), nem ilyen lovat akartak ők... szóval nagyon meg lennék lepve, ha valaha belemenne a kedves régi-új tulajdonos egy hasonló felvásárlásosdiba.

voltak kulonbozo allitasok a felek reszerol, hogy a mysql valoban konkurenciaja az oracle termeke(i)nek. Szerintem az oracle termekpalettajan van helye a mysql-nek, mert van olyan celcsoport, akinek ez pont jo.

+1

Szeretem az ilyeneket, mint "termékpaletta" meg "célcsoport". De akkor is nehéz megmagyarázni, mire jó az Oracle termékpalettáján egy olyan termék, amivel ingyenes konkurenciát csinál saját magának.
--
ulysses.co.hu

Ügyfél csalogatónak.
Itt van ingyen. Kell támogatás? Azt is adunk, esetleg már némi pénzért. Mindent megoldunk, de akkor már váltani kell a fizetős adatbázis-kezelőre.
És ez valószínűleg be is jön annyira sok esetben, hogy megéri fejlesztgetni a MySQL-t is.
--
Tertilla; Tisztelem a botladozó embert és nem rokonszenvezem a tökéletessel! Hagyd már abba!; DropBox

ugy tudom, hogy az oracle sajat db-jenek is van ingyenes verzioja, amiben olyan korlatozasok vannak pl. csak x mag, z GB memoria, stb, ami egy kisebb projektnel eleg lehet. Akkor most az oracle a sajat termekevel sajat maganak is konkurenciat csinalt? :-) De szerintem arrol van szo, hogy nem mindegyik smb vesz meg csillio penzert k. draga oracle licencet, hanem inkabb vesz olcsobban mysql community edition-t + supportot vagy mysql enterprise-t. Mert igeny az van a mysql-re, es amig az oracle (eleg) penzt lat belole, addig miert is dobna a termeket?

Volt szerencsém az express editionhoz, ha jól emlékszem a névre. Az tényleg gondolható csalogatónak. A MySQL-t nem gondolnám annak, ugyanis meg lehet vele oldani a feladatokat, így aztán a potenciális vevő könnyen arra juthat, hogy az Oracle tulajdonképpen felesleges.

Amúgy, hallottam olyan projektről, amiben követelmény volt a MySQL használata, mégpedig éppen az Oracle miatt. Ezért jött létre a CCC MySQL interfész. De amilyen rosszmájú vagyok, én azt hiszem, hogy az Oracle vezetés rosszul van a MySQL-től meg a hasonló ingyenes konkurenciától, ha tehetné megszüntetné őket. Szerencsére nem teheti.

--
ulysses.co.hu

A MySQL-t nem gondolnám annak, ugyanis meg lehet vele oldani a feladatokat, így aztán a potenciális vevő könnyen arra juthat, hogy az Oracle tulajdonképpen felesleges.

ha ez igy van, akkor oda tenyleg felesleges.

az Oracle vezetés rosszul van a MySQL-től meg a hasonló ingyenes konkurenciától, ha tehetné megszüntetné őket. Szerencsére nem teheti.

ha az ove az x termek, akkor miert ne tehetne meg, hogy leallitja az x termek fejleszteset (tegyuk fel, hogy az ugyfeleivel korrektul lepapirozza az x termek kivezeteset)? Siman megteheti. De nem arrol van szo, hogy nem teheti, hanem hogy nem akarja. Nyilvan okkal...

Akkor vajon miért vette meg a Berkely DB-t? Szerintem mindazokat begyűjti, amiben gyenge.
Csináltak már sor-oszlop orientált storage-ot is az "adatbázisok optimális ábrázolásához". :-D

Hát véletlenül ismerem a Berkeley DB-t (a kódját is), attól nem lesznek erősebbek. Egyébként is érthetetlen. BSD licencű kóddal azt csinálhatnak, amit akarnak.
--
ulysses.co.hu

Egy ideje (néhány hónapja) az Ubuntu upgrade hibát jelez a mysql-nél:

Do you want to continue? [Y/n]
Setting up mysql-server-5.7 (5.7.18-0ubuntu0.16.04.1) ...
Renaming removed key_buffer and myisam-recover options (if present)
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
insserv: warning: script 'screen-cleanup' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `screen-cleanup'
insserv: Default-Stop undefined, assuming empty stop runlevel(s) for script `screen-cleanup'
mysql_upgrade: Got error: 2002: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: error processing package mysql-server-5.7 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.7; however:
Package mysql-server-5.7 is not configured yet.

dpkg: error processing package mysql-server (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
mysql-server-5.7
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Nyilvánvalóan az a baj, hogy a telepítő script az upstart-ra számít, miközben itt már systemd van. Ezt jelentené az ún. "támogatás", amiről fent írtam.

--
ulysses.co.hu

Nem panaszképpen írom. Nem használom a mysql-t, nem érdekel, hogy jól upgrade-elődik-e vagy nem. De az azért informatív, hogy az aktuális LTS szerveren, a piacon legelterjedtebb (és állítólag támogatott) adatbazis upgrade-je elbukik. Külön nevetséges, hogy éppen a saját upstartjukkal lőtték lábon magukat. Szóval elég nyugtalanító, ha az Ubuntu elkezd valamit támogatni.

ez tiszta ubuntu issue, nem latom, mi koze akar az oracle mysql-hez vagy a mariadb-hez...

Én látom. Oda van írva, hogy: mysql-server-5.7. Hacsak ez nem.
--
ulysses.co.hu

Szvsz nálad lehet a gubanc, mert worksforme.
Ubuntu 16.04.2 + mysql-server 5.7.18-0ubuntu0.16.04.1

btw.: 16.04-ben már systemd az alapértelmezett.

Hát én biztosan nem állítottam át a mysql-t, hogy upstartolni akarjon.
--
ulysses.co.hu

16.04-ben már systemd az alapértelmezett.

Miért, opció, hogy ne legyen benne systemd? Én ilyet nem olvastam sehol...

Továbbra is használható az upstart, akárcsak a debianban a sysvinit. Mondjuk utóbbiban talán a *dm-eknek már kellhet a systemd (logind), de az alaprendszer vígan elmegy nélküle.