[megoldva] Enemy territory 64 bites Ubuntun

 ( Jester_Racer | 2009. augusztus 2., vasárnap - 11:37 )

Sziasztok!

Az Enemy Territory-t szeretném futtatni egy 64bites ubuntun, de nem nagyon akar menni.
Egy fél napot töltöttem azzal, hogy keresgéltem a megoldást mindenféle fórumokban, de nem sikerült megtalálni.

Amit próbáltam:
telepítettem az ia32-libs csomagot, majd így próbáltam telepíteni:

feri@home4:/media/letoltes/letolt/jatek$ chmod +x ./enemy_territory.run
feri@home4:/media/letoltes/letolt/jatek$ sudo linux32 ./enemy_territory.run
Verifying archive integrity... All good.
Uncompressing Enemy Territory 2.55.....................
The setup program seems to have failed on x86/glibc-2.0

See http://zerowing.idsoftware.com/linux/ for troubleshooting

próbáltam azt is, hogy a
sudo linux32 ./enemy_territory.run --target et
parancsot kiadva, a létrehozott et önyvtárból a setup.sh-t közvetlenül futtatni, de úgy is ugyanezt a hibát kaptam.

Van valakinek ötlete amit esetleg még megpróbálhatnék, egyátalán lehet 64 bites rendszeren futtatni a játékot?

Szerk.: olvastam egy chroot-os megoldásról is, de azt nem szeretném használni, annyit nem ér az egész

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Hagyd a francba azt a setup-ot, tömörítsd ki kézzel!

<= Powered By Ubuntu & Gentoo Linux =>

'Software is like sex: It's better when it's free!'
By Linus Torvalds

Oké, de mit, hogyan, hova? :)

Szerk.: ha a *.run-ra gondolsz az már megvan. Egy et nevű könyvtárba kicsomagoltam aminek ez a tartalma:

feri@home4:/media/letoltes/letolt/jatek/et$ ls -all
összesen 48
drwxr-xr-x 7 root root 4096 2009-08-02 11:18 .
drwxrwxr-x 7 root feri 4096 2009-08-02 11:27 ..
drwxr-xr-x 3 1007 1007 4096 2003-05-27 13:45 bin
-rw-r--r-- 1 1007 1007 2752 2003-05-27 13:43 CHANGES
drwxr-xr-x 3 1007 1007 4096 2003-05-27 13:43 Docs
drwxr-xr-x 3 1007 1007 4096 2003-05-28 00:16 etmain
-rw-r--r-- 1 1007 1007 1290 2003-05-27 13:45 ET.xpm
-rwxr-xr-x 1 1007 1007  287 2003-05-27 13:45 openurl.sh
drwxr-xr-x 3 1007 1007 4096 2003-05-27 13:45 pb
drwxr-xr-x 4 1007 1007 4096 2003-05-27 13:45 setup.data
-rwxr-xr-x 1 1007 1007 7502 2003-05-27 13:43 setup.sh

Innen viszont nem tudom hogyan tovább...

Nem a .run-ra gondoltam, de ha teszel az ls mögé egy -s paramétert is, megmondom ;)!

<= Powered By Ubuntu & Gentoo Linux =>

'Software is like sex: It's better when it's free!'
By Linus Torvalds

így gondoltad?:

feri@home4:/mnt/letoltes/letolt/jatek/et$ ls -alls
összesen 48
4 drwxr-xr-x 7 root root 4096 2009-08-02 11:18 .
4 drwxrwxr-x 7 root feri 4096 2009-08-02 11:27 ..
4 drwxr-xr-x 3 1007 1007 4096 2003-05-27 13:45 bin
4 -rw-r--r-- 1 1007 1007 2752 2003-05-27 13:43 CHANGES
4 drwxr-xr-x 3 1007 1007 4096 2003-05-27 13:43 Docs
4 drwxr-xr-x 3 1007 1007 4096 2003-05-28 00:16 etmain
4 -rw-r--r-- 1 1007 1007 1290 2003-05-27 13:45 ET.xpm
4 -rwxr-xr-x 1 1007 1007  287 2003-05-27 13:45 openurl.sh
4 drwxr-xr-x 3 1007 1007 4096 2003-05-27 13:45 pb
4 drwxr-xr-x 4 1007 1007 4096 2003-05-27 13:45 setup.data
8 -rwxr-xr-x 1 1007 1007 7502 2003-05-27 13:43 setup.sh

64 biten használom Ubuntu alatt, de nekem nem rémlik, hogy a telepítéssel gond lett volna...
Megpróbáltam ismét telepíteni:

blabla@GEP:~/Torrent$ sudo ./et-linux-2.60.x86.run 
Verifying archive integrity... All good.            
Uncompressing Enemy Territory 2.60 Full Install [sok-sok pötty]
/home/blabla/.setup4599: error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: No such file or directory

Ám ettől függetlenül megy szépen a telepítő. (Konzolosan a hiányzó gtk library miatt, de a kutyát nem zavarja.)

Ahogy én látom, egyedül a verziószámban van eltérés.

Próbáld meg a 2.60 installert: zerowing.idsoftware.com

--
Én egy divathupper vagyok. :)

Köszi a segítséget, a 2.60 installer-el tényleg működik :)

Tipp:

Ha hangot is akarsz alá, akkor:

wget -q -O - http://nullkey.ath.cx/~stuff/et-sdl-sound/et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound

És az "et-sdl-sound"-dal indítsad az ET-t. (Kell majd egy SDL library is hozzá, de fejből nem tudom melyik, ám úgyis kiírja, szóval megtalálod majd.)
Így indítva az ET-t simán tudok közben alsa-t használva mást is használni. Pl. Skype, Linphone stb.

--
Én egy divathupper vagyok. :)

Az ott inkabb gzip -dc az tutibb.
--

()=() Ki oda vagyik,
('Y') hol szall a galamb
C . C elszalasztja a
()_() kincset itt alant.

Nem értem. Ez mi?

--
Én egy divathupper vagyok. :)

man gzip írta:

 -c --stdout --to-stdout
        Write  output on standard output; keep original files unchanged.  If there are several input files, the output consists of a sequence of independently compressed
        members. To obtain better compression, concatenate all input files before compressing them.

Nehany gzip verzio sikolt egyet es kilep, ha nem adsz meg fajlparametert, es nincs -c kapcsolo sem.
--

()=() Ki oda vagyik,
('Y') hol szall a galamb
C . C elszalasztja a
()_() kincset itt alant.

Esküszöm, az ET hangja miatt akarsz gzip-et használni... :)
Így már ok.

--
Én egy divathupper vagyok. :)

Foleg, ha tudnad, hogy nem is jatszok a jatekkal.. :-)
Amugy tenyleg inkabb az archivum kedveert irtam oda, hatha valaki beleszalad ilyen haklis rendszerbe, akkor ne szivjon mar.
--

()=() Ki oda vagyik,
('Y') hol szall a galamb
C . C elszalasztja a
()_() kincset itt alant.

Köszi, amint eljutok oda hogy jatszak is vele, kiprobalom.
Egyszer elinditottam probakepp es akkor tenyleg nem volt hangja

Na működik a hang is, köszi az eddigi segítségeket.

Viszont sokszor amikor be akarok lépni egy szerverre, elkezdi letölteni a különböző pályákat meg ilyesmi és ennél a résznél megakad: pl szép lassan letölti a jaymod/valami.pk3-mat, majd amikor letöltődött, megint elkezdi előröl letölteni ugyanazt a fájlt. és ez megy folyamatosan. 1-2 szerverre viszont be tudok lépni.
Szerintetek mitől lehet ez?

Gondoltam arra, hogy esetleg valami jogosultsági gond lehet(nem tudja írni azt a könyvtárat, ahova mentené a fájlt) de nem találtam meg, hogy hova tölti le ezeket a fájlokat...

Na ezt sikerült megoldanom, jogosultsagi gondok voltak, sudo-val inditottam a telepitot, így az a saját home könyvtáramba is root tulajdonossal tette be a játék könyvtárát.

Már csak egy gondom van, a punkbuster nem akar működni: ha belépek egy online játékba, rögtön kivág a pb, ha pedig host-game-et indítok és bepipálom a punkbuster előtti négyzetet, akkor rögtön kilép a játék...

A grafikus felületen (tehát nem a konfigfájlban) is be lehet állítani. Valami furmány van a programon belül, mert a PB engedélyezési gombján a felirat múltidőben van. Így, ha az ember felületes, akkor Enabled-ről Disabled-re teszi.

--
Én egy divathupper vagyok. :)

Sziasztok!
van egy mafia_1.2-english.run fájlom, és szeretném feltelepíteni a mafiát.
Az sh mafia_1.2-english.run parancsal el tudom indítani a telepítőt, de csak ennyit ír ki, hogy
Verifying archive integrity... All good.
Uncompressing Mafia 1.2-english Installer........................................................
és nyomjam meg az entert az ablak bezárásához. És ha megnyomom akkor be is záródik és kész. Pedig ilyenkor meg kellene jelennie egy másik ablaknak ahol szépen bekéregeti a cd-ket és feltelepíti a játékot.
Opensusen már sikerült valahogy elindítani a telepítőt és ment is a játék, de már elfelejtettem, hogy sikerült felbarkácsolni rá. ha tud valaki nekem segíteni akkor legyen szíves írja le mi a varázsparancs, hogy tudjam telepíteni a játékot?
Köszi

A Mafia mintha nem ET mod lenne. Nem lehetne ezt uj topicban kerdezni?
--

()=() Ki oda vagyik,
('Y') hol szall a galamb
C . C elszalasztja a
()_() kincset itt alant.