Frissítés után behalt a Beryl

 ( amstelveen | 2007. január 28., vasárnap - 18:58 )

Sziasztok!

A napokban felraktam a Berylt (nem hivatalos csomag), hogy kicsit növeljem a felhasználói élményt. Ment is szépen, de ma frissítettem a rendszert és ezután a Beryl indításakor egy nagy fehér pacává változtatja a képernyőt.

Ahogy néztem a listát, volt X frissítés is. Akadt ezzel másnak gondja, vagy egyedi a problémám. Esetleg megoldás?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Fos. Próbáld visszarakni az előző X-et. Vagy berylt, ha megtalálod. Ubuntu?

UHU topikban vagyunk.

Egyébként hogy raktad fel a Berylt? Rakd fel újra ;-)

--
A nyúl egy igazi jellem. Ott ül a fűben, de akkor sem szívja!

Ja, UHU2 :-)

Nemhivatalos UHU csomagból. Az alábbiak szerint (vviktor-tól) módosítottam az xorg.conf-ot:

Section "Device"
Identifier "UHU-Card"
Driver "nvidia"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "HWCursor" "true"
Option "AddARGBGLXVisuals" "true"
Option "DisableGLXRootClipping" "true"
Option "AllowGLXWithComposite" "true"
EndSection

Section "Screen"
Identifier "UHU-Screen"
Device "UHU-Card"
Monitor "UHU-Monitor"
DefaultDepth 24
SubSection "Display"
Option "AddARGBGLXVisuals" "True" (erre szükség van a beryl futtatásához)
…........

Section "Extensions"
Option "Composite" "Enable"
EndSection

Lehet, hogy ebben van a hiba?

Gondolom egy forgatás hozna újdonságot az egyenletbe, mert ugyanazt a csomagot újrarakva valószínűleg ugyanezt kapnám. Ezt szeretném elkerülni, ha van egyszerűbb megoldás.

Azért én az újrarakást megpróbálnám, az xorg.conf-ot meg helyezd biztonságba, hogy ne kelljen mindig gépelni :-)

--
A nyúl egy igazi jellem. Ott ül a fűben, de akkor sem szívja!

Leszedtem, feltettem, a fehér massza makacs. Egyébként -és ez hülyén hangzik- jól működik, mert az ablakokat szépen rendezgeti, csakhogy ezek szürke téglalapok a fehér alapon:-)

Szóval inkább az xorgot kéne visszaállítanom, csak abban nem vagyok biztos,hogy ezt miként kéne. A mostani leszedem, aztán telepítőről felteszem az előzőt? Remélem nem lesznek függőségi gondok.

Nekem az nvidia driverek csinálták ezt. Igaz akkor még nem volt hogyishíjják. Beryl.

Erre nem is gondoltam, pedig lehet ez lesz a megoldás. Kipróbálok egy régebbi drivert.

Ha valamit változtatsz, szerintem érdemes újrarakni az nvidia drivert.
Bár UHUék sokmindent másképp csinálnak. Én ezért nem kezdtem bele. Maradtam Ubinál.
Az első próbálkozásom nekem is fehérséget okozott. De az okát nem tudtam kideríteni.

remelem ti nem szidjatok a vindozt

Ha segítesz megoldani a dolgot, akkor válaszolok neked. Egyébként ez hogy jön ide?

Ez a probléma nálam is jelentkezett, i855GM + AIGLX esetén.

Az én konfigomban az xserver és az opengl közötti protokoll megváltozása volt a ludas. Gentoo alatt a következő megoldotta: >=glproto-1.4.8, >=xorg-server-1.2, >=mesa-6.5.2 telepítése. Fontos, hogy a mesa csomag a friss glproto-t használja. Ha így egyesével nehéz cserélgetni UHU-n akkor a teljes xorg-7.2 újrapakolása + friss beryl (svnből esetleg) segíthet.

ui. nektek sikerült már intel kártyán dualhead-ben dri-t használni? állítólag az újabb i810 driverek tudják a mergedfb-t ami ehhez kell, de nekem nem sikerült elindítani ilyen beállításokkal az xservert.

üdv
hege

Képességeimhez mértem minden lehetőséget végigjátszottam:

- bery leszed-feltesz
- régi nvidia driver
- beryl és barátai forgatás

Szóval úgy tűnik, hogy a régi xorg visszaállítása lenne nyerő, viszont nem tudom hogy álljak neki. Mergpróbáltam leszedni, de egy csomó függőség miatt visszariadtam. Segítenétek?

UPsssz...

Tegnap előtti (28.) frissítés nekem is megölte a berylt ati-n.
De ilyenkor mivel cvs mindig várok 1-2 napot, mert ha 1x ment tuti nem nálam van a hiba. Ma reggelfrissitettem (29.) és láss csodát minden megy a jó öreg t40-esemen...

pch

MEGOLDÁS:

Újra kell telepíteni az nvidia drivert! Ez volt a 23-ik megoldási javaslat és láss csodát, szalad a beryl, mint régen.