Hálózati kártya halála, vagy valami más?

 ( kalmarr | 2019. április 8., hétfő - 11:25 )

Sziasztok,

a serveremnél azt tapasztalom, hogy a Hálózati kártya újra indítja magát.

Apr 8 11:19:58 server kernel: [11990.461104] r8169 0000:03:02.0 eth1: link down
Apr 8 11:20:01 server kernel: [11993.257909] r8169 0000:03:02.0 eth1: link up

Ez mi lehet? Milyen teszteket lenne érdemes lefuttatni, hogy láthassak egy átfogó állapotot a szerveremről?

Üdv.

Kalmi

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Lettek még sajnos újabb hibák a syslog-ban :(


Apr 8 11:24:40 server nmbd[1107]: [2019/04/08 11:24:40.141013, 2] ../source3/lib/interface.c:341(add_interface)
Apr 8 11:24:40 server nmbd[1107]: added interface eth1 ip=192.168.15.5 bcast=192.168.15.255 netmask=255.255.255.0

Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.219631, 1] ../lib/param/loadparm.c:1647(lpcfg_do_global_parameter)
Apr 8 11:25:49 server smbd[8880]: WARNING: The "syslog" option is deprecated
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.219834, 1] ../lib/param/loadparm.c:1647(lpcfg_do_global_parameter)
Apr 8 11:25:49 server smbd[8880]: WARNING: The "syslog" option is deprecated
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.219914, 2] ../source3/param/loadparm.c:2700(lp_do_section)
Apr 8 11:25:49 server smbd[8880]: Processing section "[template]"
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.220269, 1] ../lib/param/loadparm.c:1680(lpcfg_do_service_parameter)
Apr 8 11:25:49 server smbd[8880]: WARNING: The "syslog" option is deprecated
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.220298, 0] ../lib/param/loadparm.c:1686(lpcfg_do_service_parameter)
Apr 8 11:25:49 server smbd[8880]: Global parameter syslog found in service section!
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.220322, 0] ../lib/param/loadparm.c:1686(lpcfg_do_service_parameter)
Apr 8 11:25:49 server smbd[8880]: Global parameter log file found in service section!
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.220446, 2] ../source3/param/loadparm.c:2700(lp_do_section)
Apr 8 11:25:49 server smbd[8880]: Processing section "[kozos]"
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.220639, 2] ../source3/param/loadparm.c:2700(lp_do_section)
Apr 8 11:25:49 server smbd[8880]: Processing section "[server]"
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.220735, 2] ../source3/param/loadparm.c:2700(lp_do_section)
Apr 8 11:25:49 server smbd[8880]: Processing section "[backup]"
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.220809, 2] ../source3/param/loadparm.c:2700(lp_do_section)
Apr 8 11:25:49 server smbd[8880]: Processing section "[scanner]"
Apr 8 11:25:49 server smbd[8880]: [2019/04/08 11:25:49.220935, 2] ../source3/param/loadparm.c:2700(lp_do_section)
Apr 8 11:25:49 server smbd[8880]: Processing section "[apache]"

Ez a szoftver a kontakthiba.
A másik meg a tag hibás lezárása.

Értem is meg nem is :) Tehát ez szoftver vagy valami hardver lesz?
Végeztem egy újra indítást egyenlőre nem lett hiba még.

Hátha így jobban érted: Ez a "szoftver" a kontakthiba. :-)
Magyarázat: A "link down" és "link up" üzenetek megfelelnek a hálózati csatlakozó melletti kis pilács állapotának. Ha bedugod a kábelt, akkor up=világít. Ha kihúzod, akkor down=nem világít. Az állapotot a csatoló érzékeli, és a konkrét megoldástól függően hardver vagy szoftver úton vezérli a fényt. Ha akaratod ellenére jelennek meg az üzenetek, akkor hol bedugottnak, hol meg kihúzottnak tűnik a csatlakozó. Ez általában kontakthibát vagy hibás kábelt jelent.

A többi üzenet meg lényegtelen. Azt látod, hogy nem sikerül az imént "up" állapotúnak tűnő interfészt felkonfigurálni. Mindössze a konfigurálást végző szkript abban a hiszemben fut le, hogy még mindig "up" az állapot, pedig nem is. ;)

A "tag" az az idézett log részletet "bekerítő" code tag, amit elfelejtettél lezárni.

Igen kábel hiba volt...Köszönöm!

Komolyan nem értem, hogy mire gondolsz :)

A "tag" az az idézett log részletet "bekerítő" code tag, amit elfelejtettél lezárni.

Komolyan nem értem, hogy mire gondolsz :)

Ebbe a kommentedbe: kalmarr | 2019. április 8., hétfő - 11:31 https://hup.hu/node/163780#comment-2337137
beleírtál egy <code> taget. A végére meg nem tettél </code> taget, emiatt az összes utána következő komment monospaced fonttal megy - ennek azért csak fel kéne tűnnie...

Bökj rá az "szerkesztés" gombra, és pótold a hiányzó taget, légy szíves!

egyelõre

Lehet hogy abhálózati csatlakozás valahol kontakthibás, esetleg egy switch adapter nem érintkezik rendesen. A többi log bejegyzés csak következménye a link problémádnak.

a legvalószínűbb a kábel kontakthiba. Ha megteheted próbáld ki másik kábellel és úgy is, hogy a másik oldalon lévő aktív eszközön másik portba dugod a kábelt. Így könnyebb leszűkíteni.

Értem köszönöm. A switch is lehet...

Amúgy van valami komplettebb teszt is, amit érdemes lefuttatni a szerveren (minden elemére)?

Nincs. Másik hálózati kábel, másik switch port, másik switch, másik Ethernet kártya, másik szerver. Csökkenő valószínűségi sorrendben.

Ha elég intelligens és modern a switch, és van benne beépített TDR mérő, akkor azzal is meg lehet nézni, hogy látni-e valami problémát a dróton.

Ja, és tényleg zárd már le a legelső kommentedben a le nem zárt code taget pls...

Nehezen hihető, de lehet táp is. Tegyél elé egy villámvédett elosztót (azokban szokott valami csúcs-kiegyenlítés is lenni, nem értek hozzá), vagy próbálkozhatsz táp cserével.

Nekem az otthoni gépemen ez az alaplapi hálókártya (r8169) a bekapcsolás után szórakozik néhány percig (link down, link up). Nem jöttem rá miért csinálja. Aztán pár perc után megnyugszik és onnan stabil a kapcsolat. Bemelegszik v. nem tudom miért. Az első 10 perc áthidalásáért meg végül került bele egy régi wireless kártya is, addig átmenetileg azon keresztül van hálózat.

Lehet hogy próbálkozik egy nem támogatott/nem felépíthető móddal? Próbáld beparaméterezni hogy csak 1 módot reklámozzon és csak ott csatlakozzon, hátha.

A logban az látszik emlékeim szerint, h ipv4-en próbálkozik (, most újabban megjelent ipv6 való próba is, nem értem miért, én ugyan nem konfigoltam át semmit). Szóval látja a kártyát, DHCP-n kér IP-t, kap is IP-t, [ritkán] pár másodpercig még akár net is van, aztán szépen link down. És kezdődik előröl: link up...
És ez ismétlődik kb 2-10 perc közötti időtartamban. Aztán egyszer csak megszűnik a link down, és onnan stabilan működik. Ubuntu van rajta évek óta, különböző verziókban, de a jelenség állandó. Nem tudom milyen módokra gondolsz, ez sima alaplapi vezetékes kártya lenne. Ha statikusan adom meg az IP-t akkor is ez van.