OpenWrt PPPoE nem route-ol?

 ( Dwokfur | 2018. augusztus 27., hétfő - 8:27 )

Nemrég otthon cseréltem a router-t openwrt-sre. DOCSIS hálózat, DHCP-vel kap IP címet, minden pöccre működött. Na jó, némelyik mobiltelefont többször kellett hergelni, hogy elfogadja az új wifit.

Most egy másik helyen cserélném, ahol Digi-s LAN kábel jön be és PPPoE-vel megy a net. A korábbi router-ből kibűvöltem a felhasználó nevet és a jelszavat. LuCi használatával a WAN-t átállítottam DHCP-ről PPPoE-re és megadtam a nevet és a jelszót. A WAN6 interface-t kikapcsoltam.
A kapcsolat létrejön és a router-re bejelentkezve tudok mindent ping-elni, traceroute-olni. Az internet kapcsolat úgy tűnik él. Viszont sem a LAN-on, sem a Wifi-n lévő kliensek nem látnak ki a külső hálózatra. A router-t még tudom ping-elni.
Egyébként a kliensek, amikor megkapják a DHCP-n az IP címüket, akkor a router 192.168.1.1-es IP címét kapják meg, mint gateway-t. Ez rendben is van.

Segítsetek, hogy mit rontok el!
Digi-sek: jól néz ki ez a routing tábla?
Miért nem állítja be automatikusan? Nyilván nem static route-tal kéne megoldani.
Mit nézzek meg? Szívesen bütykölök parancssorból is, vagy grafikus felületen is.

root@router:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd93:e10e:f65d::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option username 'felhasználónév'
        option password 'jelszó'
        option delegate '0'
        option ipv6 '0'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option auto '0'
        option username 'felhasználónév'
        option password 'jelszó'
        option ipv6 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

Routing tábla a kapcsolat felépülése után:

root@router:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.0.0.1        0.0.0.0         UG    0      0        0 pppoe-wan
10.0.0.1        *               255.255.255.255 UH    0      0        0 pppoe-wan
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
root@router:~# ip route list
default via 10.0.0.1 dev pppoe-wan
10.0.0.1 dev pppoe-wan scope link  src 100.74.138.252
192.168.1.0/24 dev br-lan scope link  src 192.168.1.1

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Ha a router kilát, a kliensek meg tudják, hogy az a router, akkor elsőre a tűzfal környékén kaparásznék, de egy kliens oldali traceroute azért még nem árt.

Digi-nél elég régóta van IPv6.
Mi történik ha azt nem kapcsolod ki?

sztem nem NAT-olsz.

+1, ez is lehet gond

Az lehet. Mintha nem lene forwarding. De esküszöm nem kapcsoltam ki.
Nem tiltottam le a NAT-olást. Hogy állítom vissza, ha valamiért nem aktív?
Thx: Dw.

"Jegyezze fel a vádhoz - utasította Metcalf őrnagy a tizedest, aki tudott gyorsírni. - Tiszteletlenül beszélt a feljebbvalójával, amikor nem pofázott közbe."

reset config?

Én a helyedben kezdeném előröl az egészet, így: https://www.youtube.com/watch?v=GVIrpJVebyE Így lesz a tiszta. És persze le is kell frissíteni majd az OpenWRT-t is: https://downloads.openwrt.org/