Disztro játékra Radeon R9 270 kártyával?

 ( ffpp | 2016. október 1., szombat - 9:19 )

Fenti videokártyám van, az opensource driverrel több distro is kifogástalanul működik, viszont a zárt catalyst (crimnson) driver eddig még nem jött össze sehogy. Kérdés: Használ valaki ilyen kártyát sikerrel linux alatt, és ha igen, akkor milyen disztroval/driverrel?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

itt szoktam vasinfó után turkálni, aztán még utánaolvasok más fórumokon is, ... aztán még rágom 1 kicsit mielőtt elkezdem piszkálni ... :
http://www.phoronix.com/scan.php?page=article&item=amd_radeonr9_270x&num=4
//radeonom most 1 ideje ninics//
//intel skylake integrálttal viszont vannak élményeim :) //
_____________________
www.pingvinpasztor.hu

Szerintem hagyjad a catalyst-ot. Ugyanilyen kártyával open source drivert használva legtöbb játék megy (4.1-es opengl kompatibilis a jelenlegi 12.0.3-as mesa). Október végén jön a 12.1-es kiadás, amely már 4.3-as szinten biztosan, 4.5-össel pedig lehet, hogy kompatibilis lesz. Vulkan is egyelőre úgy néz ki, hogy benne lesz, szóval erre az 1 hónapra már minek szenvedni closed source driverrel. Amúgy ez az amdgpu pro nevezetű csoda is nemsokára elkészül úgy, hogy GCN 1.0-as kártyákkal is kompatilibs lesz, akkor meg ha nagyon ragaszkodsz a closed source driverhez, fogok tudni használni elméletileg mindenféle szenvedés nélkül.

Teljesen igaza van hagának. Sapphire Radeon R9 270-es kártyám van nekem is, Metro 2033 Redux, valamint Brutal Legend tuti megy opensource driverrel (most próbáltam).

A zárt driverrel (az utolsó tavaly decemberi) az is probléma, hogy csak régebbi xorg-servereket támogat. Tény és való, hogy minimálisan jobb teljesítmény érhető el zárt driverrel, de nem ér annyit az egész.

Csak a játkékok játszhatósága érdekel, nincs semmi okom a zártat használni. Viszont a radeonnal a HotS pl meg se mukkan. (Steam jó). Lehet, hogy wine-vonalon kell keresnem a bajt...

jAzz

battle.net sehogy se jön össze nekem bárhogy és bármilyen disztoval is próbálom...

jAzz

Playonlinux-szal probald felrakni. Anno olyan fel eve ment teljesen jol.

Mondom: sehogy se sikerül :(

de még tippem sincs, hogy mi lehet a baj...

http://pastebin.com/UkAXH1GD

jAzz

Nem mindegy, melyik wine verziót használod. A playonlinux-ban tudsz válogatni.

Fedora-val, és a 7100 Battle.net-el müxik jól.

A 8098-as nekem is ue. a hibát generálja.

--
RGeri77
Fedora Ambassador, játékmester ;-)

Jííííhhááááá!

Amit tettem az ügy érdekében:
Ha már kijött, Sabayon 16.11 clean install.
wine, winetricks install

Ezek után WineHQ alapján:
winetricks corefonts
Open Wine Configuration Editor (winecfg)
Applications tab: Windows Version: Windows XP
Libraries tab: Add msvcp140 (native, builtin)

battle.net app letölt, install. Ez elszállt a "szokásos" hibával. Sebaj, töröltem a battle.net.8098 mappát, majd örültem.

Opensource vidikártyadriver.

jAzz

Ha laggolna: wine regedit, HKEY_CURRENT_USER\Software\Wine, jobb egérgomb, új kulcs: Direct3D, jobb gomb, új karakterlánc: VideoMemorySize, és itt add meg a videokártyád memóriáját.