MikroTik - Dynamic DNS + BIND9 Szerver

 ( littlet | 2015. május 24., vasárnap - 2:47 )

Üdvözlet Mindenkinek!

Szeretnék létrehozni magamnak egy dinamikus DNS szolgáltatást, melyet MikroTik router-ek alatt használnék. A következő oldalból indultam ki: http://wiki.mikrotik.com/wiki/Manual:Tools/Dynamic_DNS

A kérdésem az, hogy van valaki, aki használta már a MikroTik ezen szolgáltatását? A leírás ugyanis eléggé hiányos. Nem lehet belőle megtudni, hogy ütemezve kell-e futtatni a parancsot, vagy a rendszer azt elintézi magának, illetve azt sem lehet tudni, hogy honnan tudja a program, hogy melyik interface IP címét monitorozza. Van itt a körünkben olyan, aki meg tudja válaszolni ezeket a kérdéseket?

Segítségeteket előre is köszönöm!

Üdv: t!

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Minek? Mikrotiknek van saját ddns kliense.
http://wiki.mikrotik.com/wiki/Manual:IP/Cloud

Tudom, de az csak a saját címeit osztja.

Arra gondolsz hogy a Mikrotik doménjén regisztrálja?
CNAME bejegyzéssel magadévá teheted
bind-ben:
sajatneve CNAME 268xxxxxxxx.sn.mynetname.net.

Pontosan. Plusz minek használnék olyat, ami nem a sajátom, ha egyszer csinálhatok is magamnak.

Ha neked ezt megéri...

Szeretek nem függeni senkitől sem.

En ezt haszanalom, 15 percenkent utemezetten lefut:
A pppoe-out1 az interface amin kilat a netre.


##############Script Settings##################
:local NOIPDomain ".. cimed ide .no-ip.org"
:local NOIPUser "..user ide.."
:local NOIPPass "..password ide.."
:local WANInter "pppoe-out1"
###############################################

:local IpCurrent [/ip address get [find interface=$WANInter] address];
:for i from=( [:len $IpCurrent] - 1) to=0 do={
:if ( [:pick $IpCurrent $i] = "/") do={
:local NewIP [:pick $IpCurrent 0 $i];
:if ([:resolve $NOIPDomain] != $NewIP) do={
/tool fetch mode=http user=$NOIPUser password=$NOIPPass url="http://dynupdate.no-ip.com/nic/update\3Fhostname=$NOIPDomain&myip=$NewIP" keep-result=no
:log info "NO-IP Update: $NOIPDomain - $NewIP"
}
}
}

Ez nem frissít BIND-et.

Ha ezt magad akarod csinálni, akkor gondolom nem okoz nehézséget a scriptben szereplő URL átírása:
http://dynupdate.no-ip.com/nic/update\3Fhostname=$NOIPDomain&myip=$NewIP
Ahol a domain a te domained, az elérési útvonal pedig egy általad megír php, ami paraméterben megkapja az IP címedet, így a php befrissíti bindben, jobb esetben mysql-backend NS-ben.

Nem átírni lenne nehéz, hanem felesleges lenne.

Szándékosan adsz pongyola válaszokat a segítő közönségnek?
Miért lenne felesleges? Magad írtad, hogy nem akarsz függeni senkitől, magad akarod megcsinálni házon belül. Ennek egyik módja amit javasoltam neked fentebb.

Elnézést, nem úgy értettem. Természetesen a válaszod korrekt, azonban nem egy egyszerű DDNS szervert akarok meghívni - ahol erre szükség van -, hanem a BIND-et TSIG-el vezérelni, ahol ez értelmezhetetlen megoldás.

pl: http://www.semicomplete.com/articles/dynamic-dns-with-dhcp/

google://bind dynamic dns update

--
A vegtelen ciklus is vegeter egyszer, csak kelloen eros hardver kell hozza!

Ez ugyan nem rossz iromány, csak nem válasz a kérdésre.

Mivel egyre több esetben NAT-olt IP-t kapnak a végpontok, ezért jobban szeretem VPN-be rendezni őket.
Mindegyik eszköz saját belső IP-t kap, amin keresztül garantáltan elérem őket menedzselés céljából. Esetleg ez nálad nem alternatíva?

Jelen esetben nem.

A linkben ott a válasz...
Ez egy statikus dolog, ha egyszer lefuttatod 1x megcsinálja...
Sehonnan sem tudja, hogy mit kell monitorozni, ez egy statikus dolog... Amit beírsz neki azt fogja megcsinálni.

Sajnos nekem a statikus dolog nem volt tiszta 100%-ig, ezért kérdeztem. Melyik rész utal erre pontosan? A kérdés pedig ettől függetlenül még mindig adott, honnan tudja, hogy mit monitorozzon?

Szerintem (még nem láttam MikroTik-et) bele kell rakni a fenti scriptbe.

Ezt a sorát:

/tool fetch mode=http user=$NOIPUser password=$NOIPPass 
url="http://dynupdate.no-ip.com/nic/update\3Fhostname=$NOIPDomain&myip=$NewIP" keep-result=no

cserélném valami hasonlóra:

/tool dns-update dns-server=23.34.45.56 name=mydomain 
zone=myzone.com address=$NewIP key-name=dns-update-key key=update

De googleztam egyet, itt van egy kombo.

Az a rész utal erre, hogy nincs benne, hogy ez egy script. A RouterOS nem fog magától állítgatni ilyeneket... (és ütemezni sem)
Ugyanazt mondom: sehonnan sem tudja, hogy mit monitorozzon, ezt neked kell megoldani, lásd korábbi hozzászólások.

Általában ezek úgy működnek, hogy névvel, jelszóval elmész egy URL-re, ott az oldal megnézi, hogy milyen IP-ről jöttél (publikus IP látszik), és azt jegyzi be.
Ehhez nem kell semmilyen varázslat. Amit kidob a http://whatismyipaddress.com/ oldal, azt látja minden más is.