[megoldva] mikrotik L2TP ipsec 3G-ről nem megy

 ( wrie | 2014. március 2., vasárnap - 20:58 )

Na akkor új szálat indítok, mert a másikban nagyon elveszett a kérdés.

Szóval be kéne állítanom egy vpn-t egy mikrotik RB2011UAS-2HnD (5.25 OS) routeren.
L2TP-t választottam az összes lehetőséget figyelembe véve, így maradnék is ennél.
A vpn alapvetően működik NAT mögött ülő gépek esetén. Viszont 3G-s modemmel nem. Sem androidos telefonon, sem usb stick-es nettel.

A config a szokásos:

/interface l2tp-server server
set authentication=pap,chap,mschap1,mschap2 default-profile=default-encryption enabled=yes keepalive-timeout=30 max-mru=1460 max-mtu=1460 disabled

/ip ipsec peer
add address=0.0.0.0/0 auth-method=pre-shared-key dh-group=modp1024 disabled=no dpd-interval=2m dpd-maximum-failures=5 enc-algorithm=3des exchange-mode=\
main-l2tp generate-policy=yes hash-algorithm=sha1 lifetime=1d my-id-user-fqdn="" nat-traversal=yes port=500 secret=xxxxxxxx send-initial-contact=yes

/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha1 disabled=no enc-algorithms=3des,aes-256 lifetime=30m name=default pfs-group=none

/ppp profile
...
set 1 change-tcp-mss=yes dns-server=8.8.8.8 local-address=10.10.10.1 name=default-encryption only-one=default remote-address=vpn-pool use-compression=default \
use-encryption=yes use-mpls=default use-vj-compression=default

/ppp secret
add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=username password=123456789 profile=default-encryption routes="" service=any

/ip firewall filter
...
add action=log chain=input disabled=no dst-port=500,1701,4500 log-prefix="" protocol=udp

add action=accept chain=input connection-state=new disabled=no dst-port=500,1701,4500 in-interface=ether1-gateway protocol=udp

A log-ban idáig jut a 3G-s kapcsolat:
firewall,info input: in:ether1-gateway out:(none), src-mac 00:xx:xx:xx:xx:xx, proto UDP, xxx.xxx.xxx.xxx:500->xxx.xxx.xxx.xxx:500, len 380

Próbáltam a nat traversal-lal operálni, de nem hozott semmi változást.
Merre induljak el?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

up

Androidios telefonon WiFi mellett mukodik?

Egyebkent... "NAT mögött ülő képek esetén" - es NAT mogott ulo VIDEOK eseten? :D
--
Ki oda vagyik, hol szall a galamb, elszalasztja a kincset itt alant.

Igen wifis kapcsolatnál azonnal csatlakozik.
De sajnos a videok ilyenkor kissé szaggatnak :-)
Javítom, thx.

Ugye nem T-s 3G?

Két T-ssel próbáltam. Eddig.

Helló

Nekünk telenornál volt hasonló probléma, ott az adattömörítés miatt nem ment, RB látta a kapcsolódási kisérletet, majd apn csere majd lőn öröm bodottág...

Üdv

Balooo

------------------------

Nincs a világon se jó, se rossz. A gondolkodás teszi azzá... (W. Shakespeare)

20-as körzetből meg a vpn.
Tudok valamit tenni, hogy a T-től is működjön?

Kérsz fix IP-t sok pízért. És így kapsz dedikált APN-t is.

Ez persze nem járható út.
Átállítottam az apn-t wap-ra, azon megy. Csak lassabb...

Úgy tűnik a wnw nevű apn jó lesz nekünk. Azon megy a vpn és a tempó is egész jó.