Brother DCP-115C

 ( Winember | 2007. október 20., szombat - 19:57 )

Üdv.

Nemrégi hír, hogy már a Brother is törődik a Linux felhasználókkal. Ennek értelmében meg is látogattam a weben a tárgybeli multifunkciós készülék "ügyében" őket és letöltöttem a Brother által ajánlott driver rpm csomagját ami simán fel is ment a SuSE 10.3 alá. Mindemellett amit szerény angol tudásommal kivettem a Brother weblapján azt is elvégeztem, vagyis létrehoztam a szükséges szimbólikus linket, de sajnos a nyomtatás még nem működik. A Yast-tal sem sikerült beállítani a CUPS-ot, sem a driver telepítés előtt, sem utánna pedig próbálgattam a hasonló típusszámú készülékeket is.

Kiküldi a tesztet és semmilyen hibaüzenet nem jön.
?

Ki érti ezt?

Ehhez szeretnék segítséget kérni, ugyanis egy új Linuxuseré a tárgybeli készülék és ha sikerülne beállítani,akkor a másolt expert rendszertől elköszönnének végleg. Tehát fontos lenne...

Köszi előre is a segítséget.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Végtére az is segítség lenne, ha valaki megnézné a
http://solutions.brother.com-on a Brother DCP-115C hez ajánlott drivert, vagyis azt, hogy milyen egyébb műveletek kellenek az rpm csomag telepítése után.

És ezt lefordítaná magyarra, és hozzászólásként be copy-zná ide (lévén nem sok szövegről van szó), hátha csak én ügyetlenkedtem el valamit és azért nem megy.

Köszi.

Nem nekem segítene valaki aki mindezt megteszi, hanem egy új Linuxosnak!
Máskülönben talán még újratelepítik az XP-t, mondván: "Nyomtatni pedig kell"

Tehát még mindíg keresem a választ: vajon miért nem működik a nyomtatás a Brother DCP-115C -nél, amikor a hozzá ajánlott rpm csomag telepítve és a Yast-tal próbáltuk beállítani a nyomtatást, s atesznyomtatásnál kiküldi a nyomtatási parancsot, de nem nyomtat és hibaüzenet sem jön.

Nekem is ilyen nyomtatóm van két hete.
Megpróbálok segíteni.

Először azt kellene megnézni hogy a /dev/usb/lp0 létrejött e és írható e.

http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/lpr_others/MFC210Clpr-1.0.2-1.i386.rpm
http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/cups_wrapper/cupswrapperMFC210C-1.0.0-1.i386.rpm
Konkrétan ezek a driverek kellenek és a lpd drivert kell először felrakni.

magic írta:
Nekem is ilyen nyomtatóm van két hete.
Megpróbálok segíteni.
...

Kössz szépen :-)

Most látom, hogy én csak a felső rpm csomagot töltöttem csak le (MFC210Clpr-1.0.2-1.i386.rpm) és ez még kevés.

Sajnos a CUPS van fent az OpenSuSE 10.3-mon és igazából nem sikerült "összebarátkoznunk" anno a saját SuSE 10.0 esemnél a HP 1015-el is megizzadtam mire sikerült "szóra bírni" a CUPS-ot, mert a Yast-tal nem mentem semmire...

Remélem a Brother könnyebben megy majd.

Köszi a segítséget.

magic írta:

Először azt kellene megnézni hogy a /dev/usb/lp0 létrejött e és írható e.

O.K.
Ma jutok oda, hogy ezt megnézzem. Tegyük fel, hogy megvan.
_______________________

Mondjuk feltettem a 2 rpm csomagot is...
_______________________

magic írta:
Konkrétan ezek a driverek kellenek és a lpd drivert kell először felrakni.

Eddig rendben, de még ezek után milyen beállítás szükséges, vagy hogyan kell csinálni?
_______________________

magic írta:
... és a lpd drivert kell először felrakni.

Mire gondolsz pontosan? Még egy külön lpd....rpm csomagra?

köszi előre is

magic írta:

Először azt kellene megnézni hogy a /dev/usb/lp0 létrejött e és írható e.

___________________________________________________

Megnéztem a /dev/usb/lp0-t és megvan, de nem volt írható a "other"-nek. És írhatóvá tettem.

Szerintem itt lehet valami "bibi", vagyis arra gondolok, hogy a felhasználónak benne kellene esetleg lenni a "printer" (vagy hasonló) csoportban.
De lehet, hogy tévedek.
Sajnos működő beállítás nincs a birtokomban, hogy megnézzem.
Tehát a /dev/usb/lp0 rendben van.

___________________________________________________

Feltettem mindkét rpm csomagot. A /cupswrapperMFC210C-1.0.0-1.i386.rpm-t másodjára. Bár hiányolta a csh-t annak ellenére, hogy a /bin alatt van egy cshlink amely a /bin/tcsh-ra mutat.
Ugyebár a cupswrapperMFC210C-1.0.0-1.i386.rpm csomagban egy shellscript van aminek a csh kell.
(nem tudom a bash miért nem jó neki?)

Amikor a cupswrapperMFC210C-1.0.0-1.i386.rpm csomagot feltettem, akkor a cups újraindult és a Yast elindítása után jelezte, hogy a nyomtató adatbázis megváltozott. Mostmár két nyomtatót is jelez a Yast.
A probléma csak az hogy egyik beállítás, vagyis nyomtató sem nyomtat és hibaüzenet sincs.

Az egyik az MFC210C a /dev/usb/lp0-on
A másik a Brother DCP115C, de ez "Not configured"

A Brother weboldala szerint az MFC210-nek működnie kellene pedig.

A "vicc" az, hogy mégcsak hibaüzenetet sem ad sem az OpenOffice.org, sem a cups, pedig a (SuSE szokásához híven) a tty10-es konzolra ki kellene írnia a hibát.
Legalábbis az általam használt régebbi SuSE verziónál ez így működik.

magic írta:
Konkrétan ezek a driverek kellenek és a lpd drivert kell először felrakni.

___________________________________________________

Tehát minden fentvan és mégsem megy :(

Jó lenne még ma némi segítség hátha elakadok.
:(

Először ezt kell.
http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/lpr_others/MFC210Clpr-1.0.2-1.i386.rpm
Ha fell vannak rakva vagy előtte is lehet, fel kell venni egy usb nyoltatót és újraundítani a cupsot.
Legalábbis slackware alatt ennyi volt.

magic írta:

Először ezt kell.
http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/lpr_others/MFC210Clpr-1.0.2-1.i386.rpm
Ha fell vannak rakva vagy előtte is lehet, fel kell venni egy usb nyoltatót és újraundítani a cupsot.
Legalábbis slackware alatt ennyi volt.

Köszi az infót :-)

Ha pontosan emlékszem, akkor az OpenSuSE 10.3-ra ezt a csomagot telepítettem: MFC210Clpr-1.0.2-1.i386.rpm

És utánna a Yast-tal próbáltam beállítani. Csak némiképp hasonló Brother nyomtató volt a menüben. Persze ez is USB-s volt. Sajnos nem sikerült első nekifutásra (a topic nyitás előtt) nyomtatni ezen a módon, de nem adtam fel.

Lehet, hogy nekem is Slackware-t kellene telepíteni, hogy működjön?
:-D

Nem tudom hogy ez müködik e OpenSuSE alat.
A cupsnak van egy webes interface ezt http://localhost:631 böngészőbe írásával lehet elérni.
itt is érdemes lehet próbálkozni.
Most még melóban vagyok.
Olyan 20:00 körül érek haza remélem akkor tudok további infóval szolgálni.

magic írta:
Nem tudom hogy ez müködik e OpenSuSE alat.
A cupsnak van egy webes interface ezt http://localhost:631 böngészőbe írásával lehet elérni.
itt is érdemes lehet próbálkozni.
Most még melóban vagyok.
Olyan 20:00 körül érek haza remélem akkor tudok további infóval szolgálni.

Köszi.

Látod a localhost:631 nekem is eszembe jutott, ugyanis a SuSE 10.0 alatt sehogysem sikerült a saját nyomtatómat, egy HP1015-öst beállítani kb. másfél éve. Ekkor a SuSE Magyar levlistán valaki adott egy tippet. És ez a localhost:631 volt.

Csak az a baj, hogy a 60 szavas angol tudásommal itt semmire sem megyek.

Csakhát, megvallom a HP1015-öt ezzel sem sikerült beállítani, ám a kitartásom meghozta a gyümölcsét :-D
Ugyanis a "saját módszeremmel" végül beállítottam.
Hogy mi volt ez? Egyszerű, ugyanis a régebbi (asszem 9.3-as) SuSE Linux alatt simán (már a telepítéskor) nyomtatott a HP1015 Laserjet (ami mellesleg a SuSE 5.3-mal is nyomtat) ugyanis ismeri a PCL5-ös nyomtatónyelvet.
Ebből is látni, hogy nem érdemes túl olcsó nyomtatót venni ami esetenként le van butítva.

Visszatérve a CUPS-ra: nekem gyanús az az, hogy az én SuSE 10.0-ásomnál fut az LPD is és itt csak a CUPS fut.

Még azt is kipróbáltam (ami az lpd-nél működött ANNO), hogy rootként kiadtam az alábbi parancsot.

echo "HELLO WORLD" >/dev/usb/lp0

És semmi!

Már ott tartok a localhost:631-gyel próbálkozva, hogy:

MFC210C (Default Printer) "Printer not connected; will retry in 30 seconds..."

Pedig a beállítások alapján működnie kellene elvben.
A beállítások ezek:
---------------------
Description: MFC210C
Location:
Make and Model: Brother MFC-210C CUPS v1.1
Printer State: processing, accepting jobs, published.
Device URI: usb:/dev/usb/lp0

-------------------------------------------------------

Aztán rootként elindítottam egy konquerort és itt kiadtam a localhost:631 parancsot

És az alábbi üzenet jött:

MFC210C (Default Printer) "/usr/lib/cups/filter/brlpdwrapperMFC210C failed"

És belenéztem a scriptbe és az első sor elgondolkoztat.
Ami ez: /bin/csh
Ugye itt van egy szimbólikus link ami a tcsh-ra mutat és nem vagyok benne biztos, hogy lefut rendesen a script.Mármint a /usr/lib/cups/filter/brlpdwrapperMFC210C Pedig próbáltam kézzel is futtatni és nem volt hibaüzenet. Szóval egyre inkább nem értem.

Ez nállam is a tcsh ra mutat a symlink.

Én még korábban a régi nyomtatóm miatt canonc bjc 1000, kiürítettem a nyomtató driverek mappáját. Ez az állapot még a brother driverének installálásakor is fellált.
A driverek a /usr/share/cups/model mappában vannak.

A nyomtató nem volt bedugva a csomagok installálása előtt közben.

Itt kis magyar infó http://frugalware.org/docs/printing.html

Nállam valamelyik csomagnál azt hiszem az elsőnél visított hogy nem tud létrehozni egy mappát azt már nem tom melyik volt.
Vagy a /var/spool/cups vagy a /var/spool/ldp.
Ezt utólag megcsináltam neki.

Még egy megjegyzés nállam nincs mindíg bedugva a nyomtató, rövid az usb kábelem. Nállad ez hogy van?

magic írta:
Ez nállam is a tcsh ra mutat a symlink.

Én még korábban a régi nyomtatóm miatt canonc bjc 1000, kiürítettem a nyomtató driverek mappáját. Ez az állapot még a brother driverének installálásakor is fellált.
A driverek a /usr/share/cups/model mappában vannak.

Köszi.
Addíg "nyomoztam" a beállításoknál (conf fájlok, stb.) és a wrapper scriptben, hogy az /usr/share/cups/model könyvtárig is eljutottam, sőt amennyire tudtam (értettem)végignyálaztam a "reklamált" scriptet ami a csh-t igényli, hogy mit csinál, és látszólag jól lefut.

magic írta:
A nyomtató nem volt bedugva a csomagok installálása előtt közben.

Esetemben igen.

magic írta:
Itt kis magyar infó http://frugalware.org/docs/printing.html

Köszi.
Én is találtam ezt-azt, de még nem sikerült ennek ellenére.

magic írta:
Nállam valamelyik csomagnál azt hiszem az elsőnél visított hogy nem tud létrehozni egy mappát azt már nem tom melyik volt.
Vagy a /var/spool/cups vagy a /var/spool/ldp.
Ezt utólag megcsináltam neki.

Lehet, hogy itt is az lesz.
Nálam az opera böngésző "játszott" ilyet, ti. nem indult ha az "user" indította, mert az egyik alkönyvtárról hiányzott az "x" az "others"-nél.

magic írta:
Még egy megjegyzés nállam nincs mindíg bedugva a nyomtató, rövid az usb kábelem. Nállad ez hogy van?

Sajnos nem nálam van hanem én is segédkezem másnak, de ott mindíg be van dugva.

Már-már a window$ telepítés került szóba...
Ha lehet elkerülném.

Köszi az eddigi segítséget.
Még próbálkozom.

Érdekes, hogy az egyik német fórumban is --force és --nodeps-el tették fel a "csh"-t igénylő csomagot.
Rejtély, hogy az rpm miért reklamálja amikor ott a szimbólikus link.

Nemrég összefutottam én is ezzel a típussal és bizony a SuSE alatt nem sikerült szóra (...) izé, nyomtatásra bírni.

Működik egyáltalán valakinek SuSE alatt?