logitech webkamera && linux-2.6.22.3 && gspcav1 driver [megoldva]

 ( wowbagger | 2007. augusztus 22., szerda - 18:24 )

Kedves Fórumozók!

Adott egy Logitech QuickCam for Notebooks Deluxe, amit a projekt oldala szerint képes meghajtani a gspcav1 meghajtócsomag.
A gépen egy 12-es Slackware lakik 2.6.22.3-as kernellel. Sajnos a driverhez nem nagyon mellékeltek használható readme-t, úgyhogy a make paranccsal próbálkoztam. A buildelés sajnos nem sikerült, a prijekt szájtján pedig nem nagyon találtam FAQ-ot, vagy troubleshooting infókat, úgyhogy tulajdonképpen megállt a tudomány...
A driver a legfrissebb 20070508-as változat.
Ha valakinek van tapasztalata, adjon ötletet, hogy mit csinálok rosszul, és mit csináljak másként...

Előre is köszi.
Üdv:
János

PS: A buildelés hibaüzeneteiből elég sok van, a legtöbb deklarálatlan állandókra, nem teljes típusleírásokra és a sizeof érvénytelen használatára vonatkozik. Ebből arra következtetek hogy valamit nem talál a fordítás során a kis drága.
A hibaüzenetek a "gspca_core.c" fájlnál kezdődtek.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Esetleg tudna valaki segíteni?
Az is elég lenne, ha valaki, akinek ugyanilyen kernele van, megpróbálná leforgatni magának, csak hogy kiderüljön, hogy hol lehet a gond.
Az a gyanúm, hogy ha nem én rontottam el valamit, akkor valószínűleg a meghajtóprogramnak túl új a kernelem.
Valaki esetleg?
__________________________________________________________
Az életben csak egy dolog a szép, de az épp nem jut eszembe.

Nekem gentoo-n lefordul portage-bol.

Akkor szerencsés vagy.
De ugye 2.6.22.X-es kernellel, és a májusi gspcav1-gyel?
Nem tudom, igazán rakhattak volna mellé leírást.
Nem tudom mit ronthattam el...
A make-nek nem adtam volna megfelelő paramétereket?
A kernelem az /usr/src/linux alá van symlinkelve, a könyvtár is az /usr/src-ben van.
Azt elvileg megtalálja a makefile.
Nem tudom mi lehet a gond.
Errorlog itt.
__________________________________________________________
Az életben csak egy dolog a szép, de az épp nem jut eszembe.

Valakinek ötlete/tapasztalata?
__________________________________________________________
Az életben csak egy dolog a szép, de az épp nem jut eszembe.

Kernelben van video4linux tamogatas? Ha nincs akkor itt talalod:
Device Drivers -> Multimedia devices -> Enable Video For Linux API 1 (DEPRECATED)
En ugy vettem eszre, hogy a compatibility layer nem jo neki. Hasonlo webcam-em van, ugyan ezzel a driverrel amivel probalkozol, viszont en is gentoo-n hasznalom, nem probaltam mas disztron.
Remelem segitettem.

Oh, pont erre volt szükségem. Köszönöm a segítséget. :D
__________________________________________________________
Az életben csak egy dolog a szép, de az épp nem jut eszembe.