Lexmark X1100 Series szkennelési gondok...

 ( marhasok | 2006. május 28., vasárnap - 17:08 )

Sziasztok!

Vettem egy Lexmark X1190-es multifunkciós nyomtatót és szkennert. A nyomtató részével nincs gond, de a szkenner elég furcsa dolgokat művel. (például azt, hogy Linux alatt nem működik) :)
Root-ként nem ismeri fel a "scanimage -L", viszont a "sane-find-scanner" megtalálja itt: "libusb:002:003"
Felhasználóként felismeri a "scanimage -L" is "lexmark:libusb:002:003 Lexmark X1100 flatbed scanner"-nek. A "scanimage -d lexmark:libusb:002:003 >proba"-ra csinál is valamit a szkenner egyszer (hangot ad, talán szkennel?), aztán nem történik semmi sem. Ha bezárom CTRL+C-vel akkor a következő újraindításig semmit sem csinál ugyanerre a parancsra. Az xsane, xscanimage nem ismeri fel, csak a TV tuner-t. Mi lehet a baj?

Köszi előre is a segítséget, üdv:
marhasok

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Nem, most már megcsinálja a képet, csak csíkos (néha üres), de továbbra is csak a scanimage -L -re csinál valamit...

El tudnád mondani mit tettél, hogy "most már megcsinálja a képet" állapotot elérd?

Én is egy X1180 -al küzdök, de éles kerregő hangon kívül semmit sem produkál. Mintha rossz irányba akana elindulni szegény.

Egyébként a debian sarge-ban lévő libsane (1.0.15-9) nem ismeri a lexmark backend-et.

A http://people.debian.org/~aurel32/sane.html oldalon találtam Sagre-os csomagokat.

Az itt lévő libsane1.0.17-ben van sane-lexmark backend ami "base" státuszú támogatást ígér az X1180-hoz.

Az upgrade után a scanimage -L is felismerte név szerint a scannert.
A frissített xsane is tud róla, de használat közben néha segfault... :(

Nekem a scanimage -L, sane-find-scanner, lsusb is mutatja az eszközt, root, user esetben is.

Hogy állítottad az usb eszköz hozzáférési jogokat, hogy ilyen eltérő módon látod őket?

Én találtam valamiféle drivert, de még nem tudtam működésre bírni nem értem hogy mit kell vele csinálni, van leírás hozzá de vagy én fordítok félre valamit vagy logikátlan, mert úgy nem megy.
A Driver itt:
http://ftp.opentle.org/pub/downloads/linux/drivers/printers/lexmark/lm1100/lm1100.1.0.2a.tar.gz

Ha jutott valaki eredményre jelezhetné.