php-8.1.1: már majdnem megijedtem

hogy esetleg gond nélkül működni fog a 8.0.10 helyett/után. Azért szerencsére nem így történt.


php --version
PHP Warning:  PHP Startup: GlobusPni: Unable to initialize module
Module compiled with module API=20200930
PHP    compiled with module API=20210902
These options need to match
 in Unknown on line 0

Szóval legalább a felhasználói bővítményeket újra kell fordítani, ha kis szerencsém van, ebbe a lépésbe még belepusztulhat a folyamat.

Hozzászólások

ez nagyon durva, a 8-as php-val forditott modul nem megy 8.1 alatt? elképesztő micsoda böszmeség ez, fel kéne égetni az egész php-t!!!!!444235+

Szar ez a mostani helyzet. Alig várom, hogy mindenhol 8.1.x-re átállhassak. Szerencsére az Ubuntu 22.04 már ezt hozza.

Most a dev gépemen 8.1 van, de a composert így futtatom: php8.0 /usr/bin/composer install

miért? komolyan kérdem.

nálam 7.0, 7.1, 7.4, 8.0 és 8.1 is fut. gyosan váltok alternative-ok között, ahogy a composer 1.x és 2.x-ese között is. kb ez a legkevesebb, ami kell a projetket váltása közben

kicsit jobban zavart, hogy pár php-cs-fixer szabály nem működött az elején (argumentumban a & köré mindig space-et akart tenni), de már az is megy

4 és fél éve csak vim-et használok. elsősorban azért, mert még nem jöttem rá, hogy kell kilépni belőle.

Szerkesztve: 2022. 01. 05., sze – 17:01

Ha már a Linuxon csalódnom kellett a PHP-ban, átmentem AIX-ra, ott azért akadt egy kis jóság:
Zend/asm/make_ppc32_sysv_xcoff_gas.S nevű fájl fordítása során:

/tmp//cc403y7g.s: line 14: 1252-191 Only .llong should be used for relocatable expressions.

Bár az is igaz, hogy egy számmal boldogabb lennék, ha az ugyanott elterülő make_ppc64_sysv_xcoff_gas.S fájlt próbálná fordítani.

Szerk: van egy gyanúsított:

/usr/bin/uname -p
powerpc

Ha ez azt mondaná, hogy powerpc64, akkor a Php is a 64-bites fájlt venné elő.

Szerk: ez lett a rendkívül tudományos megoldás:

export ac_cv_host=powerpc64-ibm-aix6.1.0.0
./configure ...
Szerkesztve: 2022. 01. 05., sze – 17:10

Végül itt tartunk, nem is olyan rossz:

$ apachectl status
Server Version: Apache/2.4.52 (Unix) PHP/8.1.1 mod_jk/1.2.48 OpenSSL/3.0.1
Szerkesztve: 2022. 01. 05., sze – 18:41

Module compiled with module API=20200930
PHP compiled with module API=20210902

nem a php a hulye....

A vegtelen ciklus is vegeter egyszer, csak kelloen eros hardver kell hozza!

Szerkesztve: 2022. 01. 05., sze – 20:26

Bónusz változás: eddig ez volt:

libtool --mode=compile --tag=CC cc ...

Most már sokkal jobb:

libtool --mode=compile --tag CC cc ...

Így legalább a házibarkács libtool-ban is találtam egy kis javítani valót: kimaradt a jelzőbit a `--tag`-nál, hogy ha nincs benne `=érték` rész, akkor a következő paramétert kell vennie értéknek.

Mármint előre elkészített binárist? Ki venné a fáradtságot, hogy pont olyan PHP-t faragjon, amilyen nekem kell? De sőt, az php/oci8/powerpc64 kombináció egyáltalán nem is működik anélkül a patch nélkül, amit sk. gányoltam öt éve, és egyelőre nem jutott be a hivatalos source-be.