Mikrotik LED állapot

Adott egy Mikrotik hEX S router. Szükség lenne a tulajnak látni az ether1-en (ahová jön a net), hogy "van-e net" (sűrűn akadozik)

Következő lépés failover mobil USB sticken... (distance=2, remélem)

Ezt csinálnám:

/system leds set [find where leds="led1"] type=interface-status

Jó így?

Hozzászólások

en ezt csak a gui-n allitottam be eddig, de ez nem fogja mutatni, hogy van e /nincs e net, inkabb van e bedugva kabel/nincs bedugva kabel

Semmilyen, ez nem annyira egzakt, ha esetleg pppoe a kapcsolat akkor annak a statuszat tudod kijelezni, de ha dhcp akkor kb eselytelen, a legeselyesebb egy alkalmazas egy szerveren ami folyamatosan pingel valamit ami off-prem, de ez is adhat fals pozitivat ha esetleg az lehal vagy fals negativat ha esetleg “a net” lehal de az a szerver elérhető, mert pl ugyanaz a szolgaltato.

én saját infrastrukturaban ugy oldottam meg, hogy a NASom dns cimet monitorozom FreshPing-en, mobilon mobilneten meg megkapom az ertesitest meg a logokat is hetente

https://www.freshworks.com/website-monitoring/

Szerkesztve: 2020. 06. 01., h - 18:34

Hogy tudod-e kapcsolni a ledet, és hogy melyiket az itt kiderül (ez tikenként változik, hex-en csak a user ledet tudom, de az ahogy látom hex s-en nincs):

/system leds
add leds=user-led type=on

Na ha meg van az egy világitó leded, akkor a van net kérdésre (= van 8.8.8.8), van eszköz

/tool netwatch
add down-script="/system leds set numbers=0 type=off" host=8.8.8.8 timeout=100ms \
    up-script="/system leds set numbers=0 type=on"

de itt bármit futtathatsz, ha nem led-et, akkor bármi mást is kapcsolhatsz.