Mplayer fulscreenen?!

 ( PcZolee | 2004. december 28., kedd - 19:26 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Hi!

-vo xv

By(t)e
TBS::Antiemes

hali

en is csak a vo -xv tudom ajanlani, igaz
ez valamivel rosszabb kepminoseget eredmenyez
de legalabb a videokartya vegzi a gyorsitast, felteve ha
tamogatja az xvideot, amit mar minden normalis kartya
tamogat, igy tudok en is egy 300MHz es laptoppal
barmilyen avit megnezni :>

[quote:025cda8e8f="antiemes"]Hi!

-vo xv

By(t)e
TBS::Antiemes[/quote:025cda8e8f]

Üdv.

Igaz én még a 0,9x-es mplayert használom (igaz elég ritkán, mert DivX-es az asztali DVD Playerem), de nekem a -vo sdl jött be.

Persze az X alatt is jó fut mindenféle videofájllal vagy DVD-vel is...

[quote:4af3b03bbe]en is csak a vo -xv tudom ajanlani,[/quote:4af3b03bbe]

Jah, ez szakít! Most próbálgattam p4-celeronnal, levittem 1700 ról 200 mhz-re, és még mindig szaggatás nélkül megy a divx! :wink:

-vo xv a király
Geforce2-nél legalábbis az nyújtja a legjobb teljesítményt.

[quote:6f00891359="predator29"]A -vf scale-el az alap méret lesz 1024, szóval kicsiben nem megy, ami szerintem gáz..
A -zoom-al, meg működik, hogy nagyra rakjam. Amin viszont meglepődtem, hogy késett a kép a hanghoz képest, mint valami régi 8 vagy 4 megás videókari-nál! Ezt csinálhatja egy gef 2-nél? Még soha nem találkoztam ezzel![/quote:6f00891359]

Talan azert, mert a videokartyadnak koze nincs a szoftveres nagyitashoz. -zoom-mal mindent a CPU szamol, es ugy latszik, te elertel a cpu kapacitas legvegehez.

-vo xv a baratod, akkor a skalazast a GPU vegzi.

asd

Nekem is problémám van a fullscreen üzemmóddal.
1.0pre2-3.3.1 varziónál még tökéletesen működik, a most letöltött 1.0pre7 veriónál a teljes képernyős üzemmódra váltva szó szerint nem történik semmi. Az mplayer ablakát simán lehet maximálisra növelni a kép szép marad, csak megmarad az ablak kerete.
Megköszönném, ha valaki tudna ötletet adni.

./configure --enable-gui így konfigold.
Utána gmplyer-t indítva egérrel megy a fullscreen. "alt + f" - el nekem sem megy én sem értem hogy miért. :?
De így megy.

[quote:83550239e5="emberk"]./configure --enable-gui így konfigold.
Utána gmplyer-t indítva egérrel megy a fullscreen. "alt + f" - el nekem sem megy én sem értem hogy miért. :?
De így megy.[/quote:83550239e5]
Nekem menüből sem megy. Ha -fs opcióval indítom, akkor felnagyítja a lejátszást teljes képernyőre, csak az ablak marad eredeti méreten így csak a kép bal felső sarka látszik.

Megtaláltam a megoldást :)

gmplayer -fstype -fullscreen

Sziasztok.

Érdekes problémám adódott. A laptopomon UHU (1.1)-et használok 2.6.9-es kernellel (ez nem is fontos). Eddig ment az mplayer x11 alatt x11-es vo-val teljes képernyőn! Nem változtattam semmit, csak fordítottam egy új mplayert (a régi is forrásból volt), és most nem megy, csak egy fekete keretet tesz köré! Soxor úgy használtam, hogy megadtam neki a -vo sdl:x11 kapcsolót, a (felirat miatt), és így is ment minden rendesen X alatt! Az xf86configot néztem, ott minden ok, a kártya egy 8mb-os savage (savage driver-el megy)!

Ha terminálból indítom az sdl:x11 kapcsolóval, és nyomok egy 'f'-et, hogy kitegye teljes képernyőre, kilép, és ezt kapom:
[code:1:c2e8b40e1e]
A film aspect értéke 1,71:1 - aspect arány javítása.
VO: [sdl] 576x336 => 576x336 Planar YV12
X11 error: XF86DGANoDirectVideoMode0,092 3031/3031 14% 67% 4,0% 0 0 76%

Az MPlayer futása 6-es szignál miatt megszakadt a(z) key_events modulban
- Az MPlayer összeomlott. Ennek nem lenne szabad megtörténnie. Az ok lehet
egy hiba az MPlayer kódjában _vagy_ a Te meghajtóidban, _vagy_ a gcc-ben.
Ha úgy véled hogy ez egy MPlayer hiba, úgy olvasd el a
DOCS/HTML/hu/bugreports.html fájlt és kövesd az utasításait! Nem tudunk és
nem fogunk segíteni, amíg nem szolgálsz megfelelő információkkal a hiba
bejelentésekor.
XIO: fatal IO error 0 (Siker) on X server ":0.0"
after 153 requests (151 known processed) with 3 events remaining.
[/code:1:c2e8b40e1e]

Mi lehet a gond? Próbáltam a gyári kernellel is, azzal is ugyanez a helyzet!
Mit csináljak? Rakjam újra az X-et?

Már kipróbáltam a 1.05try2-t, az 1.06pre-t, a mai cvs-t, és épp most fordul a 0.93, szerintem nem az mplayer miatt van, de akkor miért???

Köszi

azzal a userrel indítottad az mplayert akivel az x -t is?

hasonló problémám van nekem is én deb csomagból raktam föl. Szerintem egyszerűen egy bug ebben a verzióban.

Érdekes, a 0.93 megy! Előtte egy cvs volt fenn, megkeresem azt, és visszateszem, szerintem is bug!

[quote:8540fa43c9="gUHU"]azzal a userrel indítottad az mplayert akivel az x -t is?[/quote:8540fa43c9]

Ja, de ennek mi köze hozzá?

Ez a probléma nálam is jelentkezett, és egyre idegesítőbbé kezd válni :(
Én is .deb csomagból raktam fel..
Nincs erre valami megoldás???

Igaz ez nem olyan gyors, de a -zoommal engedélyezni lehet a a szoftveres nagyítást.

-zoom

[quote:dbbc65a30c="asd"]-zoom[/quote:dbbc65a30c]

-vf scale=1024:768

azt tudom, de ez egy 500-as laptop, szal, nem a legjobb megoldás! egyébként konzolon megy a fullscreen minden verzióval, de csak root-ként! nem tudja vki, hogy miért? más, sudo-val meg akartam csinálni, hogy user-ként futtathassam, de nem értem ezt a suso-t, egyszer fut normálisan, máskor password-ot kér! miért van ez?

A -vf scale-el az alap méret lesz 1024, szóval kicsiben nem megy, ami szerintem gáz..
A -zoom-al, meg működik, hogy nagyra rakjam. Amin viszont meglepődtem, hogy késett a kép a hanghoz képest, mint valami régi 8 vagy 4 megás videókari-nál! Ezt csinálhatja egy gef 2-nél? Még soha nem találkoztam ezzel!

[quote:8661fbc5a1]Ezt csinálhatja egy gef 2-nél?[/quote:8661fbc5a1] Mindent csinálhat, csak megfelelő gagyin kell beállítani :)