Scanner Telepítés Hogyan???

 ( PcZolee | 2004. október 17., vasárnap - 17:21 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Sziasztok!
Nekem is mustek kompatibilus scannerem van, de csak root-ként használható és ott is csak az

xscanimage mustek_pp

parancs kiadása után.
Próbáltam már mindenféle jogokat adni az lp0 eszköznek de mindhiába. Mit lehet vele csinálni, hogy egy mezei user is használhassa a scannert?

Hálás köszönet!
Ez megoldotta a problémát.

Hello!

Scsi-s scannerem van, ULTIMA AT6. A rendszer sg0 alatt ismeri fel. Ennek viszont a jogosultsága root root. Valamikor már segített vki, hogy miként lehet egy újabb csoport létrehozásával ill. megfelelő linkeléssel elérhetővé tenni az sg0-t, úgy, hogy nem veszélyeztetem a rendszer biztonságát. :?

Tud segíteni vki?

Thanx!

Sarge :)

Oooooooooooooooookoooooooooooooooooosssss!

csak az sg0 tulajdonságait kellett megváltoztatnom és a (chown) csoport beállítást scannerre állítanom, majd erre jogosultságot adnom magamnak. 8O

Bocsi!

Szervusztok! Most egy hirtelen ötlettől vezérelve megint írok nektek. Sajnos úgy tapasztaltam, a windowsos motyóktól szabadulni nem tudok. Egy darabig linuxoltam, majd abbahagytam. Angol nyelvű oktató szoftver, szkenner és webkamera, msn messenger. Ezeket szeretném beüzelni esetleg egy linux alatt.
Vannak emulátorok linux alatt. A kérdésem, webkamerát, ami teljesen buta, és olyan a szkennerem is. Tehát hardver nyista benne. Hogyan lehet wines drivert felnyomni linux alá? Vmwerezni nem akarok. Elég lassú ahoz a gépem. Szerintetek van megoldás. Nálam a reményszinte meghalt, de nálatok? :roll:

Hogyne lenne megoldas: maradj a windowsnal. Ha eccer csak ott mukodik, nem erdemes szorakozni vele.
Vagy felejtsd el a webkamerat, esetleg ne a legolcsobbat vedd meg, hanem ami normalisan mukodik.

NA mivan? Ilyen bonyolultat kérdeztem? Vagy ilyen egyszerűt? Miért nem válaszol senki? :cry: :cry:

Megoldottam! Köszi annak, aki elgondolkodott a gondon...

Ugye a párhuzamos port jogaival volt gond?

Laci

Az ám, plusz azzal, hogy 0x378-at adtam meg portnak a mustek_pp.conf-ban (ahogy az ottani példában a gyártók is), és a /proc alatt megnézve is jó volt a cím, de neki mégis parport0 kelett!
Találtam a sane oldalán egy jó kis leírást a hibakeresésre, az segített!

Na ezek szerint nekem se lesz egy egyszeru menet beuzemelni a haveromnal egy Genius ColorPage Vivid II Film scannert :cry:
Ez plustek kompatibilis, de me'g nem volt idom rendesen utanajarni (1 probat ejtettem meg, es persze nem talalta).
Ha roviden osszefoglalnad azokat a buktatokat, ami miatt neked sem ment elsore, igen halas lenne'k :roll:

Elore is kosz,
KoS

en is hasonlo cipoben jarok :)
az enyem egy HP 5100C, ami annyibol specialis, hogy kell hozza a ppscsi es az epst modul, amiket viszont sehol nem talalok. tudna valaki http-s elerest mondani vagy esetleg elkuldeni mailben?

[quote:9aca84119f="kos"]Na ezek szerint nekem se lesz egy egyszeru menet beuzemelni a haveromnal egy Genius ColorPage Vivid II Film scannert :cry:
Ez plustek kompatibilis, de me'g nem volt idom rendesen utanajarni (1 probat ejtettem meg, es persze nem talalta).
Ha roviden osszefoglalnad azokat a buktatokat, ami miatt neked sem ment elsore, igen halas lenne'k :roll:

Elore is kosz,
KoS[/quote:9aca84119f]

Azt nem írtad, hogy a te scannered USB-s, vagy LPT-s, az enyém lpt-s volt! Ajánlom, hogy nézz körül a sane honlapján, mert egy kis keresgetéssel sok segítséget kaphatsz!

Szal, nekem a következő kelett!
Gantoo-m van, ezért emergeltem az xsane-t, ez hozott magával mindent ami kell (más disztribek alatt is ilyen, csak a saját csomagkezelőjével).
Ezután a /etc/sane.d alatt keresd ki a driverednek megfelelő .conf file-t, ebben álllítsd be a scannered adatait (vannak rá példák, szinte csak a #-ket kiszedegetni a megfelelő helyekről), nekem itt nem volt jó, ha a LPT címét adtam meg a parport0 kelett, hogy menjen!
Ezután a /dev/parport0-ra megfelelő jogokat adtam, és kész!
Ha ezután se menne, akkor így ellenőrízheted[code:1:9aca84119f]ldd `which sane-find-scanner` | grep libieee1284
[/code:1:9aca84119f]
Hogy a libeee1284 támogatja-e az lpt-det, ha nem újra kell forgatni (de az a sane oldalán bővebben le van írva)!

Remélem segítettem!

[quote:cd5ad74d1e="doc"]en is hasonlo cipoben jarok :)
az enyem egy HP 5100C, ami annyibol specialis, hogy kell hozza a ppscsi es az epst modul, amiket viszont sehol nem talalok. tudna valaki http-s elerest mondani vagy esetleg elkuldeni mailben?[/quote:cd5ad74d1e]

Ezek nem kernelmodulok netántán??? HA igen forgass egy új kernelt! Bocs, de most nincs időm jobban elmélyedni a témában, mennem kell dolgozni :( ...

tegnap forgattam megint uj kernelt, ami f@szan mukodik, viszont a ppscsi nem megy, a patcheles/kernelforgatas gond nelkul megvan, de mikor probalom betolteni a ppscsi modult, azt mondja hogy undef. a parport_get_port, ami pedig benne van a ppscsi.c-ben include-olt parport.c-ben
ez a 2.6.12.3-as kernel, az utolso amivel ment rendesen a ppscsi az a 2.6.7 volt, nem tud vki megoldast?

[quote:ec375dd150="PcZolee"]
Azt nem írtad, hogy a te scannered USB-s, vagy LPT-s, az enyém lpt-s volt! Ajánlom, hogy nézz körül a sane honlapján, mert egy kis keresgetéssel sok segítséget kaphatsz!
[/quote:ec375dd150]

Az a scanner is LPT-s, ezert nem is talalja az xsane keresoje, ha jol tuodm...
A tobbi segitsegedet is kosz szepen, legkozelebb 2 het mulva kerulok az a gep ele', akkor ki fogom probalni az utmutatasaid alapjan, meg a honlapon is szetnezek.
Ha megse jonne ossze, akkor max ujra felelesztem ezt a topicot :wink:

Udv,
KoS

Sziasztok.

A minap szereztem egy Medion MD9848-as LPT-s scannert. A Sane szerint működik is Linux alatt! Mustek kompatibilis!
Elolvastam a Sane doksit, Gentoo-t használok, emergeltem a sane-t meg az összes dolgot, ami kell hozzá! Majd az /etc/sane.d alatt módosítottam a mustek_pp.conf -ot, és a dll.conf-ot, ahogy le van írva! A dll.conf-ba benhagytam a v4l -t, és a mustek_pp-t! A mustek_pp.conf-ba pedig beírtam, "scanner MD9848 0x378 ccd300" , azért mert ccd-s scanner, és az lpt1-en van! Ezekután az Xsane-t indítva csak a v4l jön be! Próbáltam, hogy kiremelem a dll.conf-ból a v4l-t, hogy csak a mustek_pp maradjon, úgy meg azt írja, hogy nincs csatlakoztatott eszköz!

Mi lehet a gond? Mit csináltam rosszul? Hogyan lehet életet lehelni ebbe?

JA az LPT tuti jó, mert a nyomtatóm megy (úgy van bekötve, hogy a scanner-be megy gép és a nyomtató)

Köszi a válaszokat!

hogy oldottad meg ?:D