Milyen Linux disztribúciót használsz?

 ( trey | 2002. január 27., vasárnap - 23:55 )
Debian Woody
1% (1 szavazat)
Debian Sarge
24% (26 szavazat)
Debian Sid
3% (3 szavazat)
Uhu Linux
12% (13 szavazat)
Slackware
1% (1 szavazat)
TurboLinux
0% (0 szavazat)
Connectiva
8% (9 szavazat)
Gentoo
28% (31 szavazat)
SuSE
12% (13 szavazat)
Red Hat
9% (10 szavazat)
Mandrake
0% (0 szavazat)
KNOPPIX/Sulix
2% (2 szavazat)
Összes szavazat: 109

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Hello.

Milyen az a Debian Sid? Hol lehetne tobbet megtudni rola (ha lehet akkor magyarul)?

Udv.

Bovebb infot itt talalsz a Debian Sid-rol. A cikk cime: Debian: wtf a potato, woody, sid...

Lehet, hogy nincs igazam, de szerintem csak sid-et erdemes hasznalni, mert mindig a legujabb verziou cuccok vannak benne, es az eleg fontos kriteriem.

A stabilitas kutyat bem erdekel, mert ha minden beta lenne benne, akkor is sokkal stabilabb, mint egy win, ugyhogy...

az uj verziou programok meg altalaban gyorsabbak es nagyob teljesitmenyt lehet kicsikarni belolluk.

*Lehet, hogy nincs igazam, de szerintem csak sid-et erdemes hasznalni, mert mindig a legujabb verziou cuccok vannak benne, es az eleg fontos kriteriem.*

Lehet, hogy neked az a fontos otthon, hogy a legújabb csomagok legyenek a rendszeredben. Viszont azert unstable, az mert az éppen megjeleno legfrissebb csomagok szinte teszteles nelkul kerulnek bele a terjesztesbe. A sid kimondottan fejlesztoknek keszult terjesztes, nem javasolhatja senki nyugodt szivvel mission-critical, vagy productivity serverre. Otthonra jatszani, internetezni, napi munka elvegzesere mindenkeppen jo lehet, sot megkockaztatom, hogy gond nelkul tudod majd hasznalni. De semmikeppen nem ajanlott eles szerverre tenni. Hogy miert?

1. Mivel ez egy fejlesztoi verzio, a biztonsagi hibak javitasai nem biztos hogy a legrovidebb idon belul megerkeznek (pl. a http://security.debian.org-on nincs source se a woody-hoz se a sid-hez, es ez ertheto is)

2. ha egyszer sid-re upgradelsz akkor vegig kell jarnod a fejlesztes rogos utjat, es ha valami nem mukodik, akkor (jogosan) nem okolhatod a fejlesztoket

3. ha egyszer upgradelsz azt tudnod kell, hogy downgrade-lni nem lehet (legalabbis nem egyszeruen, fajdalommentesen) (tudom-tudom, sokat kell varni, es amikor elavulnak a csomagok pl a kovetkezo testing csomagjai frissebbek lesznek akkor lehet lefele indulni - de egy nagyon sok ido)

*A stabilitas kutyat bem erdekel, mert ha minden beta lenne benne, akkor is sokkal stabilabb, mint egy win, ugyhogy... *

Latszik, hogy csak otthon hasznalod a geped. Vallalati kornyezetben pont forditva van a dolog. A _stabilitas_ a legfontosabb. Az hogy nincs benne a legujabb grep az csak masodlagos kerdes. Egy oracle vagy db2 szerver szempontjabol ez lenyegtelen. Ott a stabilitas, es a biztonsag a legfontosabb. Es pont ez a ketto hianyzik a sid-bol.

*az uj verziou programok meg altalaban gyorsabbak es nagyob teljesitmenyt lehet kicsikarni belolluk.*

Ez sem biztos, hogy igaz. A lenyeg: otthonra jo lehet a sid, bar en otthon is csak woody-t hasznalok. A woody-nal megvan az a lehetosegem, hogy ha stabil lesz upgradelhetek a kovetkezo *unstable* -ra. A sid-nel ez a lehetosegem nincs meg. A #debian.hu-n az elmult masfel evben sok ember megfordult, lattam mar sirni olyanokat akik sid-rol akartak visszafele "downgrade"-lni ;).

Udv: trey

A debian-rol infot talalsz a http://www.debian.org-on. A debian-ról amit tudni kell:

1. szabad operacios rendszer

2. a Linux kernelre epul (jelenleg, de van Hurd kernelre epulo verzioja is)

3. szabadon letoltheto, nem kereskedelmi terjesztes (van kereskedelmi linux disztribucio is amely a debian-ra epul)

4. nem .rpm csomagokat hasznal, hanem .deb csomagokat, a _legjobb_ csomagkezelo jelenleg a vilagon =) (ezt meg a bsd-sek is sokszor bevallottak, szeretnek ha a ports ilyen lenne =))

5. borzasztoan stabil, csak akkor adjak ki a fejlesztok, ha tenyleg kesz. ezt mutatja za alacsony verzioszama is, ami jelenle a 2.2 (potato). A stabil release-k kozott tobb ev is eltelhet, ennek eredmenyekeppen egy magas megbizhatosagu rendszert kapunk. Szerverre idealis, bar en otthon is debian-t hasznalok

6. tevhitek vannak vele kapcsolatban. pl. hogy gurunak kell lenni ahhoz hogy valaki hasznalja. EZ NEM IGAZ. keudok is nyugodtan belevaghatnak, akinek minimalis angol tudasa van, es nem sik hulye az el fog vele boldogulni (nem attol linux a linux hogy debil modra kattogtatunk a grafikus feluleten - ez is hozza tartozik, de nem ez a lenyeg). Masfel eve inditottam egy support csatornat amin online segitseget lehet kerni a debian-hoz. Volt ra pelda, hogy bejott egy 14 eves arc, eleteben nem latott linux-ot. Nemi segitseg utan 4 ora!! alatt feltelepitette a rendszeret, pppd allitott be, megcsinalta a lilo-t multiboot-ra (windows rulez jeligere) es azota hasznalja elegedetten. Ja? Es erti, hogy mi hajlik a gepen, ismeri a hatterben futo folyamatokat.

7. na a woody ennek a debian-nak a jelenlegi "fagyasztott" verzioja. Ez azt jelenti, hogy a stabillá valas elott egy ideig tesztelik, uj csomagok nem kerulnek bele mar. Ha megfeleloen stabil lesz, akkor kiadjak Debian GNU/Linux 3.0 neven.

Ahol erdemes kezdeni a debian-al most ismerkedoknek:

http://www.debian.org

http://www.debianplanet.org

az iRCNET-en:

#debian.hu - ahol estenkent 40-50 ember is osszejon, es segit egymasnak megismerni, hasznalni az debian operacios rendszert. Egy igazi community all mogotte, barkit szivesen latunk, segitunk. (azert jo ha tudja az illeto, hogym ia szamitogep mielott belevag ;))

És gondolom az se érdekel, hogy kismillió local-root exploit létezhet rá, és egy kezd? kis script kidde is 5 perc alatt felnyom...

Lásd http://bugs.debian.org/release-critical/debian/all.html

és http://bugs.debian.org/release-critical/debian-non-US/all.html

Olyan csomagokban vannak rc hibák, mint pl. dpkg, apache, gcc, hwtools, mimedecode, base-passwd...

De pl. az sem egy utolsó dolog, hogy a "phpgroupware messes up mysql root password"...

Igaz, hogy szervernek nem jo. Nem is mondtam, hogy szerverre akarom felrakni. Nalam most egy rev3 van fönt, amire felnyomtam eloszor egy nem hivatalos 4.1.0-os x-et, majd egy rakat sid .deb-et. Az igaz, hogy az r3-ban levo perl-t nem tudom kiirtani belolle, es igy egy csomo mas cucc nem megy fel ra (mi szinten sid-es), de amit eddig felraktam az jol megy.

(ami nem megy, azt is csak az en tudatlansagom miatt, es nam azert, mert rossz lenne a csomag)

/etc/apt/sources.list-be ird be:

deb ftp://ftp.hu.debian.org/debian sid main contrib non-free

deb http://non-us.debian.org/debian-non-US sid/non-US main contrib non-free

[..]

aztan

apt-get update

apt-get dist-upgrade

esetleg ha makacskodik, hasznald az apt-get -f (force) cuccot. Utana mukodni fog.

Az az egy a baj, hogy van egy FOS WinModemem, es az nem igazan indul el debian alatt, mert igaz, hogy van egy linux-os meghajtoprogramja, de az .rpm-ben van es azzal meg nem tudok mit kezdeni. Ennek kovetkezteben most is epp win-t hasznalok, mert csak ez alatt van net a gepen. Mar megrendeltem az ADSL-t, de a matav meg kifogyott valami bekotocuccbol, ugyhogy most epp az sem megy (ezzel kapcsolatban van egy erdekesseg: az interware-nel fizettem elo es a telepitocd-t mar megkaptam, amin ezt irjak a linux-os meghajtoprogramnal: "A Debian disztribúció (sid) PPPoE kiegészítése a pppd-hez, bináris csomagok." es az egesz README-ben vegig a sid csomagokat ajanlgatjak, tehat nem woody-t vagy potato-t, hanem a sid csomagjait :).

Azt hiszem megvarom, hogy belekeruljon a sid-be a 4.2.0-os xfree86, es akkor leszedem .raw-kent innen az fsn.hu-rol (van uvegszalas ismeretsegem :)

Azt nem tudom, hogy ha pl az /usr/src/deb/ -be beraktam azokat a .deb-eket, amiket fel akarok rakni, akkor azokat csak a dpkg-vel lehet felrakni, vagy lehet az apt-get-el is?

A most is epp wint hasznalok, annyit tesz, hogy jelenleg van font egy win, egy debian, es egy qnx, meg ures hely freebsd-nek meg solarisnak, de most eppen win alol netezek.

Lenne meg egy kerdesem:

Hogyan kell egy hangkartyat bekonfiguralni, es kulon kell az X-hez, vagy az egesz rendszernek csak egyszer kell?

Na lassuk szepen sorjaban:

1. A winmodemek, mint a nevukben is benne van Windows-ra keszultek, nem igazi modemek, a szamitogep CPU-ja emulalja a modem funkciokat. Es, hohy miert nem mukodnek ezek a modemek Linux alatt? Azert mert a gyartok nem adjak ki a modemek specifikacioit, technikai dokumentacioit. Ha van driver .rpm csomagban, akkor az erdemes a debian "alien" csomagjaval .deb csomagga alakitani. Sok remenyt mondjuk nem fuzok hozza. Bar ami ezekben a .rpm.ekben benne van az tobbnyire egy kernelmodul, erdemes kiszedni a csomagbol es belehaxolni a kernelbe. Ha ez sem megy, akkor http://www.linmodems.org, es a modemed tipusanak ismereteben szetnezel (ez egy ilyen winmodem drivereket tartalmazo oldal linux-hoz)

Az ADSL-t nem tudom neked bekotni, de:

ki nem sz*rja le, hogy az enternet mit tesz a gagyi telepitocd -jere? Eleg szomoru, hogy egy unstable disztribucio csomagjait teszi ra.

BTW: Debian Potato/Woody alatt:

apt-get install pppoe*

feltesz 3 darab csomagot es gyonyoruen mukodik a cucc cirka 2 perc alatt. (termeszetesen a kernelbe kell legyen pppoe tamogatas)

Tessek adok melle meg egy how-to-t is: http://portal.fsn.hu/old/dsl/adsl.html

APT-al minden fel lehet telepiteni. Javaslom az apt-setup, apt-cdrom parancsok suru nezegeteset.

Ez hangkartyatol fugg. Tobbnyire kernelszinten van a kerdeses driver, kernelbe megfelelo modul betoltesevel, es egy mixer program hasznalataval csodakat lehet muvelni. Innentol hasznalhatod a hangkartyat, esetleg kulonfele daemonokat kell telepitened pl. esd . Ez mar csak a desktop felulettol fugg.

Az meg, hogy milyen driver kell termeszetesen a hangkartya tipusatol fugg.

A kerneldriver helyett haszalhatsz pl. ALSA-t is, de az ALSA a 2.4-es kerneltol kezdve kezdi ertelmet vesziteni (jojo, tudom, hogy meg sokan hasznalnak GUS -t, de aze' ez mar szignifikans =))

Én trey-el ellentétben továbbra is alsa hív? vagyok, és nem a GUS miatt... De vmelyik kernelben az ac97-es alaplapi gánynak a drivere azt csinálta, hogy mindegy milyen sample rateje volt a lejátszott anyagnak, akkor is 48kHznek vette az sr-t...

Bedurrant az agyam, es felraktam a 0.5-os alsa-t... Bar emiatt neha kiirja az mplayer, hogy lassu a gepem, de becsukom azt az ablakot és kész:)

Szóval alsa telepítés: apt-get install alsa-src-0.5 vagy már nem emlékszem melyik... meg még az alsa libjeit, és utiljait kell feltenni.

Oda pakol neked az /usr/src-be egy alsa....tar.gz fájlt.

Ezt ott helyben kibontod.

És mikor kernelt forgatsz, akkor a szokásos make-kpkg --revision=rrr.000 --bzImage kernel_image parancs helyett, a make-kpkg --revision=rrr.000 --bzImage kernel_image modules parancsot adod ki.

És így csinál csomagot a /usr/src/modules könyvtárban lev? egyéb kernel modulokból is, mint pl. alsa vagy i2c.

Némi kis haxolással nekem még potaton is megy 0.5 alsa, sensors, stb. És még potaton is ki tudom aknázni a Thunderbird-es proci és a hozzá szüks alaplap lehet?ségeit. (Értsd h?mér?, ac97, udma100 vezérlö)

Nem tudom minek ez a pppoe-s vackolás. debian-hu levlistán (debian@lists.linux.hu) már egyszer lefutott a téma, hogy a magyarországi adsl-es szolgáltatók legtöbb esetben kivisznek egy kis dobozkát, amit etherneten összekötsz a gépeddel, és semmi pppoe-s vackolás nem kell, mert azt a dobozka csinálja.

Azt az sid csomagos telepito cd-t csak erdekessegnek mondtam, hogy meg egy egesz komoly cegnel is tudnak ilyen komoly bakikat csinalni.

A modemrol meg:

a linmodems.org-on mar eleg reg megneztem, de sajnos ott is csak ugyan az a linkje van a motorolanak, ahol az rpm-et talaltam. viszont meg regebben volt egy RedHat-em es arra felraktam, de semmit sem csinalt a kernellel, csak valami egyeb fajlokat rakott fel, de arra mar nem emlekszem, hogy miket es hova.

A tobbit meg koszi.

Nem tudom, hogy hol szerelnek ilyen ADSL-t, de en akarhany helyen jartam, akarkivel beszeltem nem ezt mondta =). Fenntartom, hogy kell a kernelbe PPPoE support, es fel kell tenni a PPPoE csomagokat. (ezt tobben is megerositettek)

Udv: trey

Ize, ezt gyu -nak irtam valaszkent, csak rossz helyre sikerult =)

Imho jó helyre ment :)

Lehet, hogy hülyén fogalmaztam.

Én még nem láttam senkinél sem ADSL-t.

De a debian@lists.linux.hu levlistán (amit Csani adminisztrál) volt ilyesmirôl szó, és én úgy emlékszem, hogy ott az volt az eset szummázata, hogy a legtöbb helyen nem kell PPPoE.

Ha oda hülyeséget írtak, akkor én is hülyeséget mondam :)

Na utananeztem en is, mert nekem (meg hetfoig) nincs ADSL-em. Tehat valoban lehet, hogy eleg csak a ppp + pppoe csomag. De a szep az egeszben, hogy 20 embert megkerdezve (akiknek van ADSL) 17 azt mondta, hogy kell kernelbe pppoe, 1 nem tudja!!! (ez a legjobb =)), 2 pedig azt mondja, hogy nem kell:

Hetfon aze kiprobalom szemelyesen is.

Imho le kéne már állítani ezt a szavazást, mert az az érdésem, hogy bundába kezd átmenni a dolog: naponta megnô a woody és a sid úgy kb. 10-10-el, vagy lehet, hogy a woody még jobban:)