Arch Linux

Leírás

Az Arch Linux terjesztés kezelésével, adminisztrálásával kapcsolatos kérdések és válaszok fóruma.

systemd-boot keyboard layout

Fórumok

Sziasztok!

systemd-boot-ot használok a gép indítására. LVM on Luks-ot használok az összes partícióra. A boot folyamán a rootfs titkosításának feloldásakor a jelszó bekérésekor QWERTY kiosztás van érvényben, ezt szeretném megváltoztatni QWERTZ-re. Google csak vconsole.conf és társait dobja fel, vagy totál irreleváns systemd-boot oldalakat, viszont nyilván ezek a fájlok nem lehetnek megoldások, hiszen ekkor még olvashatatlanok. A /boot/loader/loader.conf-ra gondoltam, hogy talán megoldás lesz, viszont a wiki szerint nincs benne ilyen opció.

Esetleg ismer valaki megoldást erre, vagy állítsam át a jelszót úgy, hogy a Z-k helyére Y-t írok (a mostani pl. "teszt" helyett "tesyt")?

Arch miniDLNA

Fórumok

Sziasztok.

Lecseréltem, a funtoo linux-om Arch linux-ra. Indokom, az volt, hogy a csomagok telepítése és frissítése sok idő vesz igénybe. Egész jól megbarátkoztam ezzel a rendszerrel. A problémám a következő.
Feltelepítettem a miniDLNA programot. Meg is írtam a config file-t. Szépen el is indul automatikusan és a tv is látja, de a mappába lévő filmeket nem. Rendszergazdaként indítva, viszont a filmeket is látja a tv. Először arra gondoltam, nem megfelelő jogokkal rendelkezik a mappa ahol a filmek vannak. Megnéztem a mappa jogait és ott mindent rendben találtam.

[pusztito@archlinux ~]$ ls -ld Filmek/
drwxr-xr-x 13 pusztito pusztito 4096 aug 20 16.07 Filmek/
[pusztito@archlinux ~]$

Egyszerűen, nem értem miért nem látja a filmeket a felhasználó. Esetleg, tudna valaki tippet adni?

Btrfs otthonra

Fórumok

Sziasztok!

Tapasztalatotokra vagyok kíváncsi Btrfs-sel kapcsolatban otthoni használatra. Van valami haszna (sebességben, stabilitásban akár) ext4-gyel szemben?
4.11-es kernellel (jelenleg) használnám arch alatt. A rendszer alatt egy 128 GB-os Kingston SSD van (sda), az adatok pedig egy 1 TB-os WD HDD-n (sdb).

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 111,8G 0 disk
├─sda1 8:1 0 1G 0 part /boot
├─sda2 8:2 0 80G 0 part /
└─sda3 8:3 0 16G 0 part [SWAP]
sdb 8:16 0 931,5G 0 disk
├─sdb1 8:17 0 50G 0 part /var
└─sdb2 8:18 0 881,5G 0 part /home

usb 3.0 hub

Fórumok

Sziasztok!

A minap vettem a pepco-ban egy usb 2.0-s hubot kb 700 ft-ért.
Eddig ok, de halál lassú, ha rajta van egy "Bus 002 Device 002: ID 045e:07fd Microsoft Corp. Nano Transceiver 1.1" és egy 3.0-s usb-s hdd.

Mivel a laptopban (HP elitebook 2530p) minkét usb port megficcent ( ti. kitört az a műanyag pöcök anyagfáradás miatt), így vettem egy usb 3-as pcimcia kártyát (xhci_hcd 0000:03:00.0: xHCI Host Controller
) amin 1 usb port van.
Ha veszek egy usb 3-as hubot, akkor növekszik a sebessége a fájlműveleteknek, mert így 1-2 MB/sec kb vagy visszafogja az ms egér tranrecive-ere?

A disztib: Linux archlaptop 4.10.10-1-ARCH #1 SMP PREEMPT Wed Apr 12 18:50:28 CEST 2017 x86_64 GNU/Linux

Arch, webmin, hitelesítési gondok

Fórumok

Sziasztok.

Valamiért Arch linuxon a webmin és a monitorix nem működik rendesen, távoli gépről böngészőn keresztül hitelesítési problémák vannak.

A log:
[12/Apr/2017:13:03:53 +0200] miniserv.pl started
[12/Apr/2017:13:03:53 +0200] Using MD5 module Digest::MD5
[12/Apr/2017:13:03:53 +0200] Perl module Authen::PAM needed for PAM is not installed : Can't locate Authen/PAM.pm in @INC (you may need to install the Authen::PAM module) (@INC contains: /opt/webmin /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at (eval 9) line 1.
BEGIN failed--compilation aborted at (eval 9) line 1.

[12/Apr/2017:13:08:25 +0200] [192.168.12.25] Access denied for 192.168.12.25

Állapotok:

# systemctl status webmin
* webmin.service - Webmin
Loaded: loaded (/usr/lib/systemd/system/webmin.service; enabled; vendor preset: disabled)
Active: active (exited) since Wed 2017-04-12 13:03:54 CEST; 21s ago
Process: 9187 ExecStop=/etc/webmin/stop (code=exited, status=0/SUCCESS)
Process: 9195 ExecStart=/etc/webmin/start (code=exited, status=0/SUCCESS)
Main PID: 9195 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/webmin.service
`-9203 /usr/bin/perl /opt/webmin/miniserv.pl /etc/webmin/miniserv.conf

Apr 12 13:03:50 Bzs-NMEA-Multiplexer start[9195]: Starting Webmin server in /opt/webmin
Apr 12 13:03:51 Bzs-NMEA-Multiplexer webmin[9195]: Webmin starting
Apr 12 13:03:53 Bzs-NMEA-Multiplexer start[9195]: Pre-loaded WebminCore

# systemctl status httpd
* httpd.service - Apache Web Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
Active: inactive (dead) since Wed 2017-04-12 12:30:40 CEST; 45min ago
Process: 2843 ExecStop=/usr/bin/httpd -k graceful-stop (code=exited, status=0/SUCCESS)
Process: 2839 ExecStart=/usr/bin/httpd -k start -DFOREGROUND (code=exited, status=0/SUCCESS)
Main PID: 2839 (code=exited, status=0/SUCCESS)

Apr 12 12:30:40 Bzs-NMEA-Multiplexer httpd[2839]: AH00558: httpd: Could not reliably determine the ...age
Apr 12 12:30:40 Bzs-NMEA-Multiplexer httpd[2839]: httpd (pid 2787) already running
Apr 12 12:30:40 Bzs-NMEA-Multiplexer httpd[2843]: AH00558: httpd: Could not reliably determine the ...age
Hint: Some lines were ellipsized, use -l to show in full.

# systemctl status monitorix
* monitorix.service - Monitorix
Loaded: loaded (/usr/lib/systemd/system/monitorix.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2017-04-12 13:16:48 CEST; 2s ago
Docs: man:monitorix(8)
Process: 11684 ExecStart=/usr/bin/monitorix -c /etc/monitorix.conf -p /run/monitorix.pid (code=exited, status=0/SUCCESS)
Main PID: 11686 (/usr/bin/monito)
CGroup: /system.slice/monitorix.service
|-11686 /usr/bin/monitorix -c /etc/monitorix.conf -p /run/monitorix.pid
`-11739 monitorix-httpd listening on 8080

# apachectl configtest
Syntax OK

--------
Tettem egy kísérletet erre:

# perl -MCPAN -e shell
Terminal does not support AddHistory.

cpan shell -- CPAN exploration and modules installation (v2.11)
Enter 'h' for help.

cpan[1]> install Authen::PAM
Fetching with LWP:
http://www.cpan.org/authors/01mailrc.txt.gz
Segmentation fault (core dumped)

..de nem ment.
Szerintetek mi lehet a baj és mi lehet egy valódi megoldás? A webmin újrahúzása nem segített.

pacman és tar hiba (megoldva)

Fórumok

Sziasztok.
Belefutottam egy érdekes problémába. Valamilyen oknál fogva a /var/lib/pacman/local/tar alól eltüntek a fájlok, csak az mtree van meg. Ezért semmit nem tudok telepíteni, mert a pacman -S csomagnév vagy a yaourt -S csomagnév vagy egy frissítés alkalmával a következő hibákat írja ki:
yaourt -Syua
A csomagadatbázisok szinkronizálása...
core 123,3 KiB 9,26M/s 00:00 [################################################] 100%
extra 1676,7 KiB 14,4M/s 00:00 [################################################] 100%
community 3,8 MiB 22,4M/s 00:00 [################################################] 100%
a(z) archlinuxfr naprakész
error: could not open file /var/lib/pacman/local/tar-1.29-2/desc: No such file or directory

Próbáltam kicselezni egy pacman -S --force tar paranccsal :) Persze nem ment. A hiba ugyan az.
A tar létezik a /usr/bin alatt, de egy tar parancs kiadására szegmentálási hibát ad.
Tehát a tar telepítéséhez kell a tar. 22-es csapdája. Mi lehet a megoldás?

netcat képes portot ,,nyitni''?

Fórumok

Sziasztok.

Mai rohanó világunkban az ember nem tudja, mit csinál.
Én sem.
Lépéseim egy nyamvadt port használatára a következő volt eddig:
iptables, firewall-cmd, shorewall, socat, majd miután rájöttem, hogy életképtelen vagyok ezekre, jött valami más.
Ez:

tail -f ./gps.minicom | netcat -l -p 10110

a gps.minicom-ba írom azt az adatfolyamot, amit a minicom rögzít RS232-n.

Ezek szerveren futnak.
A szerverre kapcsolódó kliens célprogramja (opencpn) pedig látja, mi érkezik a 10110-es porton.

Kérdés:
valóban azt látom, amit képzelek, azaz a netcat a tail-tól átvett adatfolyamot szétküldi egy megnyitott 10110-es porton?

Kliensen megnéztem, most már nem ,,filtered'' van itt:

# nmap -p 10110 192.168.12.1

Starting Nmap 6.47 ( http://nmap.org ) at 2017-01-31 16:44 CET
Nmap scan report for domain1.com (192.168.12.1)
Host is up (0.0072s latency).
PORT STATE SERVICE
10110/tcp open unknown
MAC Address: 10:7B:EF:CD:0A:D1 (ZyXEL Communications)

Nmap done: 1 IP address (1 host up) scanned in 0.53 seconds

...hanem ,,open''

firewalld -error

Fórumok

Sziasztok.

Telepítettem egy firewalld-t:


# pacman -S firewalld
warning: firewalld-0.4.4.2-2 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) firewalld-0.4.4.2-2

Total Installed Size:  4.69 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                              [###########################################] 100%
(1/1) checking package integrity                                            [###########################################] 100%
(1/1) loading package files                                                 [###########################################] 100%
(1/1) checking for file conflicts                                           [###########################################] 100%
(1/1) checking available disk space                                         [###########################################] 100%
(1/1) reinstalling firewalld                                                [###########################################] 100%

...majd gondoltam ki is próbálom:

# firewall-cmd --add-port=2947/tcp --permanent
Traceback (most recent call last):
File "/usr/bin/firewall-cmd", line 24, in
from gi.repository import GObject
ImportError: No module named 'gi'

#

[/code]

Ezt nem értem, ugyanis a python2-gobject2-2.28.6-13-armv6h.pkg.tar.xz csomag fent van..

Az Arch armv6h, a kernel 4.1.15-1-ARCH #1 Tue Dec 15 18:28:56 MST 2015 armv6l GNU/Linux

Ahogy nézegettem, csak a python2-gobject csomag esetleges hiányáról van szó, de ez fenn van.

# pacman -Qikk python-gobject python
Name : python-gobject
Version : 3.22.0-2
Description : Python Bindings for GLib/GObject/GIO/GTK+
Architecture : armv6h
URL : https://wiki.gnome.org/Projects/PyGObject
Licenses : LGPL
Groups : None
Provides : None
Depends On : pygobject-devel=3.22.0 python
Optional Deps : cairo: Cairo bindings [installed]
Required By : python-slip
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 1022.00 KiB
Packager : Arch Linux ARM Build System
Build Date : Sat Jan 7 09:18:46 2017
Install Date : Sun Jan 29 12:55:21 2017
Install Reason : Explicitly installed
Install Script : No
Validated By : SHA256 Sum

python-gobject: 92 total files, 0 altered files
Name : python
Version : 3.5.1-1
Description : Next generation of the python high-level scripting language
Architecture : armv6h
URL : http://www.python.org/
Licenses : custom
Groups : None
Provides : python3
Depends On : expat bzip2 gdbm openssl libffi zlib
Optional Deps : python-setuptools [installed]
python-pip [installed]
sqlite [installed]
mpdecimal: for decimal
xz: for lzma [installed]
tk: for tkinter
Required By : python-dbus python-decorator python-gobject python-idna python-packaging python-pillow python-pip
python-ply python-psutil python-pyasn1 python-six
Optional For : util-linux
Conflicts With : None
Replaces : python3
Installed Size : 95.33 MiB
Packager : Arch Linux ARM Build System
Build Date : Fri Dec 11 13:40:41 2015
Install Date : Sun Dec 25 16:36:08 2016
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : SHA256 Sum

python: 6752 total files, 0 altered files

Nem értem, mi lehet a baj.

php5-ssh2 --- "Call to undefined function ssh2_connect()"

Fórumok

Sziasztok.

debianon sikerült írnom egy fájlba ssh2 segítségével így:

# cat /var/www/html/php/1.php
<?php
$ssh_kapcsolat = ssh2_connect('localhost', 22);
$ssh_belepes= ssh2_auth_password($ssh_kapcsolat, 'a', '123456');
if($ssh_kapcsolat && $ssh_belepes){
$ssh_parancs = ssh2_exec($ssh_kapcsolat, 'echo hopp > /tmp/hoppppp.temp');
print "Parancs sikeresen végrehajtva!";
}else{
print "HIBA! Ellenőrizd a SSH kapcsolat beállításokat."; die;
}
fclose($ssh_kapcsolat);
?>

Parancssorban végrehajtva létrehozta a /tmp-ben a fájlt, egyéb parancssori scriptet is lehet futtatni így

# php ./1.php
Parancs sikeresen végrehajtva

Debianon ezt kellett telepítenem:
apt-get install php5-ssh2

-----------
Arch-on azonban mindez nem sikerült. Itt ilyen nevű csomag nincs, mindössze ezek:

# pacman -Ss ssh2
core/libssh2 1.8.0-1 [installed]
A library implementing the SSH2 protocol as defined by Internet Drafts
extra/java-jsch 0.1.51-1
A pure Java implementation of SSH2
community/python-paramiko 2.1.1-2 [installed]
Python module that implements the SSH2 protocol
community/python-paramiko1 1.16.0-3
Python module that implements the SSH2 protocol (compatibility version)
community/python2-paramiko 2.1.1-2
Python module that implements the SSH2 protocol
community/python2-paramiko1 1.16.0-3
Python module that implements the SSH2 protocol (compatibility version)

Miután a libssh2-t felraktam, újraindítottam a httpd-t, és még mindig ez a hibaüzenet fogadott:

# php ./1.php
PHP Fatal error: Call to undefined function ssh2_connect() in /dev/shm/asd-root/srv/http/domain1.com/nmea/1.php on line 2

Ez pontosan ugyanaz, mint debianon, amikor nem volt fenn a php5-ssh2 csomag. Mivel tudtommal még a csomagok közt is eltérések vannak a distribek közt, nem tudom, mi hiányozhat még az Arch-nak.

A
php -m | grep ssh
parancsra válasz nincs.

Arch virtualboxon: startx nem indítja a grafikus felületet (xfce), xorg hiba vagy driver hiba?

Fórumok

Hali!

Őszintén szólva még elég tapasztalatlan vagyok az Arch használatával kapcsolatban, de a wiki telepítés leírását és youtubeos telepítéseket látva arra vetemedtem, hogy feltelepítem vb-ra.
Az installálás végén feltettem az xfce4 felületet (xinitrc-be be írtam, hogy startxfce4, hogy elindulhasson), reboot,bejelentkezés majd startx parancs kiadása után jöttek a hibaüzenetek.
Ezekről 2 kép: http://www.kepfeltoltes.eu/images/620K_perny_337_k_p.png
http://www.kepfeltoltes.eu/images/880K_perny_337_k_p_1.png
Hozzátenném, hogy ez a 2 üzenet is csak az xorg újratelepítése után jelent meg.. addig csak konzolon írta, hogy "xorg terminated sucessfully".
Ezután észrevettem, hogy ha startx helyett startxfce4 parancsot adok ki akkor meg elindul, rendesen betöltötte az asztalt és a panelt, de korai volt az öröm, mert tetű lassú volt az egész..."csúszott" a kép, az egérmutató alig akart mozdulni a virtuális gépen.
Rágugliztam a problémára mielőtt itt témát nyitottam, az arch fórumon voltak egyedek akiknek hasonló gondjuk volt, ott a dbus telepítése volt a megoldás (pontosan nem tudom, hogy mi az), telepítettem én is, mire kiderült, hogy már eleve fent volt (terminál reinstallingot írt ki).
Itt egy kép, a rendszer startx parancsra való pontos reakciójára: http://www.kepfeltoltes.eu/images/844K_perny_337_k_p_3.png
Valamikor ezt írja ki, valamikor megjelenik, hogy "unable to contact setting server" (az első kép ezt ábrázolja)
Külön érdekes, hogy a startxfce4 parancs root joggal nem működik... root nélkül viszont betölti az xfce-t...(nagyon lassú, de "működik"

Nem tudom mennyit számít ez, de bootoláskor is kapok egy üzit: failed to find cpu0 device nod

A gépen a Debian fut, fglrx driver (amd radeon) nincs fent (mivel nincs szükségem rá a felhasználás során, és a korábbi virtuális rendszerek is jól futottak nélküle)

Ezeken kívül én már csak 1 hibalehetőséget látok: a telepítés egyik pontját nem teljesen értettem:
lspci -k l grep -A 2 -i "VGA" , ezt a parancsot nem sikerült elvégezni.

Hogyan orvosolhatnám a problémát? Köszönöm a hasznos válaszokat!