Arch Linux

komplett image készítés titkosított disk-ről

Fórumok

Sziasztok,

szerintetek mi a legegyszerűbb módja annak, hogy egy nvme ssd-ről készítsek egy teljes image-t? A disk-en a /boot-on kívül minden luks titkosított. Mindez notin (usb dokkoló van, abba való plusz disk van). Lehetőleg a visszaállítás se legyen nagyon macerás.

Clonezilla az első ötletem, de hátha van valami más és jó/jobb megoldás is.

Köszönöm a javaslatokat előre is!

Rpi zero -- distribválasztás

Fórumok

Sziasztok!

Van egy nem elsőgenerációs RPI zerom (nem tudom, melyik).

AP-nek szeretném használni, és a régebbi ARCH linuxom nem akar elindulni rajta,  egy kártyacsere a régiből az újba nem segít. Elképzelhető, hogy az újabban kiadott RPI zerok 64 bitesek és amiatt van az oprendszerrel a baj?

Segítséget szeretnék kérni: honnan lehet img fájban letölteni a mostani zerokhoz lehetőleg nem raspbian rendszert? Eddig csak "étlapokat" láttam ARCH telepítéséhez, többoldalas leírást, ami még a kártya bootolhatóságát is megoldja. Ezekhez sajnos már túl öreg vagyok, viszont dd-vel még képes vagyok kiírni egy lemezképet.

Köszi a segítséget, javaslatokat

grub customizer, manjaro linux letíltotta

Fórumok

 Üdv !

Csak nem értem. 

DE utálom szerkeszteni az etc/grub.d fájlt.

"Download the offline installer of the application in this link: https://archlinux.org/packages/community/x86_64/grub-customizer/downloa… Then double click on it in Dolphin and that's it."

"The grub-customizer package may work in vanilla Arch, but it continues to ruin the Manjaro-specific GRUB configuration, and yet people keep on installing it.

Wouldn’t it be wisest to drop that package from our repos instead?"

Másik kommentelő: " olyan mint a pestis "

De: az általa létrehozott /boot/grub/grub.cfg ott marad és teszi a dolgát. Viszont a letíltás után létrejött grub.cfg.new mindössze a default manjaro-t és egy osprobe windowst talált.

Mi történik itt ? Az hogy az a forumozó aki kérte a letíltást a repoból pestisnek nevezi, szive dolga.

Debian ubuntu mint nem tiltotta le.

Mi lehet a megoldás ?

System76 Galago Pro - akku cseres, vagy sw problema?

Fórumok

Van egy 2018 vegi System76 Galago Prom (nem garancias, de ha az lenne is nem mennek vele semmire USA-n kivul). Az utolso olyan, amit meg csak a sajat tapja tolt, az USB-C nem tolti.

A toltes nem megy feljebb 81%-nal. Mindezt 90% battery health mellett teszi. Igy vegulis technikailag van egy 71%-os aksim, de legalabb 2%-nal se kapcsol ki, tehat talan legalabb nem zarlatos.

Latest Arch Linux kernel, latest KDE, latest systemd. dmesg ures

Ket kerdesem van:

  1. Van valami rejtett feature akar az Arch-ban, akar a latest kernelben, akar a latest KDE-ben, akar a latest systemd-lofaszd-ben, vagy akarmiben, ami "lemasolja" az Apple-os optimised battery charging feature-t? Es elkepzelheto emiatt, hogy szoftveres okok miatt nem tudom 81% fole tolteni? Ha van ilyen, hogysan tudom kikapcsolni? KDE menuket atbongesztem, az nem volt eleg, de a parancssoros battery toolokat nem ismerem
  2. Amennyiben hardver (erre latok en is nagyobb eselyt) - ez a System76 gyarto US only, de messze vagyok USA-tol. Honnan tudok ebbe a tipusba (System76 Galago Pro) normalis akkut szerezni? Vigyem be valahova (hova?), vagy magamnak is at tudom szerelni? Minden mas gep Apple a haztartasban, ahhoz vagyok szokva, igy nem tudom mik ennel a javitasi "best practice"-ok. Tud valaki valamit ajanlani, hogy tenyleg ebbe valo aksit talaljak, es abbol se olyat, ami aztan nem fog tetszeni a gepnek?

Windows nincs a gepen, remelem anelkul is le tudjuk szukiteni, hogy ez hardver. Inkabb bootolok rajta egy regebbi kerneles live usb-t, ha azon mulik.

kdeshot

[Megoldva]Hang érdekesség

Fórumok

Sziasztok

Már napok óta, küszködök hang érdekességgel. A probléma a következő.

Ha elindítom a gépet nincs alapból hangom. Nem azért mert le van némítva a kimenet, hanem egyszerűen nincs. Ha kihúzom a fülest és visszadugom, egyből van hangom. További érdekesség az egészbe, ha mondjuk játszom, akkor utána nem tudok youtube-ot nézni mert akadozik(tulajdonkép jóformán el se indul). Viszont ha elindítom a játékot úgy, hogy elindítom a youtube-ot és kihúzom a fülest és egyből vissza is dugom, utána szépen lejátssza a youtube-ot és lesz hangom. De ugyan ez a jelenség, ha leállítom a youtube lejátszást, akkor se tudok egyből youtube-ot nézni, csak ha elindítom a játékot és ott ki be dugom a fülest.

Először arra gondoltam, valami bug lehet amit valamelyik friss update okozhat. Viszont folyamatosan frissítem a rendszert szinte már minden frissült de a probléma maradt.

Esetleg találkozott valaki ilyen jelenséggel? Mi okozhatja?

Előre is köszönöm a segítséget.

Arch linux touchpad klikk probléma [Megoldva]

Fórumok

Sziasztok.

 

Enlightenment ablakkazelőt használok, Arch linuxon, a gond, az, hogy nincs aktiválva a touchpad klikk, aimkor lefuttatom a xinput set-prop 15 332 1 parancsot, akkor minden oks,de jó lenne ezt állandósítani. Utána olvastam a dolognak, több helyen írták, hogy adjam hozzá a parancsot, az .xinitrc-hez amit meg is tettem, de sajnos nem működik. Majd azt is olvastam, hogy hozzak létre egy file-t az /etc/X11/xorg.d/-ben 99-libinput.conf néven amibe beleírtam a következőt:

skuba@arch[~] 0 % cat /etc/X11/xorg.conf.d/99-libinput.conf
Section  "InputClass"
Identifier  "ETPS/2"
MatchProduct "ETPS/2 Elantech Touchpad"
Option "Tapping Enabled" "true"
Option "Tapping Enabled Default" "true"
EndSection
skuba@arch[~] 0 %

xinput list kimenet:

skuba@arch[~] 0 % xinput list
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ 2.4G Wireless Optical Mouse                 id=11    [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                    id=15    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Asus Wireless Radio Control                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                   id=8    [slave  keyboard (3)]
    ↳ Power Button                                id=9    [slave  keyboard (3)]
    ↳ Sleep Button                                id=10    [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam: USB2.0 HD             id=12    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                            id=13    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=14    [slave  keyboard (3)]

skuba@arch[~] 0 % xinput list-props "ETPS/2 Elantech Touchpad"
Device 'ETPS/2 Elantech Touchpad':
    Device Enabled (173):    1
    Coordinate Transformation Matrix (175):    1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Tapping Enabled (332):    0
    libinput Tapping Enabled Default (333):    0
    libinput Tapping Drag Enabled (334):    1
    libinput Tapping Drag Enabled Default (335):    1
    libinput Tapping Drag Lock Enabled (336):    0
    libinput Tapping Drag Lock Enabled Default (337):    0
    libinput Tapping Button Mapping Enabled (338):    1, 0
    libinput Tapping Button Mapping Default (339):    1, 0
    libinput Natural Scrolling Enabled (309):    0
    libinput Natural Scrolling Enabled Default (310):    0
    libinput Disable While Typing Enabled (340):    1
    libinput Disable While Typing Enabled Default (341):    1
    libinput Scroll Methods Available (311):    1, 1, 0
    libinput Scroll Method Enabled (312):    1, 0, 0
    libinput Scroll Method Enabled Default (313):    1, 0, 0
    libinput Click Methods Available (342):    1, 1
    libinput Click Method Enabled (343):    1, 0
    libinput Click Method Enabled Default (344):    1, 0
    libinput Middle Emulation Enabled (318):    1
    libinput Middle Emulation Enabled Default (319):    0
    libinput Accel Speed (320):    0.000000
    libinput Accel Speed Default (321):    0.000000
    libinput Accel Profiles Available (322):    1, 1
    libinput Accel Profile Enabled (323):    1, 0
    libinput Accel Profile Enabled Default (324):    1, 0
    libinput Left Handed Enabled (325):    0
    libinput Left Handed Enabled Default (326):    0
    libinput Send Events Modes Available (294):    1, 1
    libinput Send Events Mode Enabled (295):    0, 0
    libinput Send Events Mode Enabled Default (296):    0, 0
    Device Node (297):    "/dev/input/event11"
    Device Product ID (298):    2, 14
    libinput Drag Lock Buttons (327):    <no items>
    libinput Horizontal Scroll Enabled (328):    1
    libinput Scrolling Pixel Distance (329):    15
    libinput Scrolling Pixel Distance Default (330):    15
    libinput High Resolution Wheel Scroll Enabled (331):    1

Kérdés:

 

Mit rontottam el?

 

Előre is köszönök minden hozzászólást. !

Manjaro update

Fórumok

Sziasztok!

Dedikált Manjaro fórum hijján ide irnám, hátha. Aktív Manjaro felhasználók közül van valakinek update problémája? Hiba ugyan nincs, de feltűnt, hogy egy ideje semmilyen update nem jön.

Sway-jel kapcsolatos kérdések

Fórumok

[A TOPIKOT UTÓLAG ÁTNEVEZTEM]

Sway alatt minden alkalmazás átveszi a config-ban beállított betűtípust, kivéve a böngésző. (Brave) Mi lehet ennek az oka?

config file ide vontakoz része:

## Font
font pango:MesloLGS NF 10

## Theme
set $gnome-schema org.gnome.desktop.interface

exec_always {
    gsettings set $gnome-schema gtk-theme 'Dracula'
    gsettings set $gnome-schema icon-theme 'Dracula'
    gsettings set $gnome-schema cursor-theme 'ArchCursorTheme'
    gsettings set $gnome-schema font-name 'MesloLGS NF'
}

[A TOPIKOT UTÓLAG ÁTNEVEZTEM]

[Megoldva] NetworkManager nem tud wifire csatlakozni

Fórumok

Hello,

Van egy frissen installált archlinuxom és sehogy nem bírom rávenni a networkmanagert hogy csatlakozzon a wifihez.

iwd + systemd-networkd kombó simán felcsatlakozik.

Próbáltam már wpa_supplicant profilet létrehozni, letiltottam a mac address randomizationt, ami ötlet a neten van ehhez azt mind próbáltam mégse sikerül megoldani.

Ami igen fura hogy install egyszer ment de restart óta nem sikerül rávennem hogy csatlakozzon. Eljut addig hogy bekéri a jelszót aztán mégsem csatlakozik fel.

Bármi ötletet szívesen fogadok.

Köszönöm!

 

Megoldás:

Törölni kelett a connectionök közzül a wifit.

nmcli connection delete <SSID>

aztán már simán felcsatlakozott

nmcli device wifi connect <SSID> password <PASSWORD>  (thx fsanyi !)

[Megoldva] Manjaro frissítés hiba

Fórumok

A hiba:

sudo pacman -Syu
:: A csomagadatbázisok szinkronizálása...
 a(z) core naprakész
 a(z) extra naprakész
 a(z) community naprakész
 a(z) multilib naprakész
:: Teljes rendszerfrissítés indítása...
:: Lecseréli lib32-libcanberra-pulse-t erre: multilib/lib32-libcanberra? [I/n] 
:: Lecseréli libcanberra-pulse-t erre: extra/libcanberra? [I/n] 
:: Lecseréli qca-t erre: extra/qca-qt5? [I/n] 
függőségek feloldása...
ütköző csomagok keresése...
hiba: nem sikerült előkészíteni a tranzakciót (nem sikerült kielégíteni a függőségeket)
:: alib32-libcanberra (0.30+2+gc0620e4-4) telepítése megtöri a 'lib32-libcanberra=0.30+2+gc0620e4-3' függőségét, amely lib32-libcanberra-gstreamer által szükséges
:: alibcanberra (0.30+2+gc0620e4-4) telepítése megtöri a 'libcanberra=0.30+2+gc0620e4-3' függőségét, amely libcanberra-gstreamer által szükséges