ut-bin segfault

 ( BaT | 2006. december 8., péntek - 19:07 )

UT GOTY-t próbálnék futtatni, de a fenti üzivel elszáll. (Pontosabban az üzi nem ez, de ez a lényege.) Sajna a lokis installer nem felelt meg tökéletesen (mindíg arra kér, h. mountoljam a cd-t, pedíg az mountolva van), ezért az anno q3-nál bevált módszert követem. Azaz a benne lévő .tar.gz-t tömörítem ki. Átmásoltam a wines telepítő cd-m tartalmát a /usr/local/games/ut könyvtárba, majd a kitömörített installer megfelelő fájljait bemásoltam a megfelelő helyekre. A könyvtárak neveinél mindíg az első betű nagy, a többi kicsi.
Lehet, hogy egy másik könyvtárnak nem ilyen névvel kellene léteznie?
Vagy esetleg egy .so file rossz, amit linkel, csak azt nem írja ki?

Egyébként az ucc help parancs ezt adja:

[tibi@localhost ut]$ ./ucc help
=======================================
ucc.exe: UnrealOS execution environment
Copyright 1999 Epic Games Inc
=======================================

Usage:
   ucc <command> <parameters>

Commands for "ucc":
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc
   ucc help <command>        Get help on a command

Az természetes, hogy nincsenek paraméterek? :)

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Nekem az UT installer mintha cd-rol telepitette volna a dolgokat :] De erre mar konkretan nem emlexem
---
Apple iMac 20" CTO / Core Duo 2GHz

ahoy,

próbálgasd az alábbi dolgokat:
- a home könyvtáradból töröld az .ut mappát
- próbáld hang nélkül indítani
- próbálj grafikai beállításokat változtatni az ini fájlokban
- nézd meg hogy minden so fájl megvan-e, vagy ha van másik ut-d (pl: 2003) akkor onnan másold át a so-t.

próba...

--
Unfortunately, no one can be told what The Matrix is. You have to see it for yourself.

Idézet:
Nekem az UT installer mintha cd-rol telepitette volna a dolgokat

Először átmásoltam a cd-t a megfelelő könyvtárba, aztán jöttek a telepítő filejai... :)

Na közben kiderítettem egy hibát: az egyik csomagban valami.u.0 fileok voltak és elfelejtettem őket átnevezni valami.u-ra. De most más problémái adódtak:

[root@localhost ut]# ./ut
The file '..\System\Engine.u' contains unrecognizable data
*** glibc detected *** ./ut-bin: free(): invalid pointer: 0xbfb4e768 ***
======= Backtrace: =========
/lib/libc.so.6[0x971efd]
/lib/libc.so.6(cfree+0x90)[0x975550]
./ut-bin(Realloc__11FMallocAnsiPvUiPCc+0x41)[0x804ec81]
======= Memory map: ========
00110000-001bf000 r-xp 00000000 00:15 25586      /mnt/adat/ut/System/Core.so
001bf000-001f1000 rwxp 000ae000 00:15 25586      /mnt/adat/ut/System/Core.so
001f1000-0027f000 rwxp 001f1000 00:00 0
0027f000-002cd000 r-xp 00000000 00:15 25553      /mnt/adat/ut/System/libSDL-1.1.so.0
002cd000-002d1000 rwxp 0004d000 00:15 25553      /mnt/adat/ut/System/libSDL-1.1.so.0
002d1000-0031e000 rwxp 002d1000 00:00 0
0031e000-0041c000 r-xp 00000000 03:43 164492     /usr/lib/libX11.so.6.2.0
0041c000-00420000 rwxp 000fe000 03:43 164492     /usr/lib/libX11.so.6.2.0
00420000-00423000 rwxp 00420000 00:00 0
00659000-0065a000 r-xp 00659000 00:00 0          [vdso]
00751000-00752000 rwxp 00751000 00:00 0
0079e000-0079f000 rwxp 0079e000 00:00 0
0089f000-008b1000 r-xp 00000000 03:43 834604     /lib/libnsl-2.5.so
008b1000-008b2000 r-xp 00012000 03:43 834604     /lib/libnsl-2.5.so
008b2000-008b3000 rwxp 00013000 03:43 834604     /lib/libnsl-2.5.so
008b3000-008b5000 rwxp 008b3000 00:00 0
008ef000-00908000 r-xp 00000000 03:43 832075     /lib/ld-2.5.so
00908000-00909000 r-xp 00018000 03:43 832075     /lib/ld-2.5.so
00909000-0090a000 rwxp 00019000 03:43 832075     /lib/ld-2.5.so
0090c000-00a43000 r-xp 00000000 03:43 832076     /lib/libc-2.5.so
00a43000-00a45000 r-xp 00137000 03:43 832076     /lib/libc-2.5.so
00a45000-00a46000 rwxp 00139000 03:43 832076     /lib/libc-2.5.so
00a46000-00a49000 rwxp 00a46000 00:00 0
00a4b000-00a4d000 r-xp 00000000 03:43 834579     /lib/libdl-2.5.so
00a4d000-00a4e000 r-xp 00001000 03:43 834579     /lib/libdl-2.5.so
00a4e000-00a4f000 rwxp 00002000 03:43 834579     /lib/libdl-2.5.so
00a51000-00a76000 r-xp 00000000 03:43 834578     /lib/libm-2.5.so
00a76000-00a77000 r-xp 00024000 03:43 834578     /lib/libm-2.5.so
00a77000-00a78000 rwxp 00025000 03:43 834578     /lib/libm-2.5.so
00a7a000-00a8d000 r-xp 00000000 03:43 834581     /lib/libpthread-2.5.so
00a8d000-00a8e000 r-xp 00012000 03:43 834581     /lib/libpthread-2.5.so
00a8e000-00a8f000 rwxp 00013000 03:43 834581     /lib/libpthread-2.5.so
00a8f000-00a91000 rwxp 00a8f000 00:00 0
00b3d000-00b3e000 rwxp 00b3d000 00:00 0
00bac000-00bae000 r-xp 00000000 03:43 896359     /usr/lib/libXau.so.6.0.0
00bae000-00baf000 rwxp 00001000 03:43 896359     /usr/lib/libXau.so.6.0.0
00bb1000-00bb6000 r-xp 00000000 03:43 896360     /usr/lib/libXdmcp.so.6.0.0
00bb6000-00bb7000 rwxp 00004000 03:43 896360     /usr/lib/libXdmcp.so.6.0.0
00bb9000-00bc8000 r-xp 00000000 03:43 166135     /usr/lib/libXext.so.6.4.0
00bc8000-00bc9000 rwxp 0000e000 03:43 166135     /usr/lib/libXext.so.6.4.0
00cb9000-00cc4000 r-xp 00000000 03:43 834582     /lib/libgcc_s-4.1.1-20061011.so.1
00cc4000-00cc5000 rwxp 0000a000 03:43 834582     /lib/libgcc_s-4.1.1-20061011.so.1
00ce9000-00e84000 r-xp 00000000 00:15 25575      /mnt/adat/ut/System/Engine.so
00e84000-00ee2000 rwxp 0019a000 00:15 25575      /mnt/adat/ut/System/Engine.so
00ee2000-00f42000 rwxp 00ee2000 00:00 0
08048000-0805a000 r-xp 00000000 00:15 25569      /mnt/adat/ut/System/ut-bin
0805a000-0805f000 rwxp 00011000 00:15 25569      /mnt/adat/ut/System/ut-bin
0805f000-08064000 rwxp 0805f000 00:00 0
081b6000-081f8000 rwxp 081b6000 00:00 0
b7e00000-b7e21000 rwxp b7e00000 00:00 0
b7e21000-b7f00000 --xp b7e21000 00:00 0
bfb3c000-bfb52000 rwxp bfb3c000 00:00 0          [stack]
Signal: SIGIOT [iot trap]
Aborting.

[root@localhost ut]#  

Nem tudom, lehet az a hiba, hogy kevés szabad memóm van? Vagy Úgy általában kevés memóm van? (256M) Szóval mi a hiba?

Valaki nem tudja nekem elküldeni az Engine.u fájlt? Bárhogy nézem, ez rosszul van meg eredetileg is... (Priviben küldök mailcímet, ha valaki lesz olyan kedves.)
Illetve libc-ből melyik verzió kell? :)

Ui: ne zavarjon meg, hogy /mnt/adat/ut, átmásoltam oda, hogy ne kelljen root jog a szerkesztgetésekhez...