Thunderbird - XML attachment error

Sziasztok!

Érdekes hibát produkál a Thunderbird. A levelezésben XML fájlt csatolok egy új levélhez. 
Elküldés után az xml fájl módosul egy rövid, 20-30 karakter hosszú sorral
(-------------- dXZxX3pvjmlmbzg880ZXQOez--) a végén. 

XML fájl:

<?xml version="1.0" encoding="Windows-1250"?>
<...>
akármi 
</> -------------- dXZxX3pvjmlmbzg880ZXQOez--

A legújabb verziót használom. 91.1.0 Az xml-t egy program generálja, eddig nem volt gond. 
Az elküldésnél egy automata olvasná be csak mivel megjelenik a végén a beszúrt kód ezért hibás a beolvasás.
Ezek a karakterek minden alkalommal megváltoznak, amikor e-mailt küldök. Letiltottam az összes 
bővítményt, és víruskeresést végeztem, de a hiba továbbra is fennáll. 
Miért van ez a kód a fájl végén? Miért ír bele a levelező az XML melléklethez küldéskor. 
Más fájltípusoknál nem találtunk ilyen hibát.

Köszönöm a segítséget

Hozzászólások

Én nézegettem régen ezeket a protokollokat, és rémlik, hogy ez egy "csatolt bináris tartalom vége" jelzőhoz hasonlít. Ha megnézed a levél nyers változatát, abban látszik ez, hogy hogy néz ki? Nem a fogadó oldali program rontja el a fájl kiolvasását?

Az a MIME határolósor, teljesen rendben van. A csatolt xml-fájlt "rendesen" leválasztva tökéletesen vissza fogod kapni.
Workaround: az xml fájl végére kerüljön sortörés (akkor külön sorban lesz a levél forrásában a határoló), és úgy már mókolhatod a MIME-os dolgokat figyelmen kívül hagyva. De célszerűbb valami értelmes nyelven feldolgozva kiszedni a csatolmányt a levélből.