"-bash: startx: parancs nem található

 ( Vad | 2017. április 14., péntek - 15:47 )

Három éve nyugger lettem, és hogy a szabadidőmben ne tétlenkedjek,és forgassam az agysejtjeimet ugy gondoltam, hogy meg kellene próbálkoznom a Gentoo telepítésével, mivel amugy linuxot (blackPanther és néha más linux disztrokat) használok egy ideje.
Elindultam Gentoo Wiki módban és közben az ott leirtakat a Youtub-ra felrakott videokkal ugymond összevetettem, igy gyakorlatban is követni tudtam a telepités menetét.
Az alaptelepítés problémamentesen(?) összejött, ujraindult a rendszer és innen már a jutubon https://www.youtube.com/watch?v=LsD8LqJKfm8 követtem a rendszer konfigurálását.

# emerge uvDNa world

40 óra alatt ez is lejött aztán:

# emerge -av xorg-drivers
# emerge -av xorg-server
# emerge twm xterm
# startx
bash: startx: parancs nem található
Visszatértam a Gentoo Wikihez és az ott idevágó leirás szeerint próbálkoztam de a helyzet nem változott...

Amugy pedig a CPU 2,8 GHz a ram 4GHz és NVIDIA GF9400 videokártya van a gépben.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

A xinit nem volt emergelve.
Most ujra emerge xorg-driver, stb...
Aztán kiderül...

__________________________________________________

Az "xinit" telepítése után lesz majd a "startx" parancsod. Egyébként a wiki írja is.

A képernyőn látható folyamatok biztatóak.Pillanatnyilag a plasma desktop emerdzselődik...

__________________________________________________

Már van "startx", viszont:

#startx
xauth: file /root/ .serverauth.10957 does not exist

aztán:
/root/.xinitrc: sor: 1: exec startkde: parancs nem található

De valójában ott van a .xinitrc-ben a "exec startkde

__________________________________________________

Gondolom, nem csak ennyi a terminál kimenete. Másrészt soha ne futtasd az X felületet rootként. Hozzál létre egy sima felhasználót.

Köszönöm, hogy figyelmeztettél arra, hogy rootként ne futtassam az X felületet. Ez volt a hiba, hogy rootként próbáltam. Sima felhasználóként elindult az X.
Megjelent 3 terminál és most már folytatom...

__________________________________________________

Hogy érteted, hogy megjelent a 3 terminál? A twm felületre gondoltál?

Egyébként mutathatnál egy "which startkde" kimenetet.

Ugye viccelsz?

A kérdéses hibaüzenet azt jelzi, hogy a .xinitrc-ben levő "exec startkde" futtatásával van a baj. Mivel az exec a bash beépített parancsa, marad az, hogy nem az exec, hanem az exec által indítandó startkde hiányzik.

=====
tl;dr
Egy-két mondatban leírnátok, hogy lehet ellopni egy bitcoin-t?

A .xinitrc-be beirtam az "exec startkde" parancsot. A startx-re megjelent kimenetben az volt, hogy: "/root/.xinitrc: sor: 1: exec startkde: parancs nem található". Én ezt ugy értelmeztem, hogy nincs ott a .xinitrc-ben a parancs és ez összefügg azzal, hogy a "startx"-re ezért nincs X. Viszont kde-desktop sem található.
Nem tudom mire értetted azt, hogy viccelek, arra, hogy az userként kiadott parancs müködott nálam, vagy?

Lehet, hogy az a hiba, hogy a tudatlanságomból eredően tegnap este elinditottam a "emerge --ask kde-plasma/plasma-desktop" parancsotm ami ma délután kernelpánikkal ért véget?

__________________________________________________

Azért gondoltam, hogy viccelsz, mert a "beírtam, hogy 'exec startkde' majd hiányolta, pedig ellenőriztem és tényleg ott van" kicsit olyan érzetet kelt, hogy szerinted a számítógép kitalálja, hogy te azt akartad odatenni. Mivel nem így van, egyszerű paraszti logikával is kitalálható, hogy a hibaüzenet *nem* ennek a sornak a hiányára utal.

=====
tl;dr
Egy-két mondatban leírnátok, hogy lehet ellopni egy bitcoin-t?

Délután kiderül, hogy a leírás szerint, arra odafigyelve végeztem e a telepítést.
Annyi bizonyos, hogy nem ráérös embereknek alkották meg a gentoo-t.
Magamon is csodálkozok, hogy nem lévén semmilyen informatikai képzettségem, belevágtam ebbe a projektbe.

__________________________________________________

Meg volt a kde teleepitése.
Éjfélre lett vége, és akkor kikapcsoltam a gépet mondván, majd reggel folytatom.
Erre mi történik?

Hiányzik az exec startkde!!!

Igy aztán ujra nincs X...

Közben kiderült, hogy valamit elbénáztam a tegnapelőtt. xinitrc átirásakor mert a exec startkde idézőjelben volt a.xinitrc-ben. Módosítottam és most rootként elindulás. Van KDE, de még nincs net, stb

__________________________________________________

Ha rootként elindul a kde akkor sima felhasználóként is el kell. A netre az a tippem, hogy nem ismeri fel a hálókártyád. Bár egy lspci kimenet segítene tisztában látni.

Most a rendszerinditás után:

!! Could not mount specified ROOT, try again
!! Could not find the ROOT blokk device in .
!! Please specify another value or:
!! - press Enter for the same
!! - type "shell" for a shell
!! - type "q" to skip...
root blokk device() ::_

__________________________________________________

Gondolom, boot közben írja ezt ki. Talán az fstab-ba van a hiba.

Igen, akkor írja, de hogyan jussak be ebben a helyzetben az fstab-ba?
A leállitáskor ez volt egyébként:
unable to exec '/etc/init.d/root' : input/output error

__________________________________________________

Szerintem a gentoo nem neked való.

még
de majd belejön

Meglehet, hogy nem nekem való. Említettem is, hogy nincs informatikai képzettség.
Még azt sem reméltem, hogy eljutottam a telepitésével addig, hogy van(volt) desktop. De nem adom fel, újra próbálom.
Így voltam az Arch linuxszal és a FreeBSD-vel is. Addig szenvedtem, hogy végül mindkettő sikerült, használtam is aztán mást próbáltam.
Ahogy kisbetu mondja, majd belejövök. Legfeljebb kitiltanak a fórumról a naiv kérdéseim miatt. De nem adom fel. Időm van!

__________________________________________________

Amiatt miért tiltanának ki? Azért van a fórum. Tanulás a cél? Mert használni bináris alapú disztribúció is épp megfelel, hackelni azt is lehet bőven, programozni is rá, de szerintem kevesebb a küzdelem vele, mint egy forrás alapú disztribúció esetében.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Boot-olsz egy live linuxot, felcsatolod a Gentoo root fs-ét valahova, kijavítod az fstab-ot.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Nem tudom, mennyire ment át Zahy üzenete számodra. Amikor hiányolta a startkde parancsot, akkor a bináris hiányzott. Éppen a .xinitrc-ben lévő exec startkde akarta volna futtatni, de nem volt mit. Vagy nem volt meg a startkde, vagy megvolt ugyan valahol, de a PATH környezeti változó által megadott elérési utak egyikén sem volt megtalálható.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

A Livecd-s megoldás bejött.
Nem soká bővebben!

__________________________________________________

Tulajdonképpen a Gparted-al mountoltam ujra és miután a Gparted cd-t leállitottam ujraindítás után már normális módon bootolt a rendszer.
Szerintem mikor root-ként nyomtam a startx-et bejött az asztal és ott mindjárt elkezdtem a billentyüzetet állitani, illetve a hálózatot próbálgatni, akkor azt talán nem kellett volna mert még voltak beállitani való dolgok amelyek most megtörténtek és most gyönyörü szépen müködik a rendszer, amire még sok alkalmazást kell telepiteni. Net van csak gui nincs a tálcán de most már a Gentoo Wiki lesz az olvasmányom.
Köszönöm a segitséget és a biztatást is, hogy nem nekem való a Gentoo, ami miat nem sértődtem, ellenkezőleg: csak azért is!
És össze jött!
Gondolom lesznek itt még számomra felfoghatatlannak tünő dolgok de mondtam, időm van!

__________________________________________________

Eddig minden rendben.
Raktam fel néhány alkalmazást -gimp, smplayer, firefox, kdenlive...
Mondjuk a dolphin körül valami nem oké, mert ha megnyitom vagy 120 dolphin ablak tapétázza ki a képernyőt...

Hogy pontos legyek: a Dolphinnal ha megnyitom pl egy USB-n lévő képet, vagy bármit, akkor kezdenek megnyilni a Dolphin ablakok.

__________________________________________________