Hálózat megakasztja a bootot

 ( osod88 | 2014. augusztus 7., csütörtök - 7:28 )

Debian 7.5, Poweredge t110
Boot megakad a configuring network interfaces... résznél.
Ha kikapcsolom biosban az alaplapi nic-et, továbbmegy.
Ha kikommentelem a /etc/network/interfaces-ben a vonatkozó sorokat, továbbmegy.
Ha boot után bejelentkezem és ifconfiggal beállítom az ip-t, tökéletesen működik dhcp-vel és anélkül is.
Van még egy teljesen ugyanilyen vas ugyanilyen debiannal ugyanúgy bekonfigolva, annak nincs ilyen problémája.

Mi lehet ez, hardverhiba?
[update: workaroundként tettem bele egy új pci-e hálókártyát. Most jó.]

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

subs

Hello

/var/log/messages-ből be tudnád másolni az ide vágó részt?
Az interfaces-ből a konfigot be tudod másolni?

rootként csinálsz majd egy dhclient -v eth0 parancsot? ( eth0-t gondoltam hálókarinak, csak ird be a sajátod. )

Üdv
T

Nézegettem azóta én is. Rémlik valami hogy volt már problémám egy tg3 modult használó hálókártyával.

/var/log/messages


root@file2:~# cat /var/log/messages | grep "eth0"
Aug 5 08:03:46 file2 kernel: [326588.679055] tg3 0000:04:00.0: eth0: Link is down
Aug 5 08:27:23 file2 kernel: [328005.295342] tg3 0000:04:00.0: eth0: Link is up at 1000 Mbps, full duplex
Aug 5 08:27:23 file2 kernel: [328005.295348] tg3 0000:04:00.0: eth0: Flow control is on for TX and on for RX
Aug 6 12:40:29 file2 kernel: [429534.552670] tg3 0000:04:00.0: eth0: Link is down
Aug 6 20:35:43 file2 kernel: [ 2.712139] tg3 0000:04:00.0: eth0: Tigon3 [partno(BCM95722) rev a200] (PCI Express) MAC address 00:26:b9:88:a7:b1
Aug 6 20:35:43 file2 kernel: [ 2.712146] tg3 0000:04:00.0: eth0: attached PHY is 5722/5756 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
Aug 6 20:35:43 file2 kernel: [ 2.712153] tg3 0000:04:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[1] TSOcap[1]
Aug 6 20:35:43 file2 kernel: [ 2.712158] tg3 0000:04:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
Aug 6 20:42:23 file2 kernel: [ 411.639893] ADDRCONF(NETDEV_UP): eth0: link is not ready
Aug 6 20:42:26 file2 kernel: [ 414.550950] tg3 0000:04:00.0: eth0: Link is up at 1000 Mbps, full duplex
Aug 6 20:42:26 file2 kernel: [ 414.550956] tg3 0000:04:00.0: eth0: Flow control is on for TX and on for RX
Aug 6 20:42:26 file2 kernel: [ 414.552088] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Aug 6 21:02:52 file2 kernel: [ 2.707521] tg3 0000:04:00.0: eth0: Tigon3 [partno(BCM95722) rev a200] (PCI Express) MAC address 00:26:b9:88:a7:b1
Aug 6 21:02:52 file2 kernel: [ 2.707526] tg3 0000:04:00.0: eth0: attached PHY is 5722/5756 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
Aug 6 21:02:52 file2 kernel: [ 2.707529] tg3 0000:04:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[1] TSOcap[1]
Aug 6 21:02:52 file2 kernel: [ 2.707532] tg3 0000:04:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
Aug 6 21:04:04 file2 kernel: [ 83.503079] ADDRCONF(NETDEV_UP): eth0: link is not ready
Aug 6 21:04:07 file2 kernel: [ 86.385894] tg3 0000:04:00.0: eth0: Link is up at 1000 Mbps, full duplex
Aug 6 21:04:07 file2 kernel: [ 86.385900] tg3 0000:04:00.0: eth0: Flow control is on for TX and on for RX
Aug 6 21:04:07 file2 kernel: [ 86.387028] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Aug 7 09:00:04 file2 kernel: [ 2.564314] tg3 0000:04:00.0: eth0: Tigon3 [partno(BCM95722) rev a200] (PCI Express) MAC address 00:26:b9:88:a7:b1
Aug 7 09:00:04 file2 kernel: [ 2.564317] tg3 0000:04:00.0: eth0: attached PHY is 5722/5756 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
Aug 7 09:00:04 file2 kernel: [ 2.564320] tg3 0000:04:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[1] TSOcap[1]
Aug 7 09:00:04 file2 kernel: [ 2.564322] tg3 0000:04:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
Aug 7 09:01:21 file2 kernel: [ 88.468722] ADDRCONF(NETDEV_UP): eth0: link is not ready
Aug 7 09:01:23 file2 kernel: [ 90.876765] tg3 0000:04:00.0: eth0: Link is up at 1000 Mbps, full duplex
Aug 7 09:01:23 file2 kernel: [ 90.876772] tg3 0000:04:00.0: eth0: Flow control is on for TX and on for RX
Aug 7 09:01:23 file2 kernel: [ 90.877901] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

Dhclient is megy.

root@file2:~# dhclient -v eth0
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/00:26:b9:88:a7:b1
Sending on LPF/eth0/00:26:b9:88:a7:b1
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPOFFER from 192.168.2.1
DHCPACK from 192.168.2.1
Reloading /etc/samba/smb.conf: smbd only.
bound to 192.168.2.25 -- renewal in 31519 seconds.
root@file2:~#

interfacesben csak ennyi van hogy:

allow-hotplug eth0
iface eth0 inet static
address 192.168.2.199
netmask 255.255.255.0
gateway 192.168.2.1
Miután megakad a configuring network résznél induláskor, bebootoltam egy live linuxot és kikommenteltem a fentebbi sorokat hogy ne próbálkozzon.

Slusszpoén, hogy knoppix alatt semmi gond nincs a hálóval.

Változik valami, ha az allow-hotplug eth0 helyére auto eth0 kerül?

Holnap kipróbálom ha a gép mellett leszek, nem jó ómen az ilyesmit ssh-n piszkálni. :)

Semmi nem változik ettől. A másik vason ugyanez az interfaces file tartalma (kivéve az ip cím persze).

A szükségmegoldásként betett új hálókártyával is elkezdte ezt a bulit.
Ugyanazok a tünetek, a configuring network interfacesnél megáll a tudomány.
Interfacesben kikommentelve, és utána kézzel felhúzva a hálózatot, hibátlan.
Most már ötletem sincs mi lehet a gondja.

Mennyit vársz boot során ? Idővel sem tudja folytatni ? CTR+ALT+DEL -re simán újraindul ilyenkor ?

Esetleg megpróbálnám a firmware-bnx2 telepítését...azt hiszem az való a hálókártyádhoz
(linux-firmware-free és non-free esetleg)

Órák után sem megy tovább. Crtl+alt+delre semmi, egyedül a "magic sysrq" kombókkal lehet lelőni vagy újraindítani vagy a power gombbal.Nonfree firmware csomagok fent vannak már, a másik gépen is. Arra jutottam eddig hogy döglődik az új hálókártya is.

Rosszul hangzik....
Az az érdekes, hogy más OS-el meg megy rendesen a cucc (ha jól értem)
Udev Hal környékén nézelődtél már?

Igen, jól érted, pl. knoppix-szal csont nélkül, de inquisitorral is nyúztam 24+ órát ami szintén debian alapú. Az udev témának utána kell olvassak, még nem volt vele dolgom.