Fedora 32

Elérhető a Fedora 32! Részletek a bejelentésben és a kiadási megjegyzésekben. Letölthető innen.

Hozzászólások

Már dolgozunk is rajta, hogy leforduljon a projektünk rajta, ha megvan akkor jöhet GCC 10 azaz a C++ 20!

A cégnél a Fedora a standard operációs rendszer fejlesztőknek, sőt a hivatalos binárisok is fedorán fordulnak az összes támogatott platformra.

:wq

Hogy érted, hogy ha megvan? Ha lefordul rajta, akkor az már a 10-es GCC-vel fordul szerintem:

gcc --version
gcc (GCC) 10.0.1 20200328 (Red Hat 10.0.1-0.11)
Copyright (C) 2020 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Úgy értettem, hogy egyik kollégám foglalkozik azzal, hogy elsimítsa a fordulási problémákat. A GCC10 egy kicsit jobb lett egyes warningok megszegéseinek megtalálásában (pl. -Wunused-result), illetve általában minden új GCC verzió talál valamit ami nem tetszik neki (mivel szigorúbb lesz). Továbbá az új Fedora új függőség verziókat is jelent ami szintén tud gubancot okozni. Ahogy ezek el lesznek simítva, hivatalosan is a GCC10 lesz a fő támogatott fordító verzió. Egy ideig még támogatni fogjuk a GCC9-et is, mert nem mindenki updateol első nap.

:wq

Tegnap megnéztem és mondom feltelepítem. Furcsa volt, hogy a telepítőben nincs magyar nyelv (kifelejtették szerintem, mert a Fedora 31-ben volt). Angolul végig lehet pörgetni, csak utána még manuálisan át kell állítani majd a lokalizációkat, hogy magyar legyen minden.

Akkor mégis van 32-bites támogatás? ;)

Szerkesztve: 2020. 04. 29., sze - 12:27

Mondok róla tapasztalatot. Szokás szerint a megjelenés előtt upgrade-eltem, használom már egy hónapja. Volt egy xorg-x11-drv-intel bug, azóta megjavult. Viszont épp mostanában frissítettem távolról két gépet, a SELinux relabel, vagy valami ilyesmi beakadt neki, mert az lett a következmény, hogy mobiltelefont nem lehetett USB-n mastorage device-ként csatolni, illetve nem engedett be ssh-n távolról. A megoldás az lett, hogy telefonos segítséggel kértem a gépek gazdáit, hogy mondják neki root joggal:

: >/.autorelabel
sync
reboot

Megcsinálta az újracímkézést, utána minden működött, ideértve a mobiltelefont, távoli elérést ssh-n.

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Az egyik gépen azért beleszaladtam egy hibába ami tulajdonképpen nem hiba túl jó a rendszer :)

Most guglizok, mert azon a gépen ez gond.

 

Probléma 1: conflicting requests
  - nothing provides libgstreamer-0.10.so.0()(64bit) needed by AfterShotPro3-360380:3.6-0.380.x86_64
  - nothing provides libgstapp-0.10.so.0()(64bit) needed by AfterShotPro3-360380:3.6-0.380.x86_64
 Probléma 2: conflicting requests
  - nothing provides wxPython >= 2.8.11 needed by DisplayCAL-3.8.9.3-1.1.x86_64
  - nothing provides python2-gobject needed by DisplayCAL-3.8.9.3-1.1.x86_64

Szerkesztve: 2020. 04. 29., sze - 17:55

:)

A sajgó szívem egyik fele a bankkártyám amivel megvettem a programot. :)

Szerintem lesz upgrade AfterShot-ra,  addig Darktable ami jó, de nem tudom megszokni.... ez persze már az én problémám.

Akkor lassan upgradelni kell 30-ról 31-re.

"Sose a gép a hülye."

Nem szeretem a debian alapú rendszereket.

Egyébként nem megy az upgrade, valami fostos, de nem is értem:

terminate called after throwing an instance of 'libdnf::ModulePackageContainer::EnableMultipleStreamsException'
  what():  Cannot enable multiple streams for module 'maven'
Aborted

Ezelőtt a gimp-re panaszkodott ugyanígy, azt leszedtem. De ilyen maven nincs is fent...

"Sose a gép a hülye."

Igen, ez megoldotta. A gimp-et meg visszarakam upgrade után.

Egyelőre úgy tűnik, hogy minden jó, leszámítva hogy a firefoxban és a thunderbirdben nem jó a font smoothing, a szemem kifolyik, és a pride minden színében játszik a betűk széle. Erre van megoldás? Hihetetlen, hogy ilyen apró hülyeségek időről időre előjönnek.

"Sose a gép a hülye."

Az megvan, azt nyomkodtam elsőre, semmit nem használt... Illetve de, még rosszabb lett. Ami érdekes, hogy a laptopon meg jó volt alapból. Csak a próbaképpen elkezdtem ott is állítgatni, hogy RGB, BGR, meg gyenge, közepes, full hinting, minden kombó amit találtam... És ennek hála most már ott se jó. Van szar, meg még szarabb.

"Sose a gép a hülye."

Egyébként nem tudom hova tenni, mert bármi más GTK-s app jó. GIMP, GNUCash...

De ugyanolyan megmagyarázhatatlan, mint ez a problémám volt: https://hup.hu/node/158048

A firefoxnak és thunderbirdnek ezt a gfx.colormanagement értékét csak az asztali gépen kellett állítani, a laptopon jó.

Ott érdekes a dolog, hogy teljesen ugyanaz a két rendszer. Anno egyszerre telepítettem őket. Ugyanazok a csomagok vannak feltelepítve (van erre egy scriptem, ami időnként összehasonlítja még a telepített csomagok verzióit is, és eszerint szoktam egyik vagy másik oldalt "korrigálni"), ha frissítek egyszerre frissítem őket, ugyanazokat a programokat használom, ugyanúgy van a desktop és minden dolog beállítva. Jelentéktelen dolgokban különböznek, pl. az iwl-wifi firmware csomag nincs a desktopon. Ennek ellenére nem viselkednek egyformán.

"Sose a gép a hülye."

Az about:config-ban ilyeneket találtam:

gfx.text.subpixel-position.force-disabled false
gfx.text.subpixel-position.force-enabled false
gfx.webrender.quality.force-disable-sacrificing-subpixel-aa false

Persze lehet, hogy van más is, csak rossz string töredékkel kerestem.

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Találtam közben egy régi fonts.conf mentést, volt már ezzel szívás évekkel ezelőtt is. Beraktam, jó lett.

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintslight</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
  <match target="font">
  <edit mode="assign" name="lcdfilter">
    <const>lcddefault</const>
  </edit>
  </match>
</fontconfig>

Imádom, amikor kreálnak valamihez egy csilivili GUI-s beállító szart, amivel csak elkúrni lehet a beállításokat.

"Sose a gép a hülye."

Szerkesztve: 2020. 05. 01., p - 10:59

Idáig Debian/Ubuntu vonalon mozogtam (volt Arch is), most már csak kipróbálok egy rpm disztrót is élesben. Tegnap VirtualBox-ban telepítettem egy Fedora 32-t, egész pofás.

szerk.: Alapjában véve nem volt vele semmi gond. Tetszik, hogy a Gnome a Fedora-ban a legjobban összecsiszolt és a legfrissebb. Érezhetően jól össze van rakva. Feltelepítettem pár programot: Steam (egy kis Path of Exile), KiCAD, BricsCAD, nagyon szépen ment minden.

Még mindig kényelmesebben érzem magam deb környezetben, ez viszont nem a Fedora hibája. Vissza Debian Bullseye-ra...

Ez megszokás kérdése. A csomagkezelésből, különféle biztonsági megoldásokból - pl. SELinux - jönnek bizonyos problémákra megoldások, amelyeket az ember az egyik rendszer alatt rutinból tud, nem is tekinti problémának, a másikon meg doksi olvasós, gondolkodós, küzdős. Mivel lényegében ugyanazokhoz a nyílt forrású software-ekhez lehet hozzájutni bármelyik nagyobb rendszerrel, nem látom értelmét annak, hogy egy számomra kevésbé ismert rendszert kezdjek használni. Így aztán Fedora Core 1 óta használok Fedorát, Előtte volt nekem Red Hat 7.2, 7.3, 8.0, 9. Ez a régi Red Hat talán 2001 környékéről, nem az RHEL.

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Hova lett a magyar nyelv? Installnál a listában nem találom.

robyboy

Nincs a telepítőben. Már jeleztem a bug-ot és dolgoznak rajta. Szerintem véletlenül kimaradt.
Amúgy nem nagy cucc:

Telepítés után:

#localectl set-locale LANG=hu_HU.UTF-8

majd a Gnome settings-ben a nyelv átállítása, és kész is. A könyvtárakat is felajánlja, hogy átnevezi magyarra.

Nos, frissítettem én is 32-re.

Semmi gond nem volt, a szokásos unalmas 20-30 perc.

 

Csak egy problémám akadt, amióta használom.

mpv átkerült az rpmfusion-free-release tárolóba, és a Waylanddel nem is műxik.

mpv --hwdec=auto --gpu-context=wayland parancs helyett csak így megy mpv --hwdec=auto --gpu-context=x11 a lejátszás.

 

Egyelőre minden más megy, ahogy eddig...

nTOMasz
"The hardest thing in this world is to live in it!"

Nekem eddig a wayland kimaradt az életemből. Egyrészt régi a VGA kártyám, másrészt Xfce+Compizt használok, s az a gyanúm, a wayland új GPU-val és csak Gnome-on támogatott. Bár nem tudom. Külön nem forszíroztam az X11-et, de eddig minden distupgrade után maradt a Xorg.

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Nekem az előző parancssorod is megy, meg ez is megy. (OpenSuse - AMD APU)

Viszont lejátszáskor -- mindkét esetben -- van egy érdekes sor a terminálablakban mustárzöld színnel írva:

[vo/gpu/wayland] GNOME's wayland compositor is known to have many serious issues with mpv. Switch to GNOME's xorg session for the best experience.

Jópofa kis megjegyzés... :-) Ettől függetlenül a lejátszás tökéletesen működik.