Háttérkép beállítás GPO-val (AD)

 ( cstommy | 2019. július 1., hétfő - 21:02 )

Üdvözlet!
(Lehet hogy már volt a téma, de nekem nagyon sok fejfájást okozott, ezért kérem legyünk kíméletesek)

Adott egy Windows Server 2016, AD-DC.
Van rajta egy tartomány, azon bellül 2 nagyobb szervezetiegység (mindegy, hogy mi a nevük. Legyenek A és B).
Szeretném ezeknek beállítani ugyanazt a háttérképet GPO-val, de az istennek se sikerül!!!!

Mind a két szervezetiegységnek van 1-1 GPO-ja, ami jelen pillanatban nem tér el túlzottan egymástól.
Ezekben be van állítva a szokásos két opció a tapéta, és a loopback processing mode (bocs, hogy keverve van az angol meg a magyar, a szerver magyar, de hirtelen csak angolul találtam meg az opciók nevét).

Haverom utasításait követtem, akinél ez a kettő van beállítva és működik a háttér változtatás. Nálam csak fekete képernyő van… :(
A kép egy JPEG, amit a \\szerver\netlogon\bg.jpg útvonalon érhető el…

Mi a hiba? Mit kéne máshogy csinálni?
Haver szerint az a gond, hogy userekre akarom beállítani a GPO-t, szerinte gépekre kellene (megjegyzem azokra is be lett már állítva, de semmi haszna).
Azért nem a Default-ba állítottam be, mert van 1-2 gép amire nem akarom alkalmazni a beállítást. De ez gondolom nem is annyira lényeges.

Egyszerű dolognak tűnik és én még is már hónapok óta szenvedek vele…

Szánjatok meg egy kis segítséggel :)
Köszi :)

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Nálam úgy működik, hogy felmásolom a háttérképet a gépek saját meghajtójára, majd a háttérképet onnan tölti be a GPO, nem hálózati megosztásról.

+1 - bár konkrétan ilyesmit nem csináltam még, de általánosságban elég háklis rá a Win (bármelyik verziója), hogy az aktuális háttérkép helyi diszken legyen elérhető.

----------------------------------^v--------------------------------------
"Probléma esetén nyomják meg a piros gombot és nyugodjanak békében!"

gpresult és/vagy eseménynapló mond valamit?

Egyébként én már W7-tel se tudtam ezt működésre bírni, úgyhogy megnéztem, hogy hova pakolja a beállított hátteret (TranscodedWallpaper.jpg [ill. talán W10 már nem használt kiterjesztést?]), aztán Group Policy Files-al felülírattam... második bejelentkezéstől stimmelt. (W10-re még nem szántam rá magam, hogy frissítsem, de elvileg csak a kiterjesztést szedték le a fájlról)

BlackY
--
"en is amikor bejovok dolgozni, nem egy pc-t [..] kapcsolok be, hanem a mainframe-et..." (sj)

A gpresult és/vagy eseménynaplót még nem netztem meg, de tapasztalatom szerint ilyen esetekben nem szokott eredményre vezetni…

A helyi gépre másolás (vagy az ottani kép lecserélése) egész jó ötletnek tűnik, majd ha visszatértem a szabadságomról akkor kipróbálom.

Én egyébként azon gondolkoztam, hogy nem-e azzal van a baj hogy a netlogonba másoltam fel az eredetit…?

Érdekesség képen megjegyzem, hogy a kb 600 user közül csak 1-nél működik rendesen a beállítás, de semmi plussz joga vagy előnye nincs ami ezt indokolná…

Idézet:
Én egyébként azon gondolkoztam, hogy nem-e azzal van a baj hogy a netlogonba másoltam fel az eredetit…?

Akár lehet is, én a sysvol-on belül a GPO mappájába szoktam betenni.

Idézet:
a kb 600 user közül csak 1-nél működik rendesen a beállítás, de semmi plussz joga vagy előnye nincs ami ezt indokolná…

Sötétben tapogatózás, de vótmá, hogy bejött itt a HUP-on: nem valami patcheletlen Win7, a többi pedig naprakész és be van állítva biztonsági szűrés a GPO-ra? (volt valami biztonsági hiba pár éve a GPO feldolgozásban, amit azzal oldottak meg, hogy nem a user hitelesíti magát a szerveren, hanem a kliensgép szedi le az összes GPO-t és alkalmazza a megfelelőket a userekre - csak ugye ez eltörte a biztonsági szűrést, ha a domain computers-nek nincs joga olvasni a GPO-t)

BlackY
--
"en is amikor bejovok dolgozni, nem egy pc-t [..] kapcsolok be, hanem a mainframe-et..." (sj)

Nem lőttél annyira mellé, mert egy Win8.1, de igazából frissítve van az a gép is.
(A többit meg kb félévente újra húzom, friss win 10-el)

Na, gyorsan rákerestem, minden 7 és utáni verzióra jött ki hozzá patch, 10-eknél meg ugye az azóta megjelent nagy verziók már tartalmazzák (amúgy 8.1-re ő az: https://support.microsoft.com/en-us/help/3159398).
De ha nincs security filtering, akkor majdnem biztos, hogy nem ez az (bár a symptoms-nál leírt

Idézet:
All user Group Policy, including those that have been security filtered on user accounts or security groups

akár lehet is)

BlackY
--
"en is amikor bejovok dolgozni, nem egy pc-t [..] kapcsolok be, hanem a mainframe-et..." (sj)

És ha ez a security filtering okozza a hibát akkor ezt hogyan tudom biztonságosan megkerülni/kikapcsolni/átállítani???

A GPO-nál vedd fel a Domain Computers-t is azok közé, akikre "vonatkozik" (a jelentése már megváltozott, a magyarázó szöveg még ez maradt a GP editorban). Ha nem volt szűrés rá beállítva (tehát a default Authenticated Users-re érvényes), akkor nem ez a gond (a számítógépek is Authenticated User-ek)

BlackY
--
"en is amikor bejovok dolgozni, nem egy pc-t [..] kapcsolok be, hanem a mainframe-et..." (sj)

Ajjaj, most már így értem, hogy mire gondoltál, és attól tartok hogy akkor nem ez lesz a gond mert abban biztos vagyok, hogy a default Authenticated Users-re érvényes…

A háttérkép a user policy része nálunk, de kell pár restart mire magához tér és alkalmazza addig fekete kép van, mert azt látja, hogy van valami de nem tudja mi.