OpenWrt/LEDE regresszió

Kezdetben volt az ar71xx architektúra. Ezzel minden működött, legalább is ami a TL-WR842N v3 routeremet illeti. Aztán lett az ath79, ebben bemutatkozott egy roppant bosszantó bug. Elsősorban nagyobb adatforgalomnál - pl. oprendszer frissítés - eldobta a WAN oldali kapcsolatot. Néha meggyógyult, néha kellett a reboot. Asztal alá nem kellett mászni, mert a LAN oldal élt, be lehetett rá ssh-zni. Aztán ez nem egyik javításról a másikra javult meg, de egyre jobb lett. Nagyjából 4.19.101 környékétől elfogadható. 4.19.108 már kifejezetten jó volt. Aztán jött 4.19.115, és ott tartok, hogy online rádiót sem tudok hallgatni, gyakran dobálja a kapcsolatot. Ezt úgy kell érteni, hogy 10 percen belül.

Most szépen visszateszem az előző image-et, amelyet még 4.19.108-cal készítettem. :(

Hozzászólások

Nekem nagyon ellentmondás, hogy a router szoftver inkább firmware mintsem oprendszer. Kövezzetek meg, de én azon a véleményen vagyok, hogy csak akkor érdemes upgradelni, ha valami új szolgáltatás kell.
Értem, hogy a régi firmware biztonsági szempontból nem felel meg fontosabb helyeken, de ha ez felmerül akkor viszont lehet a vasat kell először cserélni és aztán jöhet a firmware.

Szerintem tedd fel azt amivel jól működik és ha gond van vele, gondolkozz egy új router megvásárlásában.

* Én egy indián vagyok. Minden indián hazudik.

Szerkesztve: 2020. 04. 19., v - 13:57

Üdv a klubban!

Amióta újra összeálltak a LEDE-vel, és átvették tőlük ezt a "gyakori új főverzió" stratégiát, olyan trágya lett az egész, hogy az felfoghatatlan.

Mutasson valaki nekem egy olyan ar71xx-es eszközt, amin egyszerre, és stabilan képes működni a három interface: Lan, WAN, WLAN, mert, ha éppen működik a wifi, akkor előjönnek ezek a wan problémák....

Ha meg bejelented nekik, a hivatalos csatornán, hogy nálad ez-az nem működik, ráadásul, veszed a fáradtságot, és lehetőségekhez képest kidebugolod, küldesz nekik logot, és egyéb kimeneteket, leírod, hogyan lehet reprodukálni, akkor meg közlik, hogy "ő ezt kipróbálta, nála prímán megy minden, semmi hiba, és különben is, már kikapcsolta a teszt eszközét, nem fogja újra elővenni", ha meg egy hét múlva ismét jelentkezel, hogy "bocs, de egy másik eszközömön is vacakol", akkor meg kérdés nélkül egyszerűen kitiltják a accountodat a bug gyűjtő fórumról...

Arra meg ezerrel pazarolják az energiát, hogy az Ubiquity, és egyéb ilyen eszköz fullosan támogatottá váljon, miközben az ilyen széles körben használt eszközök, mint a TP-Link Atheros-os routerei meg le vannak szarva. (Ha nézel git logot, láthatod)

 

Na, ezért trágya.

latest 19.0x-en archer c7 v5-on nincs gondom egyelore (ath79, kopp-kopp)

Néha rámjön, h mégiscsak frissíteni kéne már owrt-t, de aztán hamar elhessegetem magamtól gondolatot egy orbitális szívás rémképével: jó az ahogy van, működik, ne bántsuk! 

Mindig ez a verziófétis :>

Csak egy pelda :P

root@openwrt:~# uname -a
Linux openwrt 2.6.26.8 #1 Fri Feb 12 18:03:05 CET 2010 mips unknown

Mai napig uzemel, kb sose hallottunk hogy gond lenne vele :D Már arra se emlékszem ez milyen platform. Bár cpuinfo szerint system type        : Atheros AR2317 Ha tippelnem kéne akkor D-Link DIR-300 :>

Fedora 32, Thinkpad x220

Szerkesztve: 2020. 04. 20., h - 07:16

OpenWrt a rengeteg bugos backportos hülyeségével a sírba kerget engem is néha. Véletlenül sem tudnák a kernelnek megfelelő modult szállítani (sőt lehetőség sincs rá, csak saját fordítással és tucat hackkel), a backportost meg senki sem teszteli. Egyik verzióban nem jön fel interfész, másikban már opkg install a csomagra kernel panic-ot eredményez..

Ha bárki tud olyan OpenWrt/LEDE verziót az elmúlt 3-4 évből, amiben normálisan működik a kmod-mac80211-hwsim, az ne tartsa magában! :) 

Van már hozzá friss, ropogós 5.4.50-es kernel. Részlet a dmesg-ből:

[ 5674.869963] eth1: link up (100Mbps/Full duplex)
[ 6058.867144] eth1: link down
[ 6059.892890] eth1: link up (100Mbps/Full duplex)
[ 6399.858374] eth1: link down
[ 6400.884190] eth1: link up (100Mbps/Full duplex)
[ 6511.474100] eth1: link down
[ 6512.499766] eth1: link up (100Mbps/Full duplex)
[ 6569.841798] eth1: link down
[ 6570.867712] eth1: link up (100Mbps/Full duplex)
[ 6578.034095] eth1: link down
[ 6579.059600] eth1: link up (100Mbps/Full duplex)
[ 6689.649005] eth1: link down
[ 6690.674828] eth1: link up (100Mbps/Full duplex)
[ 6758.256858] eth1: link down
[ 6759.282615] eth1: link up (100Mbps/Full duplex)
[ 7031.663969] eth1: link down
[ 7032.689781] eth1: link up (100Mbps/Full duplex)
[ 7124.847693] eth1: link down
[ 7125.873501] eth1: link up (100Mbps/Full duplex)
[ 7158.639574] eth1: link down

Valami azt súgja, még nem tökéletes. :(

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Érdemes lenne listát vezetni arról melyik router modellre melyik azaz utolsó OpenWrt verzió, amivel még használható. 

5.4.51-gyel sem sokkal jobb. Szubjektív érzés alapján mintha ritkábban dobálná a linket, de ez még mindig borzalmas:

[  250.597710] eth1: link down
[  251.653070] eth1: link up (100Mbps/Full duplex)
[  287.558625] eth1: link down
[  288.587386] eth1: link up (100Mbps/Full duplex)
[  301.990029] eth1: link down
[  303.015579] eth1: link up (100Mbps/Full duplex)
[  384.100614] eth1: link down
[  385.126206] eth1: link up (100Mbps/Full duplex)
[  604.259472] eth1: link down
[  605.285171] eth1: link up (100Mbps/Full duplex)
[ 1359.966964] eth1: link down
[ 1360.992686] eth1: link up (100Mbps/Full duplex)
[ 1387.615115] eth1: link down
[ 1388.640853] eth1: link up (100Mbps/Full duplex)

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE