Frugalware Linux

Catalyst telepítése sikertelen Frugal 1.5

Fórumok

Sziasztok!
Felraktam a Frugalware 1.5 32 bites változatát, de a catalyst nem működik rajta. Mikor felraktam a catalyst utána már a KDE is effektek nélkül jött be. Azután tovább próbálkoztam a terminálból egy aticonfig --initial parancsal aminek az lett az eredménye, hogy a Frugal helyett fekete képernyő jön be.
A Frugal grubja csak a root particiójába van, Arch grub2 van az MRB-be.
Sapphire HD 4670 kártyám van.
Hogyan lehetne helyes működésre bírni?
xorg.conf
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Frugalware Repo alapkérdések?

Fórumok

Sziasztok
Olvastam hogy a Frugalwarenak van az aurhoz hasonló repója a Repoman.
Van-e ezen kívül bármilyen más repo hozzá?
Van-e hozzá olyan csomagkezelő ami egyszerre frissítené az alap tárolóba lévő szoftvereket és a repomanból telepítetteket(olyan yaourt szerűre gondoltam)?
A 64bites változathoz van-e wine és multilib vagy magamnak kell fordítani?
A repomanba bele tudok-e tekinteni a netről vagy csak Frugalból lehet?

WiCD és a DBus néha elfelejti egymást[update]

Fórumok

Érdekes dolog: Alapvetően a WiCD fut békésen, még csomagtelepítés után is. Ellenben ha suspend(toram) vagy reboot után csatlakozni akarok (telepítés után), használhatatlanná válik, restart után is. Rebootok nem oldják meg, sem .service kreálása, ellenben egy második restart... Kissé zavaró, de vajon komoly és mély probléma, vagy szimplán egyéni balfaszkodás eredményezte?
Közben kicsit el kellett mennem. Most már egyáltalán nem hajlandó a wicd elindulni, folyton arra panaszkodik, hogy nem szolgáltat semmi .service fájl org.wicd.daemon nevet. Próbáltam csinálni ilyet, de akkor is nyavalygott, csak az exec miatt. Most jobb híján összekalapáltam egy wpa_supplicant.conf fájlt, onnan sikerült megjönnöm. Mostmár eléggé zavaró, sőt enyhén irritáló szokás. :( Mijafaszbajavan?

Linux (Frugalware-ppc) vs IBM RS/6000

Fórumok

Egy POWER3-II CHRP masinan a kovetkezo pontig jutottunk a Frugalware ppc(32) portjaval (Frugalware verzio: 1.3, yaboot 1.3.14):

Open Firmware-be az SMS menu > Multiboot > ... OK Prompt segitsegevel vagy meg a firmware boot folyamat vegen, a banner utan a 8/F8 billentyukkel kozvetlenul lehet belepni.

Ha hibasan irjuk be a boot parancsot, a gepet poweroff/poweron cikluson at ujra kell inditani.

Yaboot-ba a kovetkezovel sikerult bejutni:

0 > boot cdrom:\boot\yaboot\yaboot

Hibauzenetek:

OpenFirmware:

* DEFAULT CATCH!, code=fff00700 at #SRR0: 00000014 #SRR1: 00083000
-- invalid cmdline, poweroff/on es ujbol beirni
* Unable to use memory at load-base
-- setenv load-base 1000000 (?)
* CLAIM failed
-- tobbszor ismetlodo hibak, poweroff/on

Yaboot:

* boot: Not a valid ELF image
* Config file error: Token is too long near line 0 in file
Syntax error or read error config

Talaltam egy egesz jo OFW referenciat itt.

Az egyik boot utan a LED panel is beallt a kovetkezo koddal: 450000C3 (P1), ez a manual szerint "Memory controller subsystem internal error. (checkstop)"

Szoval a yabootba sikerult bejutni, de onnan a konfigot nem sikerult beolvasni.

1.3 kérdések

Fórumok

Sziasztok!

Telepítettem a Haven-t ( amd64 ), és volna pár kérdésem. rt61-es wlan van a notimban, és egyelőre nem muzsikál. Lehet-e tudni, hogy mit is kell tenni ez ügyben. Hogyan lehet beállítani, hogy a numlock ne kapcsoljon be ( mivel a noti-n csak a FN+ gombokkal érhető el a numpad, ezért így zavaró ). Illetve grafikus shutdown-nál kéri a root jelszót ( ez nem feltétlenül baj, viszont csak az 1-es karakteres terminál loginjéhez lő ki, nem kapcsolja ki a gépet ). Ha GUI alatt indítok egy konsole-t és root módban azt mondom, hogy "poweroff", akkor kikapcsol, de szeretném a hagyományos módszert.

Előre is köszönöm a válaszokat.

U-dash

Frugalware mennyire jó kezdőnek

Fórumok

Nen tudom, mennyire jó a Frugaware a kezdőknek. Én ikább felteszem, de ha jó neki és jól sikerül konfigurálni megcsinálom én, és persze ha valami akkor kijavítom és beállítom és jó lesz, akkor mennyi a valószínűsége ,hogy a "javítást" önhatalmulag elkezdi az illető (pedig mondtam neki ,hogy megcsinálom ) Nem szeretném álladóan újra configolni.
Ha elkezd javítani, nekem több munkám lesz valószínű, mint ahogy az elején volt.
A másik a Debian, sokkal könnyeb bekonfigurálni.Az amit én szeretnék.
Azt is megcsinálom csak abba is ha belenyúl és ez is kicsit több idő mint amennyi idő alatt felrakom és beállítom, mert helyre kell hozni.
Csak nagyon nehéz beszélni, tanácsot adni, mert nagyon okos ember, ő mindent jobban tud.
Ha van valami ötletek, minden megoldás érdekel

cputerheltség közel 100% [elhárítva-de nem megoldva]

Fórumok

Sziasztok!

Két napja előjött egy olyan probléma a Frugalware 1.2-es rendszeremen, hogy akár bekapcsolás/újraindítást követően azonnal 90-100% között van a cpu terheltsége.

A top szerint az első 3-ban az 'X', a 'kwin' és a 'plasma-desktop' szerepel, mind legalább 20%-os cpufoglalással, de nem ritkán 30% fölé is megy mindhárom processz.

Van valakinek ötlete rá?

Másik dolog:
frissítettem a rendszert a 'Gfpm' segítségével. Lefutott a frissítés, a kernel is frissült a 2.6.32 fw3-ról 4-re, azonban rendszerindításkor a régi töltődik be, fel sem ajánlja a választást, hogy melyiket akarom indítani.

Biztosan frissült, mert a csomagkezelő már azt írja, hogy naprakész...

Erre van ötlet?

Net_gond

Fórumok

Sziasztok!

Néhány hete a Frugalware 1.2 (Locris) rendszert használom. Örömmel tapasztalta, hogy a telepítője megjavult, csont nélkül felment a rendszer.

Azonban egy érdekes problémára bukkantam:

Sokáig tartó netkapcsolat esetén (órák, fél nap, mikor hogy) a böngészés egy idő után elképesztően lelassul, az oldalak többsége időtúllépéssel elszáll.
Próbáltam a Firefox legfrissebb, ill. korábbi változataival, valamint Konquerorral is ugyanez a helyzet.

Maga a net megy, mert a Gfpm tud kapcsolódni a tárolóhoz, igaz, ez is nagyon lassan, illetve a torrent is megy.

Ilyenkor a gép újraindítását követően minden tökéletesen helyreáll. (Duál bootos rendszer lévén a másik rendszeren nem jelentkezik ez a gond.)

Hogy lehetne kideríteni, hogy mi a probléma?

Wicd leszakad kapcsolódákor (megoldódott)

Fórumok

Érdekes jelenséget produkált tegnap este a Frugal. Miután hazaértem, nem volt hajlandó a Wicd elindulni,mondván nem megfelelő privilégiumokkal fut. (Előtte pár órával még nm volt gond, a laborban dolgoztam is vele.) Kis kutatás után kiderült, hogy policykit problémái vannak. Ezt helyrehoztam, de azóta a wicd, habár meglátja a hálózatot, erősen ingadozó jelet vesz róla, csatlakozásközben pedig, közvetlenül, mielőtt a kapcsolat létrejönne, bejelenti, hogy az elérési pont nem létezik. Mi több, kis ideig nem is hajlandó látni. Rájönni sem tudok, mi lehet a gond, remélem, nem hardveres. Tud valaki segíteni?
Hm. Közben helyrejött. A legérdekesebb, hogy a logokban sem átok semmi differenciát, ami felette zavar. Át kéne néznem a router logjait is.

.bash_logout hogyan

Fórumok

hali!

A neten olvasgatva azt találtam, hogy ha van valami amit szeretnénk, hogy a kilépéskor hajtódjon végre, akkor azt - a $HOME/.bash_login mintájára - a $HOME/.bash_logout-ba kell beleírni.

így tettem, de nekem nem hajtódik végre. A .bash_login végrehajtódik, de megfigyeltem, hogy az a $HOME/.bashrc-ben is szerepel:

...
if [ "$PS1" ]; then
if [ -e ~/.bash_login ]; then
source ~/.bash_login
fi
fi
...

Ha ennek mintájára beírom a .bash_logout-ot is, akkor végrehajtódik, csak éppen akkor, amikor bejelentkezve indítok pl. egy terminal-t.

Találtam még ilyet is:

A bash konfigurációs scriptjei:
/etc/profile rendszerszintű, minden felhasználó bejelentkezésekor végrehajtódik
/etc/bash.bashrc rendszerszintű, minden új shell indításakor lefut
/etc/bash.logout rendszerszintű, shellből való kilépéskor hajtódik végre
/etc/inputrc rendszerszintű, readline beállítások
~/.bash_profile felhasználó szintű, bejelentkezéskor
~/.bashrc felhasználó szintű, új shell indításakor
~/.bash_logout felhasználó szintű, kilépéskor
~/.inputrc felhasználó szintű, readline beállítások

Kérdések:
1. A $HOME/.bash_logout -ban szereplő parancsoknak kilépéskor azaz a felhasználó kijelentkezésekor kellene végrehajtódniuk?
(Az 1. kérdés függvényében)
2. Nekem miért nem hajtódik végre? / Hogyan tundnám beállítani, hogy kijelentkezéskor bizonyos parancsok lefussanak?