1440x900 Samsung 940NW monitoron hogyan

 ( BornToBePuli | 2007. augusztus 23., csütörtök - 19:17 )

Sziasztok!

A problémám az lenne, hogy...

Samsung SyncMaster 940 NW monitorom van. Szélesvásznú, 19 colos.

Szeretném 1440x900 felbontásba rakni, mégpedig úgy, hogy 75 Hz-en frissítsen. De nem megy.

Az xorg.conf ide vonatkozó részei:

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Samsung SynMaster 940NW"
        Option      "DPMS" "true"
        Option      "HorizSync" "30-81"
        Option      "VertSync" "56-75"
        # 1440x900 @ 75.00 Hz (GTF) hsync: 70.50 kHz; pclk: 136.49 MHz
        Modeline "1440x900"  136.49  1440 1536 1688 1936  900 901 904 940  -HSync +Vsync
EndSection
.
.
.
Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1440x900" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Hogyan lehetne elérni, hogy 1440x900@75Hz-en menjen a monitor. Jelenleg 1152x864-es felbontásban van a kép. Ati driver fenn van, esetleg az bezavarhat?

borntobepuli@hal9000:/etc/X11$ X -version

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN 
Current Operating System: Linux hal9000 2.6.22.1-giskard #1 Wed Jul 25 16:07:46 CEST 2007 i686
Build Date: 04 April 2007
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
borntobepuli@hal9000:/etc/X11$ 

Xorg.log itt

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Kezdő vagyok a témában, csak a frekvenciához szeretném megjegyezni, hogy nekem (igaz nvidia kártyához) csak úgy működött a kívánt freki, hogy így írtam be:

Modes "1440x900_60"

Én 60 Hz-et akartam, mert az X állandóan minden felbontásban csakis 75 Hz-et engedett. Tehát a kívánt helyen és színmélységnél a felbontást aláhúztam annyival, amennyivel akartam (a támogatottak közül persze).

Próbáltam már többféleképpen is beírni, de sehogy sem jó.
---
BornToBePuli
Software is like sex! It's better when it's free! ;-) -Linus Torvalds-

Még egy dolog. Ahogy nézem, nincs minden paraméter jól beállítva neked.

Itt a gyári leírás:
http://www.samsung.com/hu/products/monitors/tft_lcd/multifunctionalproducts/940mw.asp?page=Specifications

Itt 33 - 81 Khz-et ír a horiz. frekinek, és nem 30 - 81-et.

Nem MW hanem NW.

---
BornToBePuli
Software is like sex! It's better when it's free! ;-) -Linus Torvalds-

Modeline sor nélkül?
Illetve azok az értékek honnan vannak?
Egyszer volt velem olyan, hogy xvidtune show kiemetéből bemásolt modeline sor nem akart működni, amíg a 2. számot (itt 136.49) le nem cseréltem valami kisebbre.

+:
(II) fglrx(0): Supported VESA Video Modes:
(II) fglrx(0): 720x400@70Hz
(II) fglrx(0): 640x480@60Hz
(II) fglrx(0): 640x480@67Hz
(II) fglrx(0): 640x480@72Hz
(II) fglrx(0): 640x480@75Hz
(II) fglrx(0): 800x600@56Hz
(II) fglrx(0): 800x600@60Hz
(II) fglrx(0): 800x600@72Hz
(II) fglrx(0): 800x600@75Hz
(II) fglrx(0): 832x624@75Hz
(II) fglrx(0): 1024x768@60Hz
(II) fglrx(0): 1024x768@70Hz
(II) fglrx(0): 1024x768@75Hz
(II) fglrx(0): 1280x1024@75Hz
(II) fglrx(0): 1152x870@75Hz

Valahol itt van a gond...

Én nem tudom hogy hoztam össze azt a sort.
A modline sorok nélkül csak 60Hz-en megy. Xvidtune-t hogyan kellene beállítani?
---
BornToBePuli
Software is like sex! It's better when it's free! ;-) -Linus Torvalds-

Az xvidtune csak példa volt amivel lehet egy ilyen sort generálni, például ha el van csúszva az kép minden induláskor (és nem elég a monitoron állítani, mert dual bootos a gép), akkor elindítod az xvidtune-t (terminál ablakból) ott kattingatsz amíg jó nem lesz, megnyomod hogy show és kiírja a terminálba a Modeline sort, amit bele kell szerkeszteni az xorg.conf-ba.

De a log alapján esélyesebb hogy az fglrx körül van a baj:
konkrétan az 1440x900 nem szerepel a támogatott módok között.

De 1440x900 felbontásban 60Hz-en minden remekül megy, csak hát én 75Hz-et szeretnék.
---
BornToBePuli
Software is like sex! It's better when it's free! ;-) -Linus Torvalds-

Nem baj ha megkérdezem, hogy miért kell a 75 Hz? Talán PAL formátumú videók lejátszásánál jó esetleg. De amúgy sem villog a kép 60 Hz-en ugye, mert LCD. Csak kíváncsiságból kérdezem.

Egy technikai doksiban azt olvastam (bocs, de nem tudok ref. linket adni), hogy a 60 Hz egészségesebb az LCD szkennelő eletronikájának. Ha nem, akkor javítsatok ki.