Sb live telepítés

Fórumok

Sb live telepítés

Hozzászólások

Sok mindenre rájöttem.
Letöltöttem a alsa-driver-1.0.9rc4a.tar.bz2-t.
Kicsomiztam, beléptem.
./configure O.K.
make, erre kiadja ezt a hibaüzit:
make[4]: *** [/home/soltan/alsa-driver-1.0.9rc4a/acore/memalloc.o] Error 1
make[3]: *** [/home/soltan/alsa-driver-1.0.9rc4a/acore] Error 2
make[2]: *** [_module_/home/soltan/alsa-driver-1.0.9rc4a] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.9-19'
make: *** [compile] Error 2
A dokumentációt hiába böngészem, nem tudok angolul.
Azt sejtem, hogy a modullal van baja.
Hogyan tovább?

[quote:e278833044="Gael"]Sok mindenre rájöttem.
Letöltöttem a alsa-driver-1.0.9rc4a.tar.bz2-t.
Kicsomiztam, beléptem.
./configure O.K.
make, erre kiadja ezt a hibaüzit:
make[4]: *** [/home/soltan/alsa-driver-1.0.9rc4a/acore/memalloc.o] Error 1
make[3]: *** [/home/soltan/alsa-driver-1.0.9rc4a/acore] Error 2
make[2]: *** [_module_/home/soltan/alsa-driver-1.0.9rc4a] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.9-19'
make: *** [compile] Error 2
A dokumentációt hiába böngészem, nem tudok angolul.
Azt sejtem, hogy a modullal van baja.
Hogyan tovább?

Amire szükséged lesz az az alsa-utils, alsa-lib, alsa-oss és alsa-driver csomagok azonos verziója. Előbb a lib-et fordítod, majd alsa-oss, alsa-driver és alsa-utils. A drivernél meg kell adni, hogy milyen paraméterekkel fordítson (./configure --with-cards=ca0106 --with-oss --with-sequencer=yes). Aztán make && make install.

[quote:e479a315b2="mike"][quote:e479a315b2="Gael"]Sok mindenre rájöttem.
Letöltöttem a alsa-driver-1.0.9rc4a.tar.bz2-t.
Kicsomiztam, beléptem.
./configure O.K.
make, erre kiadja ezt a hibaüzit:
make[4]: *** [/home/soltan/alsa-driver-1.0.9rc4a/acore/memalloc.o] Error 1
make[3]: *** [/home/soltan/alsa-driver-1.0.9rc4a/acore] Error 2
make[2]: *** [_module_/home/soltan/alsa-driver-1.0.9rc4a] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.9-19'
make: *** [compile] Error 2
A dokumentációt hiába böngészem, nem tudok angolul.
Azt sejtem, hogy a modullal van baja.
Hogyan tovább?

Amire szükséged lesz az az alsa-utils, alsa-lib, alsa-oss és alsa-driver csomagok azonos verziója. Előbb a lib-et fordítod, majd alsa-oss, alsa-driver és alsa-utils. A drivernél meg kell adni, hogy milyen paraméterekkel fordítson (./configure --with-cards=ca0106 --with-oss --with-sequencer=yes). Aztán make && make install.

És tapasztalatom szerint az sem árt, ha a gcc verziója ugyanaz, mint amivel a kernelt fordítottad. Nem írtad milyen disztribet használsz, milyen kenellel, de ha csomagolt kernel, lehet, hogy jobban jársz a disztribhez tartozó alsa csomagok felpakolásával, én sokat szívtam, mire rájöttem hogyan is fordítsam, anno mikor még 2.4-es szériát használtam...

Sziasztok!
Szeretném az új sb live hangkarimat föléleszteni. Most vettem és kéne egy kis segítség, hogyan tudnám a drivert telepíteni.
Szerk.:5.1-es és 24 bites, a creative honlapján NINCS DRIVER.

alsa-nak ismernia kene, nezd meg a honlapjan a supported devices-t.
lspci mit mond?

t

Sziasztok!

Én nagyon kezdő vagyok!!!
Van egy SB Live! 7.1-em és az istenért nem kel életre!
Lécci segítsetek, mert nem akarok öngyilkos lenni!
Már csak ez tart a Windows mellett, mert már azt nagyon unom!!! :evil:
Eőre is köszi!!!

Aj megint Én vok!

2.6.8-2-k7 -es kernelem van!

Csövi

Felismeri:
Creative Labs SB Audigy LS.
Mi az alsa honlapcíme?

Illetve nem is kell betölteni a modult mert elintézi az alsaconf...

Hi!

Szerintem forgass uj kernelt. Lehet, hogy valahogy ezzel is szora lehet birni, de az uj kernel a legtisztabb dolog. Ja, es persze ALSA-val.

By(t)e
TBS::Antiemes

az alsa honlap (es mindegy egyeb oldal cime, amit nem tudsz):

http://www.google.com

vagy varj, kitalalom, Neked is le van tiltva a ceges proxydon, ugye?

t

Én elhiszem neked, de nekem is higgy mert mindent úgy csináltam ahogy leírtad.
Szóról, szóra.
De nem volt fönn az alsa-tools csomag mint utólag észrevettem ezért most újra nekiugrok, a Te útmutatásod nyomán.
Szerk.:Most meg abszolute nem megy. Valami baja van a ./configure.nál a gcc-vel.
Nem fut végig a gcc. A kernelem UHU 2.2.9-21es.
Beadom a hibaüzit:
root:/home/soltan/alsa-driver-1.0.9rc4a# ./configure --with-cards=ca0106 --with-oss --with-sequencer=yes
checking for gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
See `config.log' for more details.
root:/home/soltan/alsa-driver-1.0.9rc4a#

[quote:f04f47a2cc="Gael"]Én elhiszem neked, de nekem is higgy mert mindent úgy csináltam ahogy leírtad.
Szóról, szóra.
De nem volt fönn az alsa-tools csomag mint utólag észrevettem ezért most újra nekiugrok, a Te útmutatásod nyomán.
Szerk.:Most meg abszolute nem megy. Valami baja van a ./configure.nál a gcc-vel.
Nem fut végig a gcc. A kernelem UHU 2.2.9-21es.

Akkor passzolom, mert UHU-ban nem vagyok járatos. volt kb. 2x a gépemen, de egyszer sem bírta tovább 2 naptól. Inkább Slackware vagy Debian. Szerintem egy próbát neked is megérne...

[quote:c42e476e5b="mike"]... Inkább Slackware vagy Debian. Szerintem egy próbát neked is megérne...

Akkor inkább (K)Ubuntu. Az kezelhetőség szempontjából közelebb áll az UHU-hoz és mégiscsak Debian alapú.

Na megint elakadtam.
Az alsa-lib telepítésénél a make-ra kiírja, hogy nincs célkönytár.
Megnéztem két makefile van, de a tartalmától nem vagyok bölcsebb. Csatolnám őket de túl hosszúak.
Szerk.: UHU1.2 2.6.9-21-es kernellel. És a kernelt nem fordítottam hanem frissítettem eredeti uhu csomi-ból.

2.6-os kernel Alsa reszebe nezelodj. Van benne emu10k1 es emu10k2. Az Audigy-khez asszem a k2 kell...

E-Medve

[quote:d792fb2d3f="E-Medve"]2.6-os kernel Alsa reszebe nezelodj. Van benne emu10k1 es emu10k2. Az Audigy-khez asszem a k2 kell...

E-Medve

Ehhez a kártyához nem emu10kx modul kell, hanem ca0106. Én nemrégiben hajítottam ki, nem megy normálisan 5.1-ben. Tettem a helyére egy jó öreg SB Live! 5.1 digitalt és az működik rendesen.

Rájöttem mi a probléma.
A hangkártyámon annyira új chipset van, hogy az alsa még nem csinált hozzá modult.
Egyébként ez a chipset az SB Audigy LS.
Szóval szívás mert hiába regeltem az Alsa supportján, nem tudok angolul és szótárral a kezemben
nem tudom nekik elmagyarázni a gondom.
Ehhez kérek segítséget, egy angolul tudó, jótékony lélek kell nekem, aki segít.
Áldja meg a Jóisten azt aki nekem ezt megteszi.

[quote:2c9b26cae3="Gael"]Rájöttem mi a probléma.
A hangkártyámon annyira új chipset van, hogy az alsa még nem csinált hozzá modult.
Egyébként ez a chipset az SB Audigy LS.
Szóval szívás mert hiába regeltem az Alsa supportján, nem tudok angolul és szótárral a kezemben
nem tudom nekik elmagyarázni a gondom.
Ehhez kérek segítséget, egy angolul tudó, jótékony lélek kell nekem, aki segít.
Áldja meg a Jóisten azt aki nekem ezt megteszi.

Van hozzá driver, de ezt már az egyik előző hozzászólásomban írtam. A modul neve nem emu10k1, hanem ca0106. Egyelőre nem megy vele zenehallgatásnál az 5.1 én ezért cseréltem ki egy sima live!-ra. Az 1.0.9-es alsa már egész jól használható hozzá. Egyébként ha frissíted az pci.ids fájlodat (Debian alatt update-pciids), akkor már nem SB Audigy LS-t fog írni, hanem SB Live! 7.1 24-bit-et. Tehát leszedsz mindent az alsa honlapjáról, majd lefordítod egyenként. A driver fordításánál a ./configure --with-cards=ca0106 legyen. Így meg fogja találni és szólni fog.

[quote:69bd1e6cbf="mike"][quote:69bd1e6cbf="Gael"]Én elhiszem neked, de nekem is higgy mert mindent úgy csináltam ahogy leírtad.
Szóról, szóra.
De nem volt fönn az alsa-tools csomag mint utólag észrevettem ezért most újra nekiugrok, a Te útmutatásod nyomán.
Szerk.:Most meg abszolute nem megy. Valami baja van a ./configure.nál a gcc-vel.
Nem fut végig a gcc. A kernelem UHU 2.2.9-21es.

Akkor passzolom, mert UHU-ban nem vagyok járatos. volt kb. 2x a gépemen, de egyszer sem bírta tovább 2 naptól. Inkább Slackware vagy Debian. Szerintem egy próbát neked is megérne...

://OFF
Minek váltogassam a rendszereket, mint az alsógatyát.
Az UHU nagyon jó disztrib és MAGYAR.
://OFF

Csak azt hiszed, mert nálam ahogy leírtad (mellesleg az alsa honlapján is így van) úgy nem megy.
Egy kicsit olvasd vissza a régebbi postokat és meglátod milyen hibaüzi van mindegyik drivernél.
Tehát valami nem kerek. Mivel még nem csináltam nem tudom mi a hiba.
Mellesleg UHU-m van.

Sziasztok,

nekem is gondom van a sb live-ommal :(
fent van az alsa driver, le futtattam az alsaconfigot, szólt, de nem 5.1-be :(
tudnátok segiteni?

probáltam felrakni emu-toolsot is, de az sem jött össze...
Suse 9.3-as linuxom van 2.6.11-es kernellel
(de ugyanígy nem szól 5.1-be az Uhu 1.2-es linux alól sem)

[quote:c5ff8bd380="Gael"]Csak azt hiszed, mert nálam ahogy leírtad (mellesleg az alsa honlapján is így van) úgy nem megy.
Egy kicsit olvasd vissza a régebbi postokat és meglátod milyen hibaüzi van mindegyik drivernél.
Tehát valami nem kerek. Mivel még nem csináltam nem tudom mi a hiba.
Mellesleg UHU-m van.

Én meg mint írtam, _HASZNÁLTAM_ ezt a fajta kártyát linux alatt alsa driverrel. Pont azért szedtem ki a gépből és raktam be egy régi Live! 5.1-et, mert nem ment az 5.1 rendesen, de maga a hangkártya működik. Egyébként Slackware és Debian alatt szórakoztam vele 32 és 64 bites változatokban.
A hibaüzeneted láttán pedig elgondolkodnék, hogy fent van-e a teljes kernel forrás, valamint nem elég csak a ./configure, megfelelően fel kell paraméterezni ha a drivert akarod fordítani.

[quote:df4a54108e="Gael"][quote:df4a54108e="mike"][quote:df4a54108e="Gael"]Én elhiszem neked, de nekem is higgy mert mindent úgy csináltam ahogy leírtad.
Szóról, szóra.
De nem volt fönn az alsa-tools csomag mint utólag észrevettem ezért most újra nekiugrok, a Te útmutatásod nyomán.
Szerk.:Most meg abszolute nem megy. Valami baja van a ./configure.nál a gcc-vel.
Nem fut végig a gcc. A kernelem UHU 2.2.9-21es.

Akkor passzolom, mert UHU-ban nem vagyok járatos. volt kb. 2x a gépemen, de egyszer sem bírta tovább 2 naptól. Inkább Slackware vagy Debian. Szerintem egy próbát neked is megérne...

://OFF
Minek váltogassam a rendszereket, mint az alsógatyát.
Az UHU nagyon jó disztrib és MAGYAR.
://OFF

Nézd, egy próbát megér. Többet tanulsz ezekkel és ezek is tudnak magyarul, legfeljebb a kernel üzeneteket nem magyarul kapod bootoláskor...

[quote:634fb7b00f="TrollBalint"]Sziasztok,

nekem is gondom van a sb live-ommal :(
fent van az alsa driver, le futtattam az alsaconfigot, szólt, de nem 5.1-be :(
tudnátok segiteni?

probáltam felrakni emu-toolsot is, de az sem jött össze...
Suse 9.3-as linuxom van 2.6.11-es kernellel
(de ugyanígy nem szól 5.1-be az Uhu 1.2-es linux alól sem)

alsamixer-t próbálgattad? Millió beállítási lehetőség van, nálam 32 bites és 64 bites linux (Debian, Slackware, Ubuntu) megy/ment rendesen.

Sziasztok!
Mindent megpróbáltam de a make parancsra ez jön ki három driver esetében is:
make[4]: *** [/home/soltan/alsa-driver-1.0.8/acore/memalloc.o] Error 1
make[3]: *** [/home/soltan/alsa-driver-1.0.8/acore] Error 2
make[2]: *** [_module_/home/soltan/alsa-driver-1.0.8] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.9-19'
make: *** [compile] Error 2
A három driver nem a legfrissebb de ezek passzoltak a függőségek verziószámához:
alsa-driver-1.0.8
alsa-driver-1.0.8rc1
alsa-driver-1.0.8rc2
A függő csomagok amik nekem vannak már az elején nem tudtam őket frissíteni mert elakadtam velük.

alsamixer-t próbálgattad? Millió beállítási lehetőség van, nálam 32 bites és 64 bites linux (Debian, Slackware, Ubuntu) megy/ment rendesen.

kösz, ez segitett :)

Na gyerekek ez így szép és jó. Belöktem a gugliba a ca0106-ot mint letöltendő dolgot.
Szépen beadja a mikéntjét. Tehát egy Readme-t adott. Eddig O.K.
Rákattintok a letöltésre erre vagy ezer alsa nevezetű csomagot ajánl.
Na most melyiket válasszam?
Melyik a nekem való?
Gondolkodom rajta egy kicsit, de egy kis inspirálás elkéne.

De én mint magyar megvettem a magyar disztribet, hogy ezzel is támogassam a magyar fejlesztőket. Az adóm egy százaléka is nekik megy. Egyszóval nemzeti lokálpatrióta vagyok, de hülye nem. Tudom jó a slacki, van live lemezem belőle.
Az ubuntu első pillantásra nem nyerte meg a tetszésem, debiannal kezdeni olyan szerintem, mintha a kezdő hegymászó először a Himalájába indul, a Csomolungma meghódítására.
Egyszóval maradok az UHU-nál és ha többet tudok, átnyergelek Debianra.

Hi!

Ra lehet valahogy venni a Live-ot, hogy a kimeneten ne hallatsszon semmi mas, csak az, amit en jatszok? Marmint hogy a mikrofon jelet, vagy amire eppen van allitva a capture, ne loopbackelje vissza.

By(t)e
TBS::Antiemes