Synology NFS - XenServer

 ( powermate | 2018. október 9., kedd - 0:54 )

Sziasztok,

Egy olyan jelenséggel kapcsolatban szeretném a segítségeteket kérni, amelyben még csak hozzávetőleges magyarázat se áll jelenleg a rendelkezésre, mert a tünetek nem teljesen általánosíthatóak.

Adva van egy XenServer. Az ezen futó VM-ek vinyója egy ugyanezen a hálózaton található (Gigabites MT Switch) van közte) Synology NAS-on leledzik.

Már korábban is voltak problémáink a HA-ba tett két NAS-sal, de miután kiszedtük az egyiket, az anomáliák egy időre látszólag elmúltak. Egy Időre...

A XenServer a VM-ek háttértárát NFS-sel írják/olvassák a Synology eszközről. A Synology-n 2 volume is taláható. Az egyik SSD, a másik HDD.
Egy ideje a HDD-s virtualizációs gépek randomra "elszállnak".

[193856.804606] EXT4-fs warning (device xvda7): ext4_end_bio:314: I/O error -5 writing to inode 9907863 (offset 41943040 size 1638
400 starting block 18062992)
[193856.804648] Buffer I/O error on device xvda7, logical block 12984576
[193856.804688] Buffer I/O error on device xvda7, logical block 12984577
[193856.804715] Buffer I/O error on device xvda7, logical block 12984578
[193856.804741] Buffer I/O error on device xvda7, logical block 12984579

Ezt követően a VM-ek readonly-ba újramount-olják az érintett eszközöket/partíciókat (mely mondanom se kell a funkcionalitásuk működésképtelenségével jár) és debug-ban, majd fsck után indulnak rendeltetésszerűen.

SSD-nél az utóbbi időben ugyan nem fordult elő, csak a HDD-s gépeknél, de ez nem zár ki semmit.

Ugyanis az érintett háttértárakkal kapcsolatos hiba általános, de nem egyetemes (van olyan amikor adott gépen belül csak az egyik storage száll el, és van olyan is, amikor pl. az 5 HDD-s gépből csak 3-at érint és nem mind az 5-öt. De azt a 3-at nagyjából egyszerre). Elhamarkodott lenne mint általánosítás, de talán a méret is számít, mint ha néha a "kissebbek" megúsznák (pl. a 200 GB-s mindig megkapja az "áldást", de a 20-as előfordult hogy nem).

A kérdésem az lenne, hogy mik azok a tényezők, amik ezt okozhatják? Természetesen nem zárom ki a Synology NAS eszközt mint tényező, de a saját monitoringja erre semmilyen utalást nem tesz és szeretnék megvizsgálni minden eshetőséget.

Esetleg lehet-e az NFS kommunikáció hibája, vagy a XenServer-é (7.2.0) ?

Segítségeteket előre is köszönöm.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Neten rákeresve disk firmware bug inkább ,HDD. Van ahol azt mondják a csak a gyári eredeti firmware oké és az új verziók bugosak.