Youtube Live FF 41.0.2

 ( Rill | 2015. október 29., csütörtök - 11:33 )

Tiszteletem.

Esetlegesen mas is rafut erre a hibara rajtam kivul? A problema itt

youtube.com/html5 mind a 6 block kek szinben pompazik. Leiras hozza+mediasource.webm
// Erdekes viszont, ha about:config-ban visszalallitom eredetire a leirasokban szereplo mediasource, fragmented es webm bizonyos valtozokat mp4-et nativan lejatsza bongeszo es yt videokat is kiveve a Live streameket. Ha eredeti about:config beallitasokkal nezem yt/html5 oldalt also 3 block piroslik...

MP4 test file

Xubuntu 15.10, Firefox 41.0.2, gstreamer1.0-plugins-(bad|good|ugly) es ffmpeg feltelepitve.

Xubuntu 14.04.3-on ugyan ezzel a felallassal ment. Kutattam, kerestem, de semmi megoldas nem lett.

Esetleges otleteket szivesen fogadok. Koszonom.

Szerk:
Arra mar rajottem, hogy a legnagyobb valtozast a yt/mp4 dologban a codemedia.fragmented-mp4.exposed allitasa jelenti.
Ha true akkor az MP4 fajlok corruptak lesznek yt pedig ettol erzi (a tobbi config beallitasa mellett) kompatibilisnek a bongeszot HTML5-hoz.
Ha false, akkor minden mas jol mukodik, de yt live nem kompatibilis bongeszot erzekel...

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Ezt látom most: "An error occured. Please try again later."

En is, de nem ezt kene latni, hanem a musort.

Kifogytam az otletekbol foleg miutan a yt/html5 minden kek kockaval se megy + akkor ez is corrupt hibat dob viszont mikor false-ra allitom a media.fragmented-mp4.exposed-t, akkor yt sir, hogy nem html5 kompatibilis a bongeszom, de az mp4 video ilyenkor gyonyoruen megy.

Most akkor hol a hiba?

Ugy latom egyedul vagyok ezzel a problemaval. :/ akkor kutakodom tovabb

Sztem nem vagy egyedül, ez a youtube-on rendszeresen előjön nekem is, sőt, a youtube-nál is dokumentálva van valahol, ha jól emlékszem. Csak magyarázat, megoldás nincsen hozzá, legalábbis még nem láttam.

Nekem eddig yt reszerol a sablon cache, history torles es please try it again 30 minutes later "tanacs" a max amit lattam. Ahogy irtad ezek tenyleg csak magyarazatok valamifele jelensegre de gondolom nem meglepo ha azt irom nem segitett.

Ezzel pont ma foglalkoztam, es allitottam be az osszes gepemen. Azota ahogy tapasztaltam, csak HTML5-tel jatsza le a videokat. Ubuntu-nal nem tudom mi kellhet meg hozza, de Arch Linux eseten a gst-libav csomagot kellett meg telepiteni, plusz elvegezni az about:config-os beallitasokat. Igy szepen minden keken virit.

--
http://www.flickr.com/photos/mizyhun

Hmm, ez érdekes. Beállítottam mindent én is, de a "MSE & WebM VP9" piros maradt. Mi kellhet ehhez? Gst-libav fent van.

about:config-ban keresd meg a media.mediasource.webm.enabled bejegyzest, es allisd true ertekre.

--
http://www.flickr.com/photos/mizyhun/

Szerintem is ez kellhet hozzá. Szintén archon most állítottam be és szépen "kikékült" minden. :) Végre van fullhd videó. :)

Nem, beállítottam a szükséges opciókat, ezt is. WebM VP8 pipa is, csak a MSE & WebM VP9 nem.
Egyébként ettől függetlenül a sky news is megy, nem találtam hirtelen olyan videot, ami vp9-el lenne kódolva, így azt nem tudom.

gsstreamer1.0-libdav fent van. Mindent beallitottam about:configban ugy is tesztelte es fenn all a hiba. Mindent kikapcsoltam + nehany variacio, de marad a jelenseg.

Ami szamomra foleg meglepo (mit elso valaszomban lathato), hogy attol fuggetlenul, hogy minen keken jelenik meg a yt/html5 oldalon ugyan az a jelenes van a live streameknel. Normal videok mennek _VISZONT_ mikor minden szep kek a yt/html5 oldalon a nativ mp4 videok "... corrupt" uzenettel fogadnak.

Azert furcsa nagyon mert mikor a yt/html5 nem kek 1-2 helyen es allitja, hogy nem kompatibilis a videofajlokhoz a bongeszom, akkor minden egyeb mas oldal (vine.co, gimpy, vimeo, ...) tokeletesen megy + a direk .mp4 fajlok bongeszobol (ami elvileg alapja a live/youtube dolognak).

Csak a biztonság kedvéért, media.fragmented-mp4.use-blank-decoder ki van kapcsolva? Mondjuk nekem akkor a videó helyén zöld képernyő jelent meg és sípoló hangot játszott csak le, valószínű nem ez lesz, de egy ötlet, hátha...

Ki van kapcsolva.
Mellesleg en is megprobaltam bekapcsolva hatha ez a titok, de ahogy irtad nalam is csak a zold kep es sipolo hang jott elo.

szerk:
OP-ba tettem egy mp4 test file-t, hogy aki erez eleg erot magaban es szeretne tesztelgetni, akkor legyen mivel :)

Készítettem egy képet, hogy milyen media-val kapcsolatban vannak egyéni értékek beállítva a config oldalon Firefoxban. Talán segít: https://www.dropbox.com/s/vvl6lo17cy2r618/firefox-media-cpnfig.png?dl=0
Nekem a tesztvideót is lejátsza és az általad is próbált sky news live stream-et.

Mindenkepp hasznos. Koszonom.
Esetleg azt meg tudnad mondani a gmp-s beallitasok honnet vannak? Nekem is egyedi ertekek viszont verzioszamon kivul mindegyik kulonbozik. Otletem sincs ez mikent befolyasol ha egyaltalan befolyasol. Tobbi 5 beallitas megegyezik.

Nincs mit. Azokat a beállításokat sajnos én sem tudom, már alapból úgy volt. Ami érdekes, hogy most az itthon PC-n Ubuntu 15.10-alatt ugyanazok a hibák j9ttek elő mint nálad, míg Arch alatt ment simán minden. Nyomozok tovább én is.

Mondjuk sovany vigasz, de megnyugtato nem en baszarintottam el a dolgot. :) Gyanus nekem, hogy valami 15.10-es "bug" lesz mivel 14.04.3-on about:config 5 kattintas utan ment. Esetlegesen ha jutsz valamire es megirod megkoszonnem. En mar kedd ota ezzel "jatszom"...

Szerk:
Firefox irc channel-en volt egy segitokesz gyerek az elmult napokban, o Fedora-n van es nala minden szepen megy. FF azonos igy egyre nagyobb a gyanu az Ubi iranyaba
Mellesleg az askubuntu.com-on az elmult 5 napban egyre jobban gyulnek a hasonlo bejegyzesek. itt es itt

Nekem is meggyozodesem, a hogy "minosegi" Ubuntus csomagokban keresendo a hiba, es kevesbe a Firefoxban. :/ Valami fuggoseget szerintem a csomagkeszites soran kihagytak, es azert nem megy. Mindenesetre kivancsi vagyok a vegkifejletre. :)

--
http://www.flickr.com/photos/mizyhun/

Sajnos én sem jártam eredménnyel próbálgattam gstreamer csomagok törlésével újratelepítésével is, de semmi. Ahogyan az OP-ban írtad a media.fragmented-mp4.exposed a kulcsa. Én most azt hagytam false értéken, mivel streamet nem nézek youtubon, más oldalon pedig le fogja játszani az mp4-eket. Azért visszanézek majd erre a problémára de szerintem is elég sanszos, hogy Ubuntu bug.

En egy uj Firefox profilban kiprobalnam ezeket a beallitasokat. Lehet valami addon, vagy beallitas bekavar a dologba.

--
http://www.flickr.com/photos/mizyhun/

+1

Egy addon van. uBlock origin. Uj profillal is probaltam mar (addon nelkul is) original es egyeni beallitott about:config-al. Hiba ugyan ugy fenn all sajnos.