avr-gdb + avarice + MKII + debugwire

Fórumok

Működik valakinek rendesen? (Most éppen tiny45 lenne az alany, Ubuntu 14.10-en)
Single-step megy, de elég egy continue és nem hogy a következő breakpointnál nem áll meg, de még a gdb prompt sem jön vissza.
Egyszer megpróbáltam, hogy egy ~20 assembly utasításnak megfelelő c kódot kivárok, ha a fene fenét eszik is.
Ő győzött, fél délután ráment, mégsem futott break-re.
HW hibára, debugwire fuse-ra vonatkozó tanácsok miatt ismét leírom: a single-step működik. (Igaz, lassú, vagy ~2 sec)
Ötlet?

Hozzászólások

ha DWEN=0 akkor hogy programozod? high voltage?

Debuggoláshoz -O0-lal fordítottad a kódot, ugye?
Nálam ez (kb. 8-10 éve) okozott már gondot.

Fuszenecker Róbert

Nem, Os opcióval, vindózon O2-vel szoktam. Most kipróbáltam mindegyiket: O0, O2 és Os egyformán a fent leírtak szerint viselkedik.
A sorrend: make clear és fordítás után letöltés avrdude segítségével, dw engedélyezve. Ezután táp ki-be (Igen, tudom, ezt el szokta felejteni, aki vindóz után vált linux avr debuggolásra.) Ezután jöhet a az avarice+gdb indítása.

Neked megy a debugwire rendesen avarice+gdb alatt?

Megmondom őszintén, a DW-t sosem használtam.
Amikor még tudtam ilyesmivel foglalkozni, akkor még SPI-on ment a debug, és az ahhoz szükséges hardvert a párhuzamos port szolgáltatta (kicsit meg kellett patkolni az avrdude-ot). Kiválóan működött.
Aztán elkezdtem ARM-mal foglalkozni (előbb mikrovezérlő, aztán application proc.), és nem vittem tovább az AVR-es vonalat. Sajnos.

Azt viszont nagy örömmel látom, hogy szépen fejlődik.

Fuszenecker Róbert

Én közel húsz éve avr-t használok, sokáig aStudio-val. Ma is ez az egyetlen sw, ami miatt nem tudom elhagyni a vindózt. Időnként nekidurálom magam, hogy felszámolom ezt az utolsó kapcsot és mindig rá kell jöjjek, hogy sajnos még mindig nem jött el az idő.
avr-t írok-olvasok, fuse biteket is beleértve, akár jtag, akár spi a programozó felülete, de a debug nem akar menni Linux alatt.

A tippet azért köszönöm, ha eszedbe jutna még valami, kipróbálom.