Firefox 33, UX fail, idióták

 ( Adi | 2014. november 4., kedd - 11:36 )

Röviden: letiltották a self-signed certificate-ek használatát, "biztonsági" okokból. Kicsi kimászhatnának az elefántcsonttoronyból, kismillióan használják a böngészőt ILO, DRAC stb. szervizprocesszorok piszkálására (is), ahol jellemzően ilyen certek vannak és a használatuk nem igazán jelent kockázatot. Alapvetően nem is ez a probléma, hanem az, hogy nincs mód ezt egyszerűen kikapcsolni, már a 31-32-es verziókban is az about:config-ban kellett kotorászni. A 33-ásnál már az ott említett módszer se működik.

Konkrétan ez jött szembe ma nekem is:

https://support.cdn.mozilla.net/media/uploads/images/2014-09-21-11-20-43-cbbf4c.png

A téma hozzá, anyáznak rendesen többen is:

https://support.mozilla.org/hu/questions/1012765

"Újabb manyeyeballs-sikertörténet."

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Szerintem erre van valami command line-os megoldás, legalább is korábban, mintha nekem sikerült volna meghágnom a problémát. :) Ne kérdezd, hogyan, lehet, hogy valahova leírtam itt a HUP-on is, de egyszer kellett, túrtam a netet, s megoldódott.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Kiprobaltam (vadiuj, tiszta profillal is) es nem rinyalt, a szokasos nem megbizhato, de megertettem a kockazatot blabla utan tovabblepett.

Vajon mitol fugg?

WinXP, Firefox 33.0.2, ha jol emlekszem a 33.0.0 is igy viselkedett (a frissites utan talalt meg ujabb frissiteni valot).

security.use_mozillapkix_verification=false?

Amúgy igen, én is lábrázást kapok ettől a baromságtól.
Azonban mint biztonságközeli dolgokkal is foglalkozó IT-s, látom, hogy ezek a számunkra, szakmabeliek számára agyament default-ok sokszor az átlagfelhasználókat és a webet általánosságban nézve valóban a biztonság növelése felé hatnak.

Vitatkoznék. :)

Remekül működik az összes self-signed site-om 33.0.2 alatt.
A linkelt képet legutóbb akkor láttam, amikor menet közben cert-et cseréltem egy site-on és a Fox ezt rossz néven vette. Törölnöm kellett a CA-t a böngésző listájából és a következő megnyitáskor már rákérdezett, hogy mi legyen?

+1

a self signed certificate-nek semmi ertelme, tobbet art, mint hasznal

--
NetBSD - Simplicity is prerequisite for reliability

?
--
blogom

passzív lehallgatás ellen megvéd. jobb, mintha sima HTTP-t használna az ember, és még a certet is le lehet tárolni a böngészőben, ezáltal észreveszi az enduser, ha MITM van.

Szóval van értelme, amúgymeg nehogy azt hidd h. a CA rendszer jó..

Oke, akkor most ballagj oda legyszives az osszes nagyobb gyartohoz, mondd ezt az arcukba, majd gyere vissza a valaszokkal. Koszi.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

A Google Chrome ennel meg parasztabb, tovabbenged ugyan, de mukodeskeptelen a jelszokezelo az ilyen oldalakon, ha nem tudod fejbol a jelszot, akkor igyjaras. Marpedig a fejem nem kaptalan.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

továbbá tetü lassú a flash-sel teli tartalmaknál. a magyar langpack-ból pedig már csak a 33-ra van elérhető az addons oldalon, ezért külön köszönet a develteam-nek. de tényleg.

egyébként hogyan lehet kizárni az automatikus frissítések közül a rohadtfoxot bubuntun?
egyfolytában ugat, hogy elérhető, meg telepítsük, meg hajrá, meg hogy a mozilla is jobban teljesít... :(

--
Aspire E1-530
"...és micsoda zajt csapott!"

FF 32-hoz itt van langpack: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/32.0/win32/xpi/

A tobbi verziohoz is elerheto langpack, a verzioszamot kell cserelgetni.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Valami nagyon borult náluk, nekem ugyan nem ezzel lett tele a hócipőm épp tegnap. A 31-es utáni verziókkal gyakorlatilag egy rakat oldal, főként a hosszú és/vagy dinamikusan betöltődő oldalak kezelhetetlenül leakasztják (pl. facebook, tumblr), alig lehet görgetni, navigálni. Közben a procit meg nem tekeri, szóval nem teljesen értem. Mindez sem freebsd-n a 31-es verzióval, sem chrome alatt nem jelentkezik, profil és bővítmények eltávolítása nem segített, sem a hw gyorsítás-finom görgetés tetszőleges kombinációba kapcsolása, sem about:config varázslások. Viszont az aurora channel megoldotta, azzal nincs gond. Csak az meg nincs csomagban, csak AUR-ban van, bár épp magyar nincs.

ó én déli 12 óta szopok. először is hiába távolítottam el a dicső 33-as rohadtfoxot. release-ből 30 a legutóbbi elérhető, a 31-32 eltűnt. előre elvtársak ott a godzillánál!
aztán teljesen mindegy, hogy 30-as vagy 33-as firefox-ot telepítek, semmiféle flash-plugin nem működik. kivétel youtube, ott a videók lejátszódnak. reggel még csak tetü lassúak voltak az agyonflash-elt oldalak, mostanra eljutottunk arra a szintre, hgoy némelyik mutatkozik, a legtöbb nem.
ilyen releváns és munkaidőben (is) hasznos oldalakkal lehet próbálkozni, mint farmerama, skyrama... ezek ha működnek, akkor minden flash tartalom megjelenik ;)

jahm, ubuntu 14.04-en a telepítés után megadatott 32-es ff _sem_ működteti a flashplugint (100%-osan), feljebb ismertetett "tesztoldalak" ugyanúgy elhasalnak login után.

nem lehet hogy ideje volna a mozilla fejlesztőinek elmenni kurvázni? véleményem szerint a túlzott fehérjetöbblet és annak kényszeres visszatartása már a munka rovására is megy.... de tényleg.

update:
innen letöltött flashplugin-installer telepítése (még a frissítések előtt, 32-es ff) után működik. viszont továbbra sincs elérhető magyar langpack.

--
Aspire E1-530
"...és micsoda zajt csapott!"

http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/31.0/linux-x86_64/hu/
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/30.0/linux-x86_64/hu/

(itt mar a magyar csomagok erhetoek el)

Flash plugin: a http://flashinfo.hron.me/ oldalon bejon a verzioszam?
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Az ok, hogy a lokalizált verziók megvannak, de ez ugye nem langpack. Azok az addon.mozilla.org-on voltak elérhetők, de speciel most valóban csak a legutolsóhoz van. És gondolom nem nehéz belátni, hogy ahol pl. a céges policy nem engedi meg a telepítést, ott praktikus megoldás is a langpack user installja.
Szerk: Mégiscsak megvannak itt http://download.cdn.mozilla.net/pub/mozilla.org/firefox/releases/31.0/linux-x86_64/xpi/ és a többi verzióhoz is értelemszerűen az xpi mappában, mint le is volt írva fentebb winesre... mea culpa!

You have version 11,2,202,411 installed

--
Aspire E1-530
"...és micsoda zajt csapott!"

Hmm... akkor az a baj, hogy kisse regies mar a cucc. Ezen sajnos nehez segiteni. Nem tudom, hogy a Firefox tamogatja-e a borsos API-val keszult flash playert.
--
Ki oda vágyik, hol száll a galamb, elszalasztja a kincset itt alant:

()=() 
('Y') Blog | @hron84
C . C Üzemeltető macik
()_()

Egy megoldásról olvashattunk nemrég itt.
De ezzel szemben én azt állítom, hogy ez nem kéne, hogy gond legyen. Nálam most épp PCBSD-n: "You have version 11,2,202,400 installed", firefox 31.0, és simán megy minden. Mint fentebb is írtam, valamit a 32-33 verziókkal követtek el, linuxon a fent említett freshplayerrel megy most az ff aurora, avval sincs gond, ellenben a sima ff már-már használhatatlan, ha flash, ha fresh playerrel próbálom. Mondjuk azt azért hozzátenném, hogy nekem nem is a flash tartalmakkal volt bajom, hanem pl. a HUP-on a "debianfork.org - Újabb tiltakozás a Debian systemd tervei ellen" végtelen hosszú topic görgetése már megakasztotta, ill. további példákat írtam még fentebb.

Kifejezetten ősrégi VGA kártyám van - NVIDIA Corporation G86 [GeForce 8500 GT] (rev a1) - nouveau driverrel, de nem tapasztaltam firefox 33-ban efféle problémát.


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Nekem sem épp új: G72M [Quadro NVS 110M/GeForce Go 7300] és én nvidia-val hajtom, elég perverz lenne, ha az lenne a gond. BSD-n is azzal hajtom, bár ott még a 31-es ff van, amivel linuxon sem volt gond.

opensuse 13.2-nél firefox 33, flash a frissítésekkel jött le. és működik. repül minden, pedig nem a fos unity van az asztalon, hanem a kde4...

egyébiránt a broadcom netxtreme gigabites hálókártyát _nem_ kell már hegeszteni, ezen verziójú opensuse-ban működik!
a bluetooth-szal együtt persze.
(aspire e1-530)

--
Aspire E1-530
"...és micsoda zajt csapott!"

Remek, akkor most már tényleg alaposan utána kéne járni, hogy mi ez, mert nekem is kde4, tehát a unity biztosan nem zavart. Bár lehet, hogy nem vesződök vele, amíg az aurora teszi a dolgát.