[Megoldva -> Szervíz] ZTE Blade - Wifi probléma (furcsán müködik)

 ( Croc | 2012. július 8., vasárnap - 7:46 )

Sziasztok,

Az asszony ZTE Blade telefonja pár napja azt kezdte el játszani, hogy nem találja meg a Wifi hálózatokat, csak némelyiket, néhány másodpercre.
Elötte hónapokig tökéletesen müködött.

A megjegyzett hálózatokat (amiket használna) az esetek nagy részében "hatótávon kívülinek" jelez. Ha nagy ritkán tud is hozzá csatlakozni, akkor is pár másodperc múlva bontódik a kapcsolat, mondván hahtótávolságon kívülre került.
Ha az egyik ilyen hálózat routeréhez kb 30-50cm távolságra tartom a telefont, akkor tud csatlakozni, mondhatni stabilan is tartja, de a sebesség csak néhány Mbit (leginkább 1Mbit).

Gondoltam HW problémára (mondván megszakadt az antenna és a vezérlö között a kapcsolat), de a rövid idö alatt olyan hálózatokat is megtalál a kereséskor, ami egyébként messze van és gyenge a jele.

A telefonon több Custom Firmware-t próbáltam, de sajnos egyikkel sem javult a helyzet.
cm-9-20120628-EXPERIMENTAL-blade-ColdFusionX-tilal6991 - ICS
update-cm-9-20120426-SNAPSHOT-blade-signed - ICS
update-cm-9-20120518-SNAPSHOT-blade-sej-signed - ICS
Swedish-Snow-RLS7 - (Android 2.3.5) Jelenleg is ez fut rajta, ezzel annó tökéletesen müködött.
Az ICS-el még azért vannak gondok...

Próbáltam különbözö Wifi fix-et (Blade Wifi fix, Wifi fixer, FXR Wifi fix and rescue), de sajnos egyik sem segített igazán. Azt az FXR elérte, hogy már több hálózatot talál meg egyszerre kereséskor az eddigi 1-2 helyett, de sajnos azokat is csak rövid ideig látja.

Többször is töröltem már a user data-t, töröltem a cache-t is, de sajnos az sem változtatott semmin. (csak mindent elfelejtett a telefon)
Újraindítás, akksi ki/be is többször volt már. Sajnos eredménytelenül.

Van valakinek valami ötlete? Találkozott valaki már hasonlóval?

Google-ben kerestem/keresek, de vagy rossz kulcsszavakat használhatok, mert nem találok nagyon megoldást, vagy még senki nem találkozott igazán ilyen problémával.

Gari már nincs. Legfeljebb valami GSM bolt szervízét tudnám igénybe venni ha nem lesz más megoldás...

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

gyári rommal is fennáll a probléma? próbáld meg azt a romot vissza tenni amivel árulják a telót, hátha alapon.

A gyárihoz legközelebb a Swedish Rom áll(t). Elvileg az valamilyen gyári romon alapul.
Nem is volt vele probléma több hónapig...

A gyári egyébként 2.2 volt amivel már sajnos nem futtathatóak olyan appok amik kellenének :(
Ráadásul nem is találok hozzá zip-es formátumu 2.2 rom-ot, csak amolyan exe-st a szolgáltatóknál. De ha nem lesz más akkor azt kipróbálom. Köszi a tippet!

Egyelöre haladásnak fogom fel, hogy a sokadik kernelel már megfelelöen listázódtak a wifi hálózatok. Csak a csatlakozás nem ment még mindig...

nem feltétlen kell használnod a gyári romot, de legalább kiderül, hogy hardver gondod van vagy valami más.

Sajnos egyelöre csak az "exe"-vel visszarakható szolgáltatói Rom-okat találtam.
Azok meg úgymond kompatibilitási hibára hivatkozva nem települnek fel a telefonra.
Valószínü a clockworkmod recovery lehet az oka ami úgymond lecserélte a TPT (?) módot.

ezt az exe telepítőt nem ismerem, nekem eddig csak egy galaxy acem van/volt dolgom, de ha custom rom van rajta akkor itt is fennál, hogy ismeri fel a gyári frissítő progi, szóval elképzelhető.

Szia!

Megoldast nem tudok csak a sajat tapasztalataimat irom le:

Ginger Stir Fry beta 19-et hasznalok, tavaly ota. A gyarival, Stir Fry kesobbi betaival es a stabillal is tobb gondom volt mint ezzel a rommal ugyhogy en tobbet nem frissitek =)

Egyebkent volt egy AP (nem altalam adminisztralt) ahova 2-3 hetig tudtam csatlakozni minden nap es egyszer csak nem, hiaba frissitettem vagy csinaltam barmit. WPA-t hasznalt es mas eszkozom mukodott vele. A telefon mas AP-kon mukodott rendesen.

Udv

Utána nézek ennek a rom-nak is, köszi.

A probléma az, hogy ami mellett épp ülök, az egy DLink wifi. Most jelenleg csak az elérhetö. Máshol TPLink-es Wifi-k voltak, de sajnos ahhoz sem ment a kapcsolódás.
Elöször én is a routerre gyanakodtam, mert szokott érdekes dolgokat müvelni, de mivel a TPLinkekhez sem ment a csatlakozás... maradt telefon probléma :(

Kipróbáltam ezt a rom-ot is (több verziót is). Sajna ugyanaz a helyzet, mint a többivel.
Töröltem update elött az adatokat, cache-t. Bebootol, müködne minden jól. A wifi meg is találja a hálózatokat, de sajnos nem tud kapcsolódni amikor kellene a megadott hálózathoz.
Pár próbálkozás után a routert újraindítottam, ezután fel is jelentkezik rá a telefon, majd wifi ki és visszakapcsolás után már nem, hiába jelzi teljesen jónak a jelerösséget.

Más telefon, notebook gond nélkül megy ezzel a wifivel, és a Blade is ment még pár nappal ezelött. Pedig a jelszó is jó, többször ellenöriztem.

A routerben sajnos nem találtam erre vonatkozó logot. A telefonban még nem néztem.
Este még megpróbálok egy másik eddig ismeretlen routerrel összerakni egy teszt AP-t, hátha...

Mindenesetre érdekes a probléma...

Nekem ez a probléma a GingerBreaddel eltűnt, most egy hete ICS van rajta (coldfusionx), ezzel megint előjött. Valószínűleg visszatérek CM7-re, az volt nekem a legstabilabb (de a Swedish snow elég hasonló alapokra épül tudtommal).
Egyébként nekem a legnagyobb bajom most az ICS-sel, hogy nagyon kevés appot tudok sd kártyára rakni. Facebook, maps, google drive mind rengeteg helyet foglalnak, viszonylag ritkán használom öket és nem lehet sd-re rakni...

A Swedish Snow-t szerintem én is lecserélem a CM7-re. Abban amúgy is 2.3.7-es az Android, és eddig gyorsabban bootol és áll le.
Persze hogy a problémánál maradjunk, legalább a wifi hálózatokat is megfelelöen látja :)

Még keresgélem a megoldást, hátha csak valami rejtett paraméteren múlik az egész...

Egyébként az ICS ezen a Blade-en kamera problémákkal küszködik. Kockás/csíkos a kép, szétesik, és volt hogy meg is fagyott a telefon. A wifi pedig rosszabb benne, mint a CM7-ben. Remélem azért lesz majd jobb ICS, mert ettöl függetlenül elég igéretesnek néz ki.

A kamera kép nálam jó volt, de nekem is lefagyasztotta egyszer a telefont. Közben rájöttem, hogy az app áthelyezés nagy valószínűséggel azon múlott, hogy cm7-ben van egy beállítás, amivel minden app sd kártyára helyezését engedélyezi. Lehet, hogy cm9-ben is van ilyen, nem "jött velem szembe"
Amúgy nekem is nagyon tetszett, ui sebességben, kezelhetőségben eddig a legjobb.

Csak tipp: az nem lehet, hogy a nagy meleg miatt akadozik? Nekem wifizes kozben eleg rendesen melegszik a telefon felso resze (a kamera korul).

(Rejtett feliratkozas.)

----------
Az Örömtündér minden évben ellátogat a Földre és akit megérint a pálcájával az Boldog lesz! De esetleg az is megtörténhet, hogy kiveri belőled még a sz*rt is... (by radcsong)

Amikor jó volt, érzésre tényleg melegebbnek tünt.

Most nagy nehezen hajlandó volt egy WRT54GL-el 11Mbit-es sebességet elérni, de sajnos így is többször akadt meg a kapcsolat, hiába volt kinn a teljes wifi jelet és kapcsolatot jelzö ikon a "statusbar"-on.

Gondoltam a melegre én is, de most épp egy hüvös légkondis helyen probáltam...

Úgy látom ez egyre inkább szervíz lesz :(

Ha van még rá garancia cseréltesd. Valószínű h nem fogják nézni milyen rom van rajta. De lehet még azt sem hogy mi baja van.

Valamennyit javult a dolog ha a
Menu, settings, wifi, wifi settings, menu, advanced, regulatory domain -nál 13-ra állítom az értéket.

Ezzel a beállítással CM rom-nál már sikerült elérni 24Mbit-es kapcsolat sebességet az eddigi 1-2Mbit helyett.

Ez a beállítás úgy látszik elsösorban a CM rom-oknál van meg. A (közel) gyáriaknál (pl: Swedish Spring RLS5 - Android 2.2) nincs (vagy nem találtam).

Azt jól is teszed, európában épp a 13 csatornás mód az engedélyezett (11 usa, 14 japán). Mivel ez európai/kínai piacra eladott telefon, a nem CM romok szerintem alapból így jönnel. Viszont ez nem kellene, hogy javítsa a helyzetet, csak olyan wifikre is tudsz csatlakozni, amik a 12-13-mas csatornán mennek.

sziasztok!

nekem is hasonló gondjaim vannak a wifivel kb egy hónapja.
valamikor a CM 7.2 stable utáni nightly-kkal romlott el. addig stabilan, viszonylag nagy távolságról is tartotta a jelet, sok hálózatot látott, de azóta 5-6 méterre csökkent a hatótávolság, még falak nélkül is.
és ahol más eszköz 5-10 hálózatot lát, ott a blade-em csak 1-2-t.

először hw hibára gyanakodtam, ezért visszaraktam rá a gyári romot, hogy úgy vigyem szervizbe (még éppenhogy garis).
nagy meglepetésemre a gyári rommal megjavult a wifi.
aztán netes kutakodás alapján arra következtettem, hogy az újabb CM romokban valamit variáltak a wifivel és a feszültségével, energiaspórolás miatt. csakhogy nekem ez konkrétan használhatatlanná tette a wifit, ha kimegyek az a szobából, ahol az AP is van.
és ami még furcsább, hogy hiába tettem vissza régebbi CM 7.1 verziót, amivel még biztosan emlékszem, hogy nem voltak wifi gondok, most azokkal is vannak. próbáltam más romot is, de ugyanarra a kernelre épül, ezért szintén rosszalkodik a wifi. meg belefutottam olyan gondba is, hogy nem volt hajlandó bootolni egy ROM, amit clockwork recovery-ből telepítettem pedig elvileg azzal mennie kellett volna a dolgoknak jól. szóval most a legutóbbi nightly van fent és igyekszek az AP közelében maradni :)

azt kéne összehozni valahogy, hogy egy régebbi kernelt, wifi "drivert", vagy valamit kéne ráhegeszteni a mostani rendszerre, hogy visszaálljon a normálisan működő wifi. de hogyan? és honnan?
a gyári romot nem szivesen tenném vissza napi használatra, mert nem vagyok hajlandó lemondani az sd-ext partícióról és még nagyon sok extráról, amit cyanogenék összehoztak.

szerk:
most feldobtam egy ginger stir fry b27-et, ezzel jónak tűnik a wifi. így hirtelen szembetűnő különbség, hogy látja a sok környékbeli AP-t, amit régen a cyanogen modokkal is látott a teló.
csak ez a rom se nagyon felel meg nekem mindennapos használathoz :/
valami csak a kernellel, meg a wifi "driverekkel", vagy az undervoltos dolgokkal lehet.
valakinek valami ötlet?

Részben örülök, hogy nem csak nekem jelentkezett ez a probléma, de remélem sikerül megoldanod.

Próbáltál más "stock rom"-ot?
Itt elég sok össze van szedve:
http://forum.xda-developers.com/showthread.php?t=1353526

Ebböl azok a 2.3.5-ös Rom-ok amiket kipróbáltam tartalmazták az "app2sd" funkciót. Vagy legalábbis elérhetö volt az SD kártyára áthelyezés az Application menüböl az adott appnál. Ha csak ez a legföbb probléma :)

Nálam mondjuk sajnos ezek a stock rom-ok sem segítettek, söt azok sem amilyen Froyo-kat sikerült visszarakni, de lehet én nem vettem észre, hogy azok is valamilyen szinten a CM kernel/drivereket használják...

Egyelöre feladtam a dolgot. Föleg mivel végül kapott egy másik telót az asszony. Majd egyszer ha megint lesz egy kis idöm/türelmem elöveszem telót és próbálkozok egy sort hátha...

őszintén szólva nem nagyon tudnék kiegyezni egy ilyen downgrade megoldással.
ideiglenesen, tesztelgetni persze jó. tényleg megy a wifi régebbi romokkal/kernelekkel és nem a hardver ment tönkre.
de aztán csak azt kéne, hogy valami új romra régebbi kernelt, vagy beállításokat eszközölni. de erre még nem találtam leírást, annyira meg nem vagyok benne az android belső lelki világában :) esetleg megkeresek 1-2 rom fejlesztőt, hátha tudnak segíteni.

nekem ez a rom és kernel fordítás egy kicsit magasnak tűnik.
de majd beleásom magam. csak ahhoz sok szabadidő kell :)
köszi a linket!

+1

+1

+1

+1

jónak tűnt, látta a sok környékbeli hálózatot, de úgy látszik, hogy a hatótávolsággal megint problémák vannak, nem is kicsit.
tpt-vel visszaraktam a gyári romot és így is rossz. 5-6 méter után már hiába látja a hálózatot, ki is írja, hogy a wifi jel 60-70%-os, de nem hajlandó csatlakozni. :/
na most elkezdek a szervizen gondolkozni... :/

Kicsit megkésve írom, bocs, de nálam is végül szervíz lett a vége.
Vissza kellett sajnos rakni a gyári ROM-ot, de utána a szervízben is elfogadták a hibát és cserélték gyakorlatilag az egész telefont. Most jól müködik egy ideje.

Melyik ROM- al működik jól?
--
üdv: virtualm

Mikor kihoztam a szervízböl az azelött már megszokott Swedish Snow RLS7-et raktam rá, de azzal ugyanazt a wifi-s hibát produkálta, mint elötte.
Így a GingerStirFry b29-et és a MIUI-t (Android 4 alapú) használtam rajta jó ideig amivel a wifi is jó volt. Nemrég ismét megpróbáltam a Swedish Snow RLS7-et. Most abban is jó a wifi. Jelenleg is a Swedish Snow-al müködik.
Így mondhatni már az összes ismertebb ROM-al jól müködik, bár ha nem látom én sem hiszem a fent leírt "javulást".

Akkor ezek szerint a HW szivatott.
Cserébe lett ujjgyakorlatod a ROM pakolásból.
[Megoldva] ?
--
üdv: virtualm

Jogos! Pótolom.