ubuntu hang

 ( d3xt3r | 2012. február 17., péntek - 18:41 )

Adott egy Asus (k50af) laptop, és egy ubuntu (stable). Bedugok egy fülest, és a füles is szól és noti hangszórója is, bármit csinálok. Erre van megoldás?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

nincs

Van. Le kell halkítani és akkor egyik sem szól. :)

te vmi nagyon okos ember lehetsz, gondolom az összes létező fórumot/erről szóló leírást tucatszor átnyálaztad

Phoenix Art - Website Tester

hat ja, azert is irtam, hogy nincs :)

Rakjal ra Windowst :)

Ezt nézd meg sztem, ha még nem tetted meg:
http://ubuntuforums.org/archive/index.php/t-1751483.html

de milyen szomoru, hogy ilyen alapveto funkcioval is szenvedni kell...sajnos ez jellemzi az egesz linuxot :(

Szeretem, mert ahogy fütyülök úgy táncol, csak tudni kell hozzá rendesen füttyögetni, persze vannak olyan dolgok amik egyértelműek és alap dolog lenne, és mégse... amúgy meg full respect az összes fejlesztőnek, mert a nullából felépíteni, az már valami.

"sajnos ez jellemzi az egesz linuxot" -> Soroljam a win hasonlóan bosszantó hiányosságait/hibáit?

Phoenix Art - Website Tester

megtennéd? :)

--
Sent from my ezeréves Nokia.

win: véletlenül másik usb-be dugsz be valamit a múltkorihoz képest - új eszköz, telepítés.

lnx: ugyanazt elsőre bárhova - már rég ismeri, és működik azonnal.

ez semmi...ez nem szivas, az a szivas, hogy laptopodba benyomod a fulest es megis szol a laptop kis szarja is...

hátja. de csak ubi alatt. win7-nél teljesen jó.

Legyszi...

Lehet neked nem lesz megoldás, de én meg ezzel szívtam, és workaroundot találtam a megoldásra.
-
Weak és Soft referenciák a Javaban

Asus k50ij Ubuntu 10.4 LTS -- kezdettől fogva fennáll a probléma, német oldalakon is néztem megoldást, egybehangzó vélemény, hogy 100%-os megoldás nincs. Ha kihúzom a csatlakozót és visszadugom, akkor nekem úgy elhallgat a beépített hangszóró.

+1
ASUS K50IJ-SX036L-nél is ugyanez a probléma. Ha kihúzom a csatlakozó és visszadugom, akkor nekem továbbra is szól.

Szerintem lehet, hogy megoldja, ha leradírozod a Pulseaudio-t róla, és csak sima Alsa-t, meg Alsamixer GUI-t teszel fel (asszony gépén ez lett a megoldás a Pulseaudio kontra VLC kontra Flashplayer okozta kellemes megakadt hang, majd utsó 2 hang loop forever tünetére)
Persze ez csakis akkor lehetséges, ha Bubuntuék nem drótozták hozzá a fél Ubuntu desktopot a Pulseaudio-hoz.... Nem tudom, mert a fent említett vason Linuxmint 10 van, és az sem biztos, hogy a Mint csapat nem nyúlt bele a Pulseaudio függőségeibe, legalábbis ennyire nem túrtam utána, mert friss telepítés volt anno, és akkor úgy voltam vele, hogy ha nem jön be már teszek is rá valami kevésbé összedrótozott disztrót, mert azon a második fél órán már nem múlik..

Persze ez csak egy ötlet volt...

Akkor van szopó, ha már a Unity megjelenése utáni Ubid van, mert akkor a Pulse már rántja is magával az integrált hangkezelést a panelből, meg az Ubuntu-desktopot


http://taklertamas.deviantart.com/ || registered Linux User #518773 || Dell Studio 1537 #! Statler Alpha2

legfrissebb van, majd utánanézek, köszönöm addig is a válaszokat :)

Milyen érdekes. Épp erröl irtam legutóbbi hupos blogbejegyzésemben. Csak ott win7 vs. Linuxmint volt a téma. De megérne egy összehasonlítást a mint vs ubuntnu is.
Nálam a unity tiltólistán van. És a kezdet kezdetén is azért szerettem a linuxot mert szimpatikus volt a moduláris felépítése. Debiant pl mai napig úgy szeretek telepíteni,hogy alaprendszer felmegy netinstallal. Aztán apt segítségével a többi. Hosszabb meló,de így igazán én állitom össze a rendszert és jobban képben vagyok,mint egy készen kapott ubuntu esetében.
Ps. Pulseaudiót soha nem telepítek. Micsoda fasiszta megoldás ez? Beledrótozni az oprendszerbe?! Az hiszem azonnal letúrnám az ubuntut.
Azzal sem értek egyet,hogy te alkalmazkodj az oprendszerhez. Inkább az szolgálja ki a te igényeidet. Nem?

Nekem a Dell gépemen játszott ilyet, némi kutakodás után ha jól emlékszem egy "alsa-backports" csomag rántotta helyre a problémát.

szerk. (~10min later)
btw... most csak ezt találtam, hátha

if(you == understand.this){
          get.a.girlfriend;
}

Ugyan ezt csináltam én is ahogy már említettem, persze így búcsút is lehet mondani a komplett ubuntu-desktopnak unityvel együtt, mivel a Pulseaudio egyik függősége maga az Ubuntu-desktop(azaz a Unity). A srác azonban(ahogyan én is) még Unity előttit használ(Maverick). Ezért sikerült neki.

Egyébként meg van egy frankó ötletem! Tegyél fel(topicnyitó) LinuxMint Debian Editiont.. Stabilabb mint az ubi, Gnome2.3, és rolling release(tehát mindig a legfrissebb) Ubuntu one helyett ott a dropbox, a Music store, az meg amúgy is túlképpen a 7DIGITAL..... Abban könnyebben eldobhatod a Pulseaudiot..
Vagy nézz körül Kitár Zsuzsiéknál(open suse), vagy Vass Dórikáéknál (Fe dora..... ma nagggggyonhülye vagyok :-D), hátha ott jobban megoldották eztetet a dógot..

De nem is értem, ha a blogod alatt állítólag Debian ketyeg, akkor én nem is szívnék tovább a helyedben az uborkával, főleg ha már nem vagy nyúbáj... Persze tudom, lehet, hogy benned is felmerült az ami bennem: Anno Ubival kezdtem, és reméltem, hogy eljön végre az Ubi éve.. Sajna még ez sem az :-( Asszem bútorozok vissza Crunchbangre, főleg, hogy a legfrissebb LiveCD már Backportsra, meg 3.xx-es kernelre épül, így egyszerűbb lesz vele a szopás :-)

Utólag is elnézést, ha valakit megbántok, nem trollkodásnak szántam, de még azért van mit csiszolni ezen a Unity Pulse dolgon.. Egyébként meg sajnálom, és egyben szerencsésnek érzem magam, hogy a sógorom gépén nincs gond a 11.10-zel. Ha elég türelmesek vagyunk(márpedig csak mi vagyunk Linux userek türelmesek igazán) akkor talán a 12.04 már használhatóbb lesz. Mindig ezekkel a kib@xott függőségekkel qrnak fel!!! A vége ennek vagy Arch, vagy Gentoo lesz :-@..hrrrrr!!!!


http://taklertamas.deviantart.com/ || registered Linux User #518773 || Dell Studio 1537 #! Statler Alpha2

Azt hiszem, nem merem elhinni, hogy a pulseaudio-t nem lehet leszedni az ubuntu-desktop nélkül. Ez számomra kissé megrázó. Uborkával semmi bajom nem volt, néha szétesik, de összerakom, néha frissítést akar, de teljesítem, néha a háló behal, de megoldom... Szal így jól kijövök vele, mert soha nem unatkozom.

Az ubuntu-desktop az egy metapackage, sztem semmi nem lesz ha leszeded, nem tartalmaz lényges fájlokat csak függőségeket határoz meg és mást sem fog szerintem leszedni.
Ha leszeded valószínűleg nem fog elrontani semmit minden marad ugyanúgy és a pulseaudio-t is leszedheted.
Nálam:

# aptitude -sy purge ubuntu-desktop
The following packages will be REMOVED:  
  ubuntu-desktop{p} 
0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 61.4 kB will be freed.
Would download/install/remove packages.

# dpkg -L ubuntu-desktop
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/ubuntu-desktop
/usr/share/doc/ubuntu-desktop/changelog.gz
/usr/share/doc/ubuntu-desktop/copyright

Amit leírtam csak egy erős sejtés, majd megcáfolja, aki jobban tudja :)

Most én is ilyen viszonyban vagyok vele, de én már kezdem elveszteni a türelmemet, mert a Compiz halálos (mindig elfelejti illetve random felejti el a beállított képernyőszél funkciókat) meg Pulse hangrendszer nyavajás környezettel naponta szenvedni... Hogy a Nautilus mireelindulelsőinduláskoraddigrakihozzákanyugdíjam dolgáról már ne is szóljak...

Aztán lehet hozzám vágni, hogy persze mert én most az Alpha2-t tesztelem.. De ezek a dolgok más gépen is előperdültek már a stabil ággal is... Nekem amúgy sem tetszik az, hogy valami a Compizra épít egy kezelőfelületet, mikor maga az egész Compiz egy bughalmaz.. Oké, hogy kétezertízenakárhányban már legyen szép egy Linux, de milyen áron? Meg még az alábbiak is jelentkeznek nálam, és ezek is idegesítenek:

-Synaptic random összeomlik update után

-A szoftver center egy fos már bocsánat..
A fő kategóriáknál még néz ki valahogy, de amint az egyik kategórián belül keresünk, a hatalmas fehér felület az oldalt látható felsorolásokkal hogyismondjam... RONDA!!(szubjektív) Ezt már mások megcsinálták szebben is ők is. Persze ez csupán esztétikai szempont, de ezen felül maga a szoftver center is rendszeresen elhasal (11.10 óta)

-Unity Launcher1: még mindig nem értem, hogy HOGYAN HAGYHATNAK KI EGY OLYAN FONTOS ÉS KÉNYELMES, RÁADÁSUL MEGSZOKOTT FUNKCIÓT, HOGY HA MAXIMALIZÁLT ABLAK PANEL IKONJÁRA KATTINTOK, AKKOR AZ MENJEN LE SZÉPEN MINIMALIZÁLT ÁLLAPOTÁBA, ÉS NE A MEGNYITOTT ABLAKAIT MUTOGASSA NEKEM!!!! AZT MUTOGASSA hover-re, és ne onClick-re!!!!!!!!! VÁÁÁÁÁÁÁÁ (mékeerángatni azt az egeret állandóan?)

- ALT+F2-re mire feljön a dash, és mire KÉTSZER lefele nyilazok a legutóbb megnyitott alkalmazás eléréséhez, nah hát ez is minden, csak nem user friendly.......(11.10 óta így van)

-Unity Launcher2:
Az meg milyen már, hogy régebben túl hamar ugrott be a teljes képernyős alkalmazásokba(pl ha teszem azt rá akartam menni a "minimize" gombjára az alkalmazásnak), ha "dodge" módban volt, aztán az volt erre a bugfix, hogy akkor ezen túl egy hirtelen "L" alakot kell leírni az egérrel felfelé, hogy előhozd, mert ez így tuti jó lesz....(most always visible módban használom)

Bocsánat, azt hiszem egy kicsit elragadtattam magam ... :-D


http://taklertamas.deviantart.com/ || registered Linux User #518773 || Dell Studio 1537 #! Statler Alpha2

Mindenekelőtt szeretném köszönetemet kifejezni brainscan-nek és hű követőinek, amiért ilyen sikeresen zülleszik le az oldal szellemi színvonalát. Szép munka fiúk, csak így tovább. Lassan levisztek minket is a ti szintetekre és ott már rutinból nyertek.

d3xt3r:
A problémára nagy valószínűséggel van megoldás a te esetedben is. Egy Travelmate 5530G-n is előjött, kis utánnajárással kiderült hogy az ALSA nem pontosan detektálta a kártya típusát, ebből adódott a gond.
Tudnunk kellene először is a hagkártyád pontos típusát. Ehhez terminálban a következő paracsot kell beírni:
cat /proc/asound/card0/codec* | grep Codec
Ha megvan írd meg és meglátjuk mi a további teendő.
Pulseaudio-t ne piszkáld. Sokak szerint most épp ez az aktuális mumus és minden hangproblémát hajlamosak arra fogni. Nekem személyesen még soha semmilyen problémám nem volt vele.

----------------
(:> )B

Bocsánat! Azt hiszem paraszt voltam és elfogult
Alsa backports megoldásnak utána sem jártam.. :-( Viszont ezt szeretem a Linuxban, meg a közösségben!! Amikor már azt hiszi az ember, hogy nincs/nem is lesz megoldás, akkor mindig valahol megvan valakinél, vagy már reszeli, vagy ha még sincs megoldás, legalább elolvashatjuk egymás rossz tapasztalatait, és már megpróbálhatunk felkészülni, a legközelebbi hardverválasztásra, hogy nehogy jól beválasszunk


http://taklertamas.deviantart.com/ || registered Linux User #518773 || Dell Studio 1537 #! Statler Alpha2

Bocsanatot kerek, hogy nem mukodik rendesen az Ubuntu ....

dexter@notebook:~$ cat /proc/asound/card0/codec* | grep Codec
Codec: VIA VT1708S

akkor pulseaudio-t le szedjem, vagy ne szedjem? vagymi?

Én már nem merek mondani semmit, mert bár fentebb bűnbocsánatot gyakoroltam, az a személy, aki többünket itt megrótt gyalázkodásunk, és színvonalrontásunk miatt, most mégsem áll elő neked azzal az ötlettel, amit mi nem tudtunk leírni Ubifika nélkül.

megpróbálod megkeresni a hardvergyártó honlapját, hátha van Linuxos driver, majd azt forrásból felteszed.

khm.... A DRIVERED


http://taklertamas.deviantart.com/ || registered Linux User #518773 || Dell Studio 1537 #! Statler Alpha2

Én kiváncsiságból leszedtem, és még fasza kis installation guide is van mellékelve, meg némi chipset info, ilyesmi.....

Ha ez sem segít, akkor sajna csak az ecetes olló.....
Vagy még itt is írogatnak valamit... bár ez már régi írás, de lehet, hogy mégis bejöhet belőle valami..

http://ubuntuforums.org/showthread.php?t=1462288&page=2


http://taklertamas.deviantart.com/ || registered Linux User #518773 || Dell Studio 1537 #! Statler Alpha2

Egy percig sem állítottam hogy kezemben van a tuti megoldás. Mint minden ilyen probléma ez is igényel nem kevés utánnajárást, google ill. fórumok olvasását stb. Ez bizony időigényes, és sokszor még így sem vezet eredményre a dolog. A lényeg ott van, hogy az ember kicsit elgondolkodik és megpróbál segíteni a másiknak.
Tudomásul kell venni hogy ez egy alapvetően Linux-os fórum, vagyis az "hehe, rakjál fel Win-t" meg "deszarezaUbuntu meg a linuxis" ill. "Win7 alatt megy" stb. kommnetek (nehogy félre értsd nem azt mondom hogy te írtál ilyeneket, csak a stílus és hozzáállás érzékeltetésére szolgálnak), nem igazán segítenek a hlyzeten és akkor még finom voltam.
Aki itt kér segítséget meg van rá az oka hogy nem Windowst használ. Én sem megyek windows-os fórumokra butaságokat irogatni, mert az egyrészt engem minősít másrészt senki nincsen vele előrébb.

A sok fikázás helyett inkább azzal az ötlettel kellett volna kezdeni amit itt és a következő hozzászólásodban felvázoltál. Ebből rögtön kiderül hogy tulajdonképpen értelmes fazon vagy ha összekapod magad :)

----------------
(:> )B

Pulseaudio-t ne szedd le. Azzal nem fog megoldódni a problémád, mert azt az ALSA hardverdetektálása okozza.
Eddig annyit siekrült kiderítenem, hogy az újabb ALSA verziókban már javították a codec hibáinak nagy részét köztük ezt is.

"On irc in the channel #alsa dtchen mentioned that the VIA codecs have been significantly recently.

Fixed in these packages:

ii alsa-base 1.0.24+dfsg-0ubuntu1 ALSA driver configuration files
ii alsa-utils 1.0.24.2-0ubuntu6 Utilities for configuring and using ALSA
ii bluez-alsa 4.91-0ubuntu1 Bluetooth ALSA support
ii gnome-alsamixer 0.9.7~cvs.20060916.ds.1-2 ALSA sound mixer for GNOME
ii gstreamer0.10-alsa 0.10.32-1ubuntu5 GStreamer plugin for ALSA
ii linux-alsa-driver-modules-2.6.38-10-generic 2.6.38-10.201107131605 Ubuntu-supplied Linux modules for version 2.6.38-10-generic ALSA snapshots"

Hasonló esetben (https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/164708), az oldotta meg a problémát, hogy a srác felvette az Ubuntu Audio Dev PPA-t (Synaptic-ban a ppa:ubuntu-audio-dev/ppa -t kell a források közé felvenni, majd frissíteni a rendszert) és frissítette a meglévő ALSA Driver modulokat.

Az információkat ezekből a forrásokból szedtem, ha te is átolvasnád őket:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/607482
https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules
https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/164708
https://launchpad.net/~ubuntu-audio-dev/+archive/ppa/+packages?field.name_filter=&field.status_filter=published&field.series_filter=lucid

Nem állítom hogy ez a tuti megoldás de egy próbát azért megér, ha nem jön össze legalább tudni fogjuk hogy mással kell próbálkozni.

Javasolták meg a VIA HD Audio Driver telepítését forrásból. Ami fájlt linkeltek az viszont nem jó mert neked nem Debian 4.0 van. Helyette ezt: http://drivers.viaarena.com/via_linux_hd_audio_fc4-c6&mdv2006-07.0_hd_audio_driver_ig_v0.82a.tar.gz a fájlt kell letöltened, de mivel a telepítési útmutató régebbi Debian rendszert vesz alapul, és egyébként is pilótavizsgás, és nem ajánlom a dolgot. Maga az ötlet egyébként jó, nekem nem jutott eszebe a gyártó oldalán keresgélni. Ha erre adnád a fejed mindenképp kérd "tartalektamas" segítségét, hátha neki nagyobb tapasztalata van a forrásból telepített cuccokkal.

Majd írd meg mire jutottál.
----------------
(:> )B

Nah, ha ennyi info után sem sikerül neki, akkor már tényleg csak az ecetes olló...
Egyébként egy gyors guglizással a "VIA VT1708S" -""kulcsszót"" beírva, hamar olyan írásokba lehet botlani, hogy ez többeknek sem jött össze, vagy legalábbis nem működik flottul.. Sajnálnám, ha nem sikerülne, mert akkor lenne egy újabb chipset amit messze el kell kerülni ha Linuxra adja a fejét a júzer...

Amúgy meg nincs nagyobb tapasztalatom.......
Az a baj, hogy ha esetleg csak régebbi Alsa verzióval megy neki, mint amit a disztró szállít, akkor függőségi problémákba is ütközhet.. :-(

Csak próbálom kitalálni a megoldást kis hentes agyammal.
Nem gondoltam volna, hogy a VIA cuccoknak ilyen elavult a supportja Linuxon..

Még esetleg ki lehet prószálni egy régebbi Ubuntu változatot, vagy végső elkeseredésben Debian, Fedora, vagy OpenSuse livecd-t, hogy megy e azzal a dolog. Aztán ha igen, akkor azt kell használni.

Sajna nagyon nem egyedi a gond egyébként:

http://forums.linuxmint.com/viewtopic.php?t=90006&f=49 ## nekik nem sikerült
http://hardc0l2e.wordpress.com/2011/04/25/vt1708a-workaround-for-ubuntu-10-10/ ## neki sikerült megoldania, de nem a /S, hanem a /A chipsetje volt, továbbá az is kiderül, hogy a 10.10 kernelében volt valami fasság..

Itt is írnak a problémáról:
http://www.debianuserforums.org/viewtopic.php?f=7&t=613


http://taklertamas.deviantart.com/ || registered Linux User #518773 || Dell Studio 1537 #! Statler Alpha2

na most aztán semmi hang :D ami a pdf-be van leírás, az alapján csináltam és elnémult minden...

valszeg én balfaszkodom, de kifejezetten hálás lennék, ha egy szájbarágós leírást kapnék a régi driver eltávolításáról, és az új teljes beüzemeléséről.

Reméltem hogy nem a "PDF-es leírás alapján drivertelepítés" lesz az első amit kipróbálsz, mert mint írtam is, az nem Ubuntu-hoz készült ráadásul már több mint 4 éves.
Én azt javasolnám hogy amennyire lehet próbáld meg a leírás alapján visszalapátolni a módosításokat és próbáld ki inkább a PPA-s megoldást hátha az jobban bejön.

----------------
(:> )B

Gyorsmegoldás hasonló esetekre:

Kimásolod a /lib/modules/ alól a kernelmoduljaid, hogy legyen mit visszaállítani, ha valamit elkutyulsz.
Ellátogatsz az alsa honlapjára, letöltöd az épp aktuális alsa-driverst.
make, majd sudo make install
Végül a hangkártyához tartozó modulok újratöltése, vagy ha nem akarsz kókányolni, restart.

Ha megjavult, örülsz, ha nem, szomorkodsz. Ha még rosszabb lett a helyzet, mint volt, visszaállítod a gondosan jó előre lementett kernelmoduljaid.

"régebbi Ubuntu változatot" <- Nem inkább egy újabbat kellene?
Azt én is néztem hogy sokan szenvednek vele, pedig egy viszonylag régi codec-ről van szó... Nem hiszem hogy a gyártóktól olyan óriási erőfeszítést követelne, hogy legalább az alapvető funkciókat committeljék az ALSA-ba hogy ne kelljen mindent mindig visszafejteni. Talán majd az az idő is eljön egyszer...

----------------
(:> )B

Fentebb írta az illető, hogy "asszem a legfrissebb van" ezért javasoltam régebbit..
A lényeg az, hogy kell találni egy olyan verziót amivel megy. de az is lehet, hogy ha megpróbál akárcsak egy LinuxMint 12-t telepíteni(hogy mindenképp maradjunk az Ubuntu holdudvarában, nehogy be kelljen mocskolni a kezünket egy Archlinuxszal is akár) , lehet hogy abban másik Alsa verzió van.. De legegyszerűbb a disznóvaccson(distrowatch.com) megnézni a különböző disztrók csomaglistáiban a verziószámot, hogy melyikben hányas, és olyat feltenni amivel nem volt baj.

De eddig gergov megoldása a legjobb tegye fel ami volt is rajta(azaz a 11.10), majd lementi a modulokat, aztán meg lehet kísérletezni Alsa verzókkal... Sajna ez nem megy máshogy, mert ez pont nem egy "klikk->klikk->klikk oszt meg is van oldva" probléma.

Én csak azért vagyok a másik Ubuntu verzió, vagy másik disztribúció telepítése mellett(főleg, ha azon a gépen volt már olyan ami ment, és emlékszik is rá, hogy mi volt az), mert lehet, hogy az Alsa vacakolás esetleg szabadidőtől, függően napokig is eltarthat, egy új telepítés, még a legrosszabb esetben is(kurvarégigépen) max 1 óra


http://taklertamas.deviantart.com/ || registered Linux User #518773 || Dell Studio 1537 #! Statler Alpha2