Megoldva. Quake live szivat? Avagy mit kezdjek egy msi file-al linux alatt?

Fórumok

Igaz nem mondanám, hogy napi szinten beugrok Quake live-ba, de néha nagyon jól esik/esne. Ahogy most is. Mióta létezik a linuxos verzió azóta használgatom. Bár időnként jött olyan frissítés ami kifagyasztotta a böngészőt, ilyenkor pihentettem. Egy darabig azt hittem az a baj hogy Iceweasel nem pedig Firefox, de a következő frissítés után legtöbbször rendbe jött.

Pár napja újra rámjött a Quakezhetnék, viszont most nem a quakeplugint frissítené, hanem egy msi file-t, mégpedig a QuakeLiveNP_433.msi -t ajánlgatja nekem, ami tudomásom szerint egy windows installer.

Nem hittem neki, továbbmentem, és ha csatlakoznék ezt kapom:

You are downloading required data and must let it finish before you can join an online match.

A fórumban semmit nem találtam ere vonatkozólag.

Oprendszer még mindig Lenny, nem volt időm frissíteni..

Találkozott már más is ilyennel?

Hozzászólások

Nem írod hogy milyen böngésző, feltételezem Firefox4.
Ez kell neked:
http://cdn.quakelive.com/assets/2011031504/QuakeLivePlugin_433.xpi?v=0,…
"Hivatkozás mentése más néven", mert berhelni kell. Az xpi egy átnevezett zip fájl, bármivel meg tudod nyitni.
Belül install.rdf nézzen így ki:

http://www.quakelive.com/forum/showthread.php?7195-Running-Quake-Live-i…

Sajnos nem tudom ide beszúrni, mert még a [ code] mező is rosszul jeleníti meg.
Így állítólag megy, én még nem teszteltem le.

----------------------------------------------------------
"One should strive to achieve; not sit in bitter regret."
www.xonotic.org

1: mivel verziót nem írtál, nem lehetett tudni, hogy melyik firefoxnak megfelelő böngészőt használsz, és gondolom az emberek túlnyomó többsége nem up2date az iceweasel verziókból.
2: a user agern eleje még ie-ben is mozilla (mutass 1 browsert amiben nem), nyilván ezért a regexp a végét nézi.
3: böngészővel hivatalosan nem kompatibilis extension telepíthető az extensionbe való belenyúlkálás nélkül is, az about:config-ban az extensions.checkCompatibility-t kell false-ra állítani.

--
Don't be an Ubuntard!

Ok igaz, Lassan már csak én vagyok az aki tudja, hogy a Lenny-ben még mindig 3.0.x Iceweasel van, mert más már nem használja. Tegnap pont emiatt vettem fel a backports tárolót, mert elvileg benne van a 3.6-os, gyakorlatilag nincs.

De látom már hol a gond, igazatok van. Valami nem volt rendben az utóbbi hetekben vele (legalább újra operát használok) ez:
"Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8"
Fogalmam sincs mi írta át, még a moonlight plugint is kivettem nem rég.
Sürgősen frissítenem kell az egész rendszert.

Nagy köszönet :)
--
AGA@
Clyde Radcliffe Exterminates All the Unfriendly Repulsive Earth-Ridden Slime

Az iceweasel user agent-jét kell átírni azonos verziójú firefox-ra, és írd bele, hogy linux-os.
http://www.netdip.com/user-agent-switcher-iceweasel-firefox-ik/

mondjuk valami ilyesmi kerüljön bele:
"Mozilla/5.0 (X11; U; Linux i386; hu; rv:1.9.1.7) Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7 (.NET CLR 3.5.30729)"

Persze lehet, hogy valami command line opcióval is meg lehet adni, hasonlóan ehhez (már elavult)