Excelben nevek kigyűjtése

 ( csonkasanyi | 2009. december 1., kedd - 10:36 )

Sziasztok!

Excelben, vagy OO.o Calcban szeretnék olyat megoldani, hogy a táblázat két oszlopában (legyenek ezek az A,B oszlopok) nevek szerepelnek. Ezekből a nevekből szeretném kigyűjteni egy 3. oszlopba (legyen ez C), azokat a neveket, amelyek mindkét oszlopban szerepeltek. A neveknek nem feltétlenül kell egymás mellett lenniük A-ban és B-ben!

Hogy lehet ezt táblázatkezelővel megcsinálni?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

vlookup függvény, vagy valami hasonló amit keresned kell.

a vlookup nem működik megbízhatóan.

ha van rá mód és lehetőség akkor szórd be normális adatkezelőbe, és oldd meg ott.

ha nincs, akkor:
-deduplikáld A-t, majd B-t, majd tedd őket egy oszlopba.
-rendezd a neveket,
-írj egy függvényt, ami 1-et ad ha két sorban ugyanaz az érték van,
-majd szűrj rá erre az 1-es értékre, és kész vagy.

Vagy nem.
Ha rendezve: ABCD és DEFG a két oszlop elemei, akkor a módszered alapján nulla "találat" van.

Excellben:

=HA(A1=B1;A1;"")

mármint magyar excellel, angolul természetesen IF a függvény. Ez amúgy a google docban is működik, és oo-ban is esélyes (bár azt nem használom)

viszont írta hogy nincsenek egymás mellett a nevek.

Lényegében ez két halmaz metszete, lehet ágyúval lőnék verébre, de én MySQL-ben csinálnék 1 táblát, abba átimportolnám és két SELECT-tel és egy INTERSECT-etl megoldanám.

(SELECT oszlop_a FROM tabla LIMIT 0, 5000) INTERSECT (SELECT oszlop_b FROM tabla LIMIT 0, 5000)

Tényleg nincsenek egymás mellett a nevek, ezért a C oszlopba egymás után bemásoltam az A és a B tartalmát, abc sorrendbe rendeztem, így ha vannak párok, akkor azok egymás alá kerülnek, majd erre alkalmaztam az alábbi képletet:
=HA(C1=C2;C1;"")
ez tulajdonképpen a párokat vizsgálja, és D-be beírja azokat a neveket, ahol a párok egyeznek, ahol meg nem, oda meg nem ír semmit!

Köszi mindenkinek a sok megoldási javaslatot!

ha jól emlékszem valami tömbképlettel meg lehetett oldani ilyet

I am the god of hellfire, and I bring you...

Sztem probald meg ezt a C oszlopban

=IF(AND(ISNUMBER(MATCH(A1;B$1:B$100;0))=TRUE();ISNUMBER(MATCH(B1;A$1:A$100;0))=TRUE());"ki kell gyujteni";"nem kell kigyujteni")

itt mindkettonek (tehat A-nak es B-nek is meg kell lennie a masik oszlopban valahol)
ha eleg csak az egyik is az AND-et ird at OR-ra

=IF(COUNTIF($A$1:$A$100;B1);B1)

szerkesztve: Látom lekéstem, de hátha valakinek kell majd valamikor :)

ha van pl. 15 sor az A és b oszlopokba akkor
a c oszlopba így ki tudod gyűjteni: =IF(COUNTIF(B$1:B$15,A1)>0,A1,"nincs tobbszor")

I am the god of hellfire, and I bring you...