MPlayer videó hiba (megoldva)

 ( hnsz2002 | 2007. június 15., péntek - 16:26 )

A problémám, hogy az MPlayer a videót nem jól jeleníti meg. Semmilyen formátumnál. Úgy néz ki a dolog, hogy a képernyő tetején két videóablak van, de mindkettőbe inverz, fura a kép... Egyszerűb, ha adok egy screenshot-ot: http://hnsz.uw.hu/screenshot.jpg

Mi a gond? OpenSUSE 10.2...

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

olyan screenshot kéne ahol látni az mplayer üzeneteit is
vagy azokat vágd be hogy milyen -vo val megy
esetleg próbáld -vo x11 -vo xv -vo gl2

Celeron-M 1400Mhz, 768M, Debian SID, 2.6.22-rc2

Erre a paraméterre el se indul:
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.40GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support. You will not be able to use your remote control.

Playing 13 - megvan subba!!!! .avi.
AVI file format detected.
VIDEO: [DX50] 640x336 24bpp 25.000 fps 812.6 kbps (99.2 kbyte/s)
Clip info:
Software: VirtualDubMod 1.5.10.2 (build 2540/release)
Error opening/initializing the selected video_out (-vo) device.

Egyébként az output:
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.40GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support. You will not be able to use your remote control.

Playing 13 - megvan subba!!!! .avi.
AVI file format detected.
VIDEO: [DX50] 640x336 24bpp 25.000 fps 812.6 kbps (99.2 kbyte/s)
Clip info:
Software: VirtualDubMod 1.5.10.2 (build 2540/release)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 640 x 336 (preferred colorspace: Planar YV12)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.90:1 - prescaling to correct movie aspect.
SwScaler: using unscaled yuv420p -> bgr565 special converter
VO: [fbdev] 640x336 => 640x336 BGR 16-bit
A: 17.1 V: 17.1 A-V: 0.004 ct: 0.000 428/428 9% 7% 0.5% 0 0

adjal meg neki egy: -vo xv,x11 -et

[törölve]

MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.40GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support. You will not be able to use your remote control.

Playing 13 - megvan subba!!!! .avi.
AVI file format detected.
VIDEO: [DX50] 640x336 24bpp 25.000 fps 812.6 kbps (99.2 kbyte/s)
Clip info:
Software: VirtualDubMod 1.5.10.2 (build 2540/release)
Error opening/initializing the selected video_out (-vo) device.

:(

[szerk] most jöttem rá, hogy az et nem kapcsoló... :D

próbáld meg root-ként, ha nem serveren vagy.
__________________________________________________________________

Nekem mindig igazam van, ha nem, akkor nincs igazam, szoval megint igazam van hogy nincs igazam.

próbáltam, detto

Milyen VGA/driver?

NVidia FX5200

Driver előtt és most driver telepítése után sem megy

-vo sdl
?

hornyakn@zeus:/windows/F/_iras/Film> mplayer -vo sdl 13\ -\ megvan\ subba\!\!\!\!\ .avi
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.40GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support. You will not be able to use your remote control.

Playing 13 - megvan subba!!!! .avi.
AVI file format detected.
VIDEO: [DX50] 640x336 24bpp 25.000 fps 812.6 kbps (99.2 kbyte/s)
Clip info:
Software: VirtualDubMod 1.5.10.2 (build 2540/release)
Error opening/initializing the selected video_out (-vo) device.

Exiting... (End of file)
hornyakn@zeus:/windows/F/_iras/Film>

tipp nevezd át a filmet mondjuk 13_megvan_subba.avi -ra
lehet, hogy ez kavar be

__________________________________________________________________

Nekem mindig igazam van, ha nem, akkor nincs igazam, szoval megint igazam van hogy nincs igazam.

nem a névvel van a baja, mindennel ezt csinálja, akkor is, ha 1.wmv a neve

Szerintem valahol ennek a környékén kellene a hibát keresni:

VDec: vo config request - 640 x 336 (preferred colorspace: Planar YV12)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar YV12 as output csp (no 0)

nem
probald csak meg ugy hogy:
mplayer -vo xv -v A FILEOD
es masold be ide az egeszet a-z ig
hasznalsz: pl berylt vagy compiz-t ?

egyiket sem használom

az output:
hornyakn@zeus:/windows/F/_iras/Film> mplayer -vo xv -v 13\ -\ megvan\ subba\!\!\!\!\ .avi
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.40GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
get_path('codecs.conf') -> '/home/hornyakn/.mplayer/codecs.conf'
Reading /home/hornyakn/.mplayer/codecs.conf: Can't open '/home/hornyakn/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
CommandLine: '-vo' 'xv' '-v' '13 - megvan subba!!!! .avi'
get_path('font/font.desc') -> '/home/hornyakn/.mplayer/font/font.desc'
font: can't open file: /home/hornyakn/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
Using nanosleep() timing
get_path('input.conf') -> '/home/hornyakn/.mplayer/input.conf'
Can't open input config file /home/hornyakn/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support. You will not be able to use your remote control.
get_path('13 - megvan subba!!!! .avi.conf') -> '/home/hornyakn/.mplayer/13 - megvan subba!!!! .avi.conf'

Playing 13 - megvan subba!!!! .avi.
get_path('sub/') -> '/home/hornyakn/.mplayer/sub/'
[file] File size is 729147392 bytes
STREAM: [file] 13 - megvan subba!!!! .avi
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
AVI file format detected.
list_end=0x2286
======= AVI Header =======
us/frame: 40000 (fps=25.000)
max bytes/sec: 0
padding: 0
MainAVIHeader.dwFlags: (272) HAS_INDEX IS_INTERLEAVED
frames total: 143773 initial: 0
streams: 2
Suggested BufferSize: 0
Size: 640 x 336
==========================
list_end=0x10F4
==> Found video stream: 0
====== STREAM Header =====
Type: vids FCC: DIVX (58564944)
Flags: 0
Priority: 0 Language: 0
InitialFrames: 1
Rate: 25/1 = 25.000
Start: 0 Len: 143773
Suggested BufferSize: 51223
Quality 0
Sample size: 0
==========================
Found 'bih', 40 bytes of 40
======= VIDEO Format ======
biSize 40
biWidth 640
biHeight 336
biPlanes 1
biBitCount 24
biCompression 808802372='DX50'
biSizeImage 2488320
===========================
Regenerating keyframe table for MPEG-4 video.
list_end=0x217A
==> Found audio stream: 1
====== STREAM Header =====
Type: auds FCC: (0)
Flags: 0
Priority: 0 Language: 0
InitialFrames: 1
Rate: 24000/1 = 24000.000
Start: 0 Len: 138022080
Suggested BufferSize: 12000
Quality -1
Sample size: 1
==========================
Found 'wf', 18 bytes of 18
======= WAVE Format =======
Format Tag: 8192 (0x2000)
Channels: 2
Samplerate: 48000
avg byte/sec: 24000
Block align: 1
bits/sample: 0
cbSize: 0
==========================================================================
list_end=0x2286
AVI: dmlh found (size=248) (total_frames=143773)
list_end=0x22C6
hdr=Software size=44
Software : VirtualDubMod 1.5.10.2 (build 2540/release)
list_end=0x2B2FB1F0
Found movie at 0x280C - 0x2B2FB1F0
Reading INDEX block, 287535 chunks for 143773 frames (fpos=724546040).
AVI index offset: 0x2808 (movi=0x280C idx0=0x4 idx1=0x2EEC)
Auto-selected AVI audio ID = 1
Auto-selected AVI video ID = 0
AVI: Searching for audio stream (id:1)
AVI video size=584165332 (143773) audio size=138022080 (138022080)
VIDEO: [DX50] 640x336 24bpp 25.000 fps 812.6 kbps (99.2 kbyte/s)
[V] filefmt:3 fourcc:0x30355844 size:640x336 fps:25.00 ftime:=0.0400
Clip info:
Software: VirtualDubMod 1.5.10.2 (build 2540/release)
get_path('sub/') -> '/home/hornyakn/.mplayer/sub/'
Error opening/initializing the selected video_out (-vo) device.

Exiting... (End of file)
hornyakn@zeus:/windows/F/_iras/Film>

a /etc/X11/xorg.conf ba
Section "Module" -ba van olyan hogy: Load "extmod" ?

szerk: tedd be az egeszet

van....

# /.../
# SaX generated X11 config file
# Created on: 2007-06-14T20:29:47+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer , 2005
# Contact: SaX-User list
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
FontPath "unix/:7100"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "hu"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "9"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Generic Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 306 230
HorizSync 30-71
Identifier "Monitor[0]"
ModelName "PHILIPS 107G5"
Option "DPMS"
VendorName "PHL"
VertRefresh 43-160
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce FX 5200 (0x0322)"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

"mplayer -vo help" <- mit mond?

hat ez az. nyilvan semmilyen dev package nem volt felteve, oszt csak fbdev-et forditott bele a kerdezo ami meg nem megy (eleve X alatt nem ertem ennyire egyaltalan mitol megy).

szerintem fel kene tenni valami x11-dev vagy hasonlo nevu csomagot. meg gondolom a mesa-dev -et hogy a vo gl2 menjen.

- Use the Source Luke ! -

suse alatt anno (4 éve) én is szivtam, de debin alatt 1x sem, a legujabb debianban (Etch) csak apt-get install mplayer és megy, de jobban szeretem én forgatni, ahhoz meg kismilló header kell, ami nem biztos hogy suse repoban fenn van
keress inkább rpm csomagot valamerre
__________________________________________________________________

Nekem mindig igazam van, ha nem, akkor nincs igazam, szoval megint igazam van hogy nincs igazam.

Nem akarom leváltani a SuSE-t, szeretem... :) És eddig semmi komoly bajom nem volt semmivel. Egyébként anno a 9.3 alatt simán ment, pedig ugyanígy forrásból csináltam.
./configure
make && make install

És ment hiba nélkül.... A vas is ugyanez volt.

Ez alatt mit értesz?

zeus:/etc/X11 # mplayer -vo help
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.40GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
Available video output drivers:
fbdev Framebuffer Device
fbdev2 Framebuffer Device
cvidix console VIDIX
null Null video output
mpegpes Mpeg-PES to DVB card
yuv4mpeg yuv4mpeg output for mjpegtools
tga Targa output
pnm PPM/PGM/PGMYUV file
md5sum md5sum of each frame

zeus:/etc/X11 #

Ez nem elég? :/ Defaultból ennyit rak fel. Akkor hogy csináljam?

mint ahogy mondtak mar masok is az a baja h nincsenek fenn a fejleszoi csomagok
yastal tedd fel a:
xorg-x11-libXv-devel
alsa-devel
sdl-devel
kb ennyi eleg is

mar ha ittartunk, miert nem hasznalsz rpm et, nem akarlak megeserteni de kezdonek tunsz:)

nezegesd ezt meg: http://opensuse-community.org/Package_Sources/10.2
es akkor lesz mplayer meg minden finomsag yastba :)
gl

Nem is állítottam, hogy profi vagyok! :) Azért nagyjából tudom-értem a dolgokat, de ilyen problémával még nem találkoztam.

Felraktam, amiket mondtál... 1 próba...

"Nem is állítottam, hogy profi vagyok! :)"
nem, csak sokan sertesnek veszik

Grat, ott a pont! Köszönöm szépen!!! :D
Csomagok fel, újrafodítás és voálá!

THX! :)

zeus:/etc/X11 # mplayer -vo help
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.40GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
Available video output drivers:
fbdev Framebuffer Device
fbdev2 Framebuffer Device
cvidix console VIDIX
null Null video output
mpegpes Mpeg-PES to DVB card
yuv4mpeg yuv4mpeg output for mjpegtools
tga Targa output
pnm PPM/PGM/PGMYUV file
md5sum md5sum of each frame

zeus:/etc/X11 #

Off: ksnapshot. (Kubuntuban bindelve van a svcreenshot gombra, lehet hgy neked is.) :ON
__________________________________________________________________
Dúdold ezt a dalt, és aki gyűlöl majd érte, az lesz a bosszú népe.

OK ;)

vo=gl ?

Elindul, de ugyanaz a helyzet, mint a nyitó kérdésembe a kép...

Nem tudsz downgradelni? De komolyan. Én a legújabb meplayerrel én is iszonyat sokat szívtam mire kiderült hogy tényleg rossz, nekem dvd-t nem volt hajlandó lejátszani csak kb 3fps-el a meghajtó pedíg visított mint a veszedelm, ebből kihozott 3fps-t.
[Flame on]
Én azt vettem észre hogy egyre bugosabb a stuff. A kicsit régebbiek valóban kevesebb dolgot támogattak, de az a keveebb dolog működött. Én be is állítottam a portagenek hogy ha lehet akkor 1.0-rc1-nél újabb nem kel az még megy.
[Flame off]

nekem is 1.0 rc1 van.... Keressek régebbit? mondjuk 0.9?

Annyira nem hiszem hogy régebbi kell, ha jól megy akkor ok, akkor semmi baj nincs vele, Bocs nekem nem rc1-van hanem pre8 vagy mi. Szerintem azért szívózik nekem ilyen sokat mert 64-bites a gép meg a rendszer is.

OK, most fordul a pre8... Pár perc, és mondok eredményt.... :)

Ez se megy.... :(((((((((

Akkor nincs ötletem sajnálom. Más lejátszókkal minden ok?

minek downgradelni ? az a baj hogy nincsen(ek) fent az x11 devel csomag(ok), anelkul meg nem sikerul beleforditani normalis - X alatt (jol) mukodo - videokimeneteket az mplayerbe.

azt hogy suse-ban milyen x11 devel csomagok vannak en nem tudom, talan keresd meg.

amugy meg nem tudom miert kell fikazni az mplayert. szabadforrasu, utana tudsz nezni SVN-ben hogy mikor romlott el, melyik commitnal, errol lehet szolni a keszitoknek es valoszinu kijavitjak, mert csak nem tudnak a regressziorol - vagy te is kijavithatod es a javitast kuldod. de nyilvan az utobbiak kozul egyiket sem teszitek meg, egyszerubb itt nyavajogni feleslegesen.

- Use the Source Luke ! -

xorg-x11-devel és xorg-x11-libx11-devel csomagok vannak... Ezeket kell felrakni?

[szerk] meg egy rakás devel csomag függőségbe...

feljebb mar irtak pontosabban nezd meg.
szerintem az xorg-x11-devel mar eleg kell legyen valamire. a masik nem tudom mi (de valoszinu artani nem art).

szerk: es miert baj ha vannak fuggosegek?

- Use the Source Luke ! -

Nem baj, csak meglepődtem, hogy az egész x11-devel cucc két csomagból áll, és kb. 6MB, de aztán szólt, hogy van még egy pár cucc....