apt-get szegmentálási hiba

Fórumok

Sziasztok!

Egy roppant érdekes és kínos gondom lett a minap.

Mindenféle előjel nélkül "elromlott" az aptom&synapticom...
Az apt-get update még lefut, de a végén szegmentálási hibát dob, az összes többi parancs (apt-get upgrade, synaptic, apt-cache search, stb) pedig eleve el se indul szegmentálási hibára panaszkodva :-(

A dpkg-val nem valami hatékony a rendszert naprakészen tartani, de az legalább működik!

Nincs valakinek épkézláb ötlete?

Előre is köszi!

Hozzászólások

nekem ilyen esetben csak az segitett, ha letoroltem a *pkgcache.bin-t.

Közben megoldottam, az archívum kedvéért:

A gugli kidobta a HUPWIKIT, csak a lényeget idézem be:

" sérült a "cache"

Probléma: megsérültek az apt cache állományai.

Példa:

apt-get akarmi
(...)
Segmentation faulty Tree... 50%

Megoldás: töröld le a cacheket (rm /var/cache/apt/*.bin)."

Bejött, működik!

--
by Mikul@s

Nekem is ez volt a problémám (http://hup.hu/node/32909). Rajtam is a cache törléses segített, de a hiba újból előjön. Valakinek valami permanens megoldása?

Sziasztok!

Nálam is előjött ez a probléma de hiába töröltem a /var/cache/apt könyvtárból a bin fileokat a helyzet ugyanaz... Valakinek van esetleg más ötlete?
Kubuntu 12.04 3.2.0-30 kernel