Neverwinter Nights

 ( Kobra | 2005. október 25., kedd - 0:27 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

asszem lekéne csekkolnod újra a nwm és a küldetések fájljait ha nem okésak akkor csak felülírás és mehet a cucc ,mellesleg nekem is ez a gondom mint neked csak még leszedem ujra mert asszonták igy biztos + az md5 sem volt jo

[quote:d081d81fd1="T_Feri"]asszem lekéne csekkolnod újra a nwm és a küldetések fájljait ha nem okésak akkor csak felülírás és mehet a cucc ,mellesleg nekem is ez a gondom mint neked csak még leszedem ujra mert asszonták igy biztos + az md5 sem volt jo[/quote:d081d81fd1]
Már megtörtént... feltettem a Bioware és aliflg.org használatával is és semmi egyéb gond nincs csak ez a tetű SDL...

...teljesen a nulláról.
nwresources129.tar.gz + nwclient129.tar.gz + English_linuxclient166_xp2.tar.gz
Most még rosszabb lett:(

[code:1:6a250e4dd1][kobra@terrarium nwn]$ ./nwn
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Failed to initialize graphics.
Fatal signal: Segmentation Fault (SDL Parachute Deployed)
./nwn: line 12: 13095 Szegmens hiba ./nwmain $@[/code:1:6a250e4dd1]

Hi!

GLX extension missing? Nvidia vagy Ati driver fent van? Helyesen van beállítva? NvAGP beállítása XOrg.Conf-ban? Más 3d-s cucc megy? Összes lényeges SDL cuccok fent vannak? PATH-ba benne vannak? root-ként futtatod? Megfelelő a tgz-k md5 összege? Jó könyvtárban vannak kicsomagolva? Minden abba a mappába került? Egyik mappát patch előtt vagy után üríteni kell! (már nem emléxem pontosan) Megvolt? Google milyen találatokat dob erre a hibára? Más fórumok? Hivatalos nwn lap troubleshooting?

Ennyi jutott eszembe. bye: nightw

[quote:79dcf03885="nightw"]GLX extension missing? Nvidia vagy Ati driver fent van? Helyesen van beállítva? NvAGP beállítása XOrg.Conf-ban? Más 3d-s cucc megy?[/quote:79dcf03885]
nVidia fent van mandriva alapból fel is tette és használja... más 3D cuccot nem akartam még használni, jah MOHAA megy...

[code:1:79dcf03885]Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nv"
Option "DPMS"
Option "IgnoreEDID" "1"
EndSection
[/code:1:79dcf03885]

[quote:79dcf03885="nightw"]Összes lényeges SDL cuccok fent vannak? PATH-ba benne vannak? root-ként futtatod?[/quote:79dcf03885]
Lásd a korábbi bejegyzéseim... azok vannak fent és az az SDL csomag is amit ajánlott... az SDLt nem adja, vissza, h PATHon lenne... de ha a scriptbe kézzel beírom hogy /usr/lib/SDL az SDL akkor is kiírja hibának...

[quote:79dcf03885="nightw"]Megfelelő a tgz-k md5 összege? Jó könyvtárban vannak kicsomagolva? Minden abba a mappába került? Egyik mappát patch előtt vagy után üríteni kell! (már nem emléxem pontosan) Megvolt?[/quote:79dcf03885]
Persze...

[quote:79dcf03885="nightw"]Google milyen találatokat dob erre a hibára? Más fórumok? Hivatalos nwn lap troubleshooting?[/quote:79dcf03885]
Hogy telepítsem újra... hát ezt tettem...

[quote:9ee3848161="Kobra"]nVidia fent van mandriva alapból fel is tette és használja... más 3D cuccot nem akartam még használni, jah MOHAA megy...
[code:1:9ee3848161]Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nv"
Option "DPMS"
Option "IgnoreEDID" "1"
EndSection
[/code:1:9ee3848161]
[/quote:9ee3848161]
hát nekem nem úgy tûnik, mintha az nvidia driver olyan nagyon használatban lenne...

[code:1:e1f0457f54]
Section "Device"
...
Driver "nv"
...
EndSection
[/code:1:e1f0457f54]
Biztos megy a 3D? nvidia driver beállítása ezzel kezdődik:
[code:1:e1f0457f54]
Section "Device"
...
Driver "nvidia"
...
EndSection
[/code:1:e1f0457f54]

Hi

Akkor oszlassuk kicsit a ködöt. A dolog egyértelmű teljesen. Létezik egy GPL-es driver nvidia kártyákhoz, ami egész kielégítő támogatást nyújt, de 3d-ben nulla. nv a neve. Emellett létezik a hivatalos, nvidia által fejlesztett driver, aminek nvidia a neve. Ezt a honlapjukrók tudod letölteni. _Biztos_, hogy semmilyen nagy(értsd. legális/hivatlos, de nem fizetős) disztro cd-in nincs rajta, mert sértené az nvidia licencefeltételeit. Csomagban sem mindig léteznek, mert az sem minden esetben legális. nv driver megfelelő ahhoz, hogy XOrg menjen mindenféle felbontásban és megjelenítésben, de alkalmatlan bármilyen 3d-s képesség érdemi kihasználásához. MOHAA pedig feltehetőem szoftveresen fut, ami nem vezet túl jó teljesítményhez. Ha nincs felrakva nvidia _hivatalos_ drivere, akkor www.nvidia.com és letöltés, telepítés. Egyszerű. Ha fent van, akkor csak cseréld ki az "nv"-t, "nvidia"-ra a config file-ban.

Bye: nightw

[quote:df878b471d="nightw"]_Biztos_, hogy semmilyen nagy(értsd. legális/hivatlos, de nem fizetős) disztro cd-in nincs rajta, mert sértené az nvidia licencefeltételeit. Csomagban sem mindig léteznek, mert az sem minden esetben legális. nv driver megfelelő ahhoz, hogy XOrg menjen mindenféle felbontásban és megjelenítésben, de alkalmatlan bármilyen 3d-s képesség érdemi kihasználásához. MOHAA pedig feltehetőem szoftveresen fut, ami nem vezet túl jó teljesítményhez. Ha nincs felrakva nvidia _hivatalos_ drivere, akkor www.nvidia.com és letöltés, telepítés. Egyszerű. Ha fent van, akkor csak cseréld ki az "nv"-t, "nvidia"-ra a config file-ban.[/quote:df878b471d]

Hmm, pedig Mandrake évek óta tartalmazza:)
Nálam is telepítve van...
[code:1:df878b471d]rpm -qa | grep nvidia
nvidia-kernel-2.6.12-12mdk-7676-1mdk
nvidia-kernel-2.6.12-12mdk-i586-up-1GB-7676-1mdk
nvidia-7676-5mdk
dkms-nvidia-7676-5mdk[/code:1:df878b471d]

[quote:cd6b71f495="Kobra"]

Hmm, pedig Mandrake évek óta tartalmazza:)
Nálam is telepítve van...
[code:1:cd6b71f495]rpm -qa | grep nvidia
nvidia-kernel-2.6.12-12mdk-7676-1mdk
nvidia-kernel-2.6.12-12mdk-i586-up-1GB-7676-1mdk
nvidia-7676-5mdk
dkms-nvidia-7676-5mdk[/code:1:cd6b71f495][/quote:cd6b71f495]

OK. Valószínűleg ügyeskedtek a licence-el és valahogy becsomagolták. De cd-ken nagyon valószínű, hogy nincs rajta, csak neten van fent csomagban. De lehet, hogy közben nvidia-nak megjött az esze. Régen úgy volt, hogy újság mellékletre sem kerülhettek a driverek, mert nem engedte a cég, csak a netes letöltést. Mindenesetre az XOrg.conf-od biztosan helytelen, ha nem nvidia van beírva driver-nek, hanem nv. Azt javítsd, akkor valószínűleg minden gondod megszűnik.

bye: nightw

Ahoj!

Mandriva 2006 alatt szeretném beizzítani, de folyton ezt kapom:
[code:1:67eb1aadb8][kobra@terrarium nwn]$ ./nwn
Fatal signal: Segmentation Fault (SDL Parachute Deployed)[/code:1:67eb1aadb8]

Már fent vannak az alábbi csomagok is a játék oldalán ajánlott SDL csomag mellet:
[list:67eb1aadb8]libSDL_image1.2-1.2.4-1mdk
libSDL_ttf2.0-2.0.7-1mdk
libSDL_gfx13-2.0.13-1mdk
libSDL1.2-video-ggi-1.2.8-5mdk
perl-SDL-1.20.0-13mdk
libSDL1.2-1.2.8-5mdk
libSDL_mixer1.2-1.2.6-1mdk
libSDL_net1.2-1.2.5-4mdk
libSDL1.2-video-directfb-1.2.8-5mdk[/list:u:67eb1aadb8]

Van valakinek ötlete, h még mit nem tettem fel vagy mit kell csinálni, h menjen?

Talan elfelejtetted az nwn-et szerkeszteni..

en mar kivettem a .lib -et a lib path-bol... talan neked ez hianyzik...

!/bin/sh

# This script runs Neverwinter Nights from the current directory

export SDL_MOUSE_RELATIVE=0
export SDL_VIDEO_X11_DGAMOUSE=0

# If you do not wish to use the SDL library included in the package, remove
# ./lib from LD_LIBRARY_PATH
export LD_LIBRARY_PATH=./miles:$LD_LIBRARY_PATH

./nwmain $@

Próbáld meg root-ként futtatni, nekem is volt valami hasonló hibaüzenet, de már nem emlékszem pontosan.

Ákos

[quote:71caa4bdf7="tamasrs"]Talan elfelejtetted az nwn-et szerkeszteni..
en mar kivettem a .lib -et a lib path-bol... talan neked ez hianyzik...
[/quote:71caa4bdf7]

Nem, ezt ki vettem... de akkor is futott UHU alatt amikor benne volt... természetesen az utolsó 1.66 verzió lenne.
Viszont most bele írtam, h írja ki a változókat és a [code:1:71caa4bdf7]export LD_LIBRARY_PATH=./miles:$LD_LIBRARY_PATH

echo $LD_LIBRARY_PATH
[/code:1:71caa4bdf7]

alapján csak a [i:71caa4bdf7]./miles:[/i:71caa4bdf7] a $LD_LIBRARY_PATH változó értéke

erre a cserére van valakinek ötlete?
ha leszedem őket, egy rakás függőség is elszáll és követhetetlen mennyiségű a csomag amit leszed...

Más ötletem meg nincs az SDL problémára...:(

[code:1:ab0e5429fe]sudo urpmi SDL-1.2.5-1.i386.rpm

SDL-1.2.5-1.i386.rpm telepítése folyik
Előkészítés... #############################################
A telepítés nem sikerült:
file /usr/lib/libSDL-1.2.so.0 from install of SDL-1.2.5-1 conflicts with file from package libSDL1.2-1.2.8-5mdk
file /usr/lib/libSDL-1.1.so.0 from install of SDL-1.2.5-1 conflicts with file from package games-compat-0.3-4mdk
[/code:1:ab0e5429fe]

SIKERÜÜÜÜÜÜÜÜÜLTTT!!!!!!!!!!!!!
ha csak aaz alap sdl libeket rakod fel akkor megy ,a sok sdl-es cuccot szedd le és probáld egyenkén ,ubuntu alatt vmi oss-all csomiban vannak a a cuccok ,ha meg nem akarsz kísérletezuni akkor szedd le a slipknot Fxxx this world c. számát és ha megy az elején a gitár akkor elvilek okés a game(ez komoly én is igy csináltam)
sok sikert

# This loads the font modules
Load "type1"
# Load "speedo"
Load "freetype"
# Load "xtt"
Load "nvidia"
# This loads the GLX module
Load "glx"
# This loads the DRI module
Load "dri"

xorg.conf -ban ez van
illetve:

az sdl-t hajtsd el a gépedről, nekem csak a szívás van vele gentoo alatt

[quote:e26c097b3a="gUHU"]Load "nvidia"
Load "/usr/X11R6/lib/modules/extensions/nvidia/libglx.so"[/quote:e26c097b3a]
ez ugyan az?
[quote:e26c097b3a="gUHU"]
az sdl-t hajtsd el a gépedről, nekem csak a szívás van vele gentoo alatt[/quote:e26c097b3a]
ha megpróbálom az agést x rendszert leszediné...