XF86-ban ALT-Gr probléma

Fórumok

XF86-ban ALT-Gr probléma

Hozzászólások

Hali!
Megvan a dolog átírtam most se jó.

[quote:2f9a0a0e29="sany"][quote:2f9a0a0e29="Boy"]Hali!
Debian alatt nem megy az alt-gr, nincsen hoszú û...
tud valaki segíteni?
Köszi!

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "hu"
# ez a sor nem kell! Option "XkbOptions" ""
EndSection

ctrl+alt+F1 > mélyterminál

bejelentkezés rootként
killall gdm/xdm/kdm (amivel megy)
cd /ect/x11
mc
rájalépsz az XF86Config -ra > F4
mekeresed a "keyboard" részt
"#" jelet elé, ami nem kell ill beírod ami kell!
F2 > enter
ha "mc command no found"
Akkor
nano /ect/x11/ XF86Config
ha kész,
gdm

Hali!
Nem tudom, újat mondok-e, még nem is értek nagyon a Debainhoz, sem az Xhez, kovetkezo a kerdesem. Letoltok egy minimalis debian cd-t, felrakom rola a base systemet, hogy legyen apt, meg ilyesmi. aztan szepen sorjaban felrakom az X-et, aztan xfce4-et, avgy enlightenmentet, mindegy. de: hiaba nyomom az alt-gr-t, nem muxik. ctrl-alt-F1 - F6 ban muxik, Xben sehogysem. akarhanyszor ujrakonfiguralom, nem megy. nem szeretek mikeroszoft vendozt hasznalni, de mivel sokmindent szeretnek linux alatt csinalni, ezert igy tarthatatlan a helyzet.

kérem, hogy aki ismeri a problemat, volt mar ilyenje, vagy csak 5lete, van, irjon.

(gugliban mar kerestem ezt a problemat, meg debian forumokon, de sehol nem talaltam megoldast. egyik forumon ajanlottak olyan programot, amivel ujra ki lehet osztani a billentyuzetet, csak az meg nem ismerte a magyart bill.-t)[/b]

Hali!

Talán olvasd el ezt, hátha találsz megoldást a problémádra. :wink:
http://www.hup.hu/wiki/index.php/Debian_desktop_kialak%C3%ADt%C3%A1sa

[quote:22fdb9e78e="kitsi"]Hali!

Talán olvasd el ezt, hátha találsz megoldást a problémádra. :wink:
http://www.hup.hu/wiki/index.php/Debian_desktop_kialak%C3%ADt%C3%A1sa

Sajnos nem találtam benne semmi erre vonatkozót, azért köszi!

Köszi, így sem megy minden verzíót beírtam már...majd legközelebb

[quote:9228dd0f35="sany"]ctrl+alt+F1 > mélyterminál

bejelentkezés rootként
killall gdm/xdm/kdm (amivel megy)
cd /ect/x11
mc
rájalépsz az XF86Config -ra > F4
mekeresed a "keyboard" részt
"#" jelet elé, ami nem kell ill beírod ami kell!
F2 > enter
ha "mc command no found"
Akkor
nano /ect/x11/ XF86Config
ha kész,
gdm

[quote:65a51e8d12="ghannak"]Hali!
Nem tudom, újat mondok-e, még nem is értek nagyon a Debainhoz, sem az Xhez, kovetkezo a kerdesem. Letoltok egy minimalis debian cd-t, felrakom rola a base systemet, hogy legyen apt, meg ilyesmi. aztan szepen sorjaban felrakom az X-et, aztan xfce4-et, avgy enlightenmentet, mindegy. de: hiaba nyomom az alt-gr-t, nem muxik. ctrl-alt-F1 - F6 ban muxik, Xben sehogysem. akarhanyszor ujrakonfiguralom, nem megy.[/b]

Hello,

ha jol ertelmezem a problemad, akkor a /etc/X11/XF86Config-4 -ba ennek kellene szerepelnie. Nekem ezzel mukodik:
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "hu"
EndSection

udv,
battila

[quote:ff585e3b50="battila"][quote:ff585e3b50="ghannak"]Hali!
Nem tudom, újat mondok-e, még nem is értek nagyon a Debainhoz, sem az Xhez, kovetkezo a kerdesem. Letoltok egy minimalis debian cd-t, felrakom rola a base systemet, hogy legyen apt, meg ilyesmi. aztan szepen sorjaban felrakom az X-et, aztan xfce4-et, avgy enlightenmentet, mindegy. de: hiaba nyomom az alt-gr-t, nem muxik. ctrl-alt-F1 - F6 ban muxik, Xben sehogysem. akarhanyszor ujrakonfiguralom, nem megy.[/b]

Hello,

ha jol ertelmezem a problemad, akkor a /etc/X11/XF86Config-4 -ba ennek kellene szerepelnie. Nekem ezzel mukodik:
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "hu"
EndSection

udv,
battila

Sajnos pont ugyan ez van nekem is az input device szekcioban, csak 105 gombbal, es hat nem mukodik.
esetleg valami mas otlet?
koszi

Megint update...
Ket dolgot probaltam, eloszor a
dpkg-reconfigure locales , itt jelenleg csak a ket hu_HU volt, hozzaadtam az osszes en_ kezdetut.
Masik, hogy mc-bol kilepve az xterm jo lett. Ugy tunik, nem is az xtermben, hanem az mcben babraltak valamit felre...
Pl. CTRL-ENTER csak enterkent mukodik, az ALT-GR idiota karaktereket rak ki meg egyeb... Maga az xterm jonak laccik..

Szia !

[code:1:4dea427777]
Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "hu"
Option "XkbOptions" ""
EndSection
[/code:1:4dea427777]

Nálam így működik.

Szerintem az xkb csomagok környékén nézz körül, lehet hogy valami hiányzik...

Helló ghannak!

Nekem is volt egy időben ilyen problémám, nézd meg, hogy fent van-e az xbase-clients nevű csomagod. Azt hiszem ez vagy az ezáltal behúzott csomagok megoldják a problémádat. Írj, hogy mi lett belőle.
Helló :wink:

[quote:5c1e5dce1d="kozatt"]Helló ghannak!

Nekem is volt egy időben ilyen problémám, nézd meg, hogy fent van-e az xbase-clients nevű csomagod. Azt hiszem ez vagy az ezáltal behúzott csomagok megoldják a problémádat. Írj, hogy mi lett belőle.
Helló :wink:

Sajnos az xbase-clients csomag mar a legujabb verzio. :x

Az xkb csomagok kozul mi hianyozhat? (mert meg azt sem tudom, mik azok)
koszi

Ohh, btotyi, nagyon koszonom, megmentetted az eletemet :wink: !
az xkbopionsnel nekem "hu" volt, de kiszedtem, es lam, mukodik!
nagyon koszonok mindent!

Szornyu, nekem is volt ilyen gondom regen, aztan valahogy megcsinaltam, es most megint van :( Pedig csak egy apt-get update, upgrade volt, raadasul az osszes X-csomag hold-ra van allitva :(
Sot, futott az x, ugy ment le az upgrade....
Mindegy, ha megtalalom ujra a gondot, megirom. Barcsak felirtam volna anno, mit irtam at. :(

Update: lefuttattam ujra a frissitest, most mukodik az altgr, viszont a nehany karakter helyett nem az jelenik, aminek kellene :(
Ami meg rosszabb, hogyha xterm/bash es felfele nyillal elo akarom hozni a regi parancsokat, mar ott is rossz karakter jelenik meg :(
Tehat a pipe jele helyett rovid "ö". Hmm, itt viszont | jo...Ugy latszik, csak az xtermet erinti a problema.

Hali!

Debian alatt nem megy az alt-gr, nincsen hoszú û...
tud valaki segíteni?
Köszi!

[quote:a390f22795="Boy"]Hali!

Debian alatt nem megy az alt-gr, nincsen hoszú û...
tud valaki segíteni?
Köszi!

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "hu"
# ez a sor nem kell! Option "XkbOptions" ""
EndSection