Mplayer nem működik

 ( ProdyGee | 2005. május 31., kedd - 10:50 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Kipróbáltam egy csomó vo-t de nem javul meg tőlle. Szerintem a hangkártyával van baja, de mind1, dvd-t nézek xine vel, legalább a többi videot nézhetem mplayerrel. Mondjuk kicsit zavart hogy a xine egyből müködött ezt meg bekell hangolni, de gondolom, ha jól beállítgatom ez jobb lesz. Viszont milyen sdl eket tegyek fel? SDL=Simple DirectMedia Layer?
Gondolom eddigi írásaimból is kiderült hogy kezdő vagyok linux terén, szóval kicsit bővebben írd le légyszives.
Köszi
Gee

mekora felbontast hasznalsz? mert en ugy vettem eszre hogy aszem 800x600 vagy 1024x768-ban nem tud mplayer dvdt lejatsazni... az aspect ratio miatt nagyob bep jon ki mint a fizikai felbontas, es ekkor elszall. de aszem 800x600 a bunos, es aspect ratio miatt 960xYYY jonne ki.

1024x768, szerintem nem ez a baj.

Lenne egy kérdésem azt valahol be lehet állítani, hogy alapból esd-t használja, mert a mozilla plugint is felraktam és megáll a video mert alsa-t akar használni, de nekem esd kéne.

Amugy meg találtam egy bugot, de lehet hogy énvagyok hülye, van egy dvd-m amit a windowsos mplayer rosszul játszik le (linuxos még sehogy), mert csak a rárakott reklámot játsza le, aztán kiirja hogy vége és leáll.

A mediaplayer classic, meg a linuxos xine viszont lejátsza jól, dvdmenü, minden megy.

Bye
Gee

Fordítsd újra forrásból az Mplayert.

mplayer beallitasai a ~/.mplayer/config -ba vannak... oda beirod hogy ao=esd es maris azt fogja hasznalni... hany title van a dvd-n? dvd:// probaltad? megnezted nincs-e tobb title? dvd://2 pl?

Nekem egészen a mai napig tökéletesen működött, de miután tegnap átvittem a vinyót, amin a film volt egy wines gépre és visszahoztam, nem képes lejátszani semmit se (nem a linuxos vinyó, ez csak egy 20 gigás FAT32-s). Ezt írja ki: Végzetes hiba! Hiba a kiválasztott video_out (-vo) egység inicializálásakor! Se AVI se MPEG formátumot nem képes megnyitni, mindenhol ezt a hibeüzenetet kapom. Kérem, aki tud erről valamit, segítsen.

Az mplayerhq.hu nem megy. Van valami hir rola?

Hello
Ubuntu linuxra felraktam az mplayert, de ha bármit leakarok játszani kifagy.

Ezt írja ki:
MPlayer 1.0pre6-3.3.5 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for Debian.

Linux RTC init error in ioctl (rtc_irqp_set 1024): Hozzáférés megtagadva
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : Nincs ilyen fájl vagy könyvtár
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Nincs ilyen fájl vagy könyvtár
Failed to open LIRC support.
You will not be able to use your remote control.
Playing hw_kojima_productions_mgs4teaser.asf.
ASF file format detected.
VIDEO: [WMV3] 320x240 24bpp 1000,000 fps 0,0 kbps ( 0,0 kbyte/s)
Clip info:
name: KOJIMA PRODUCTIONS - MGS4 -
author: KOJIMA PRODUCTIONS
copyright: (C) 1987 2005 KONAMI
comments: You are prohibited to distribute any part of this data in any means w ithout the permission.
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 16005->176400 (128,0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
==========================================================================
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0 size:230400 align:1
StreamCount r=0x0 1 1
Decoder supports the following YUV formats: YV12 YUY2 UYVY YVYU  
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 320 x 240 (preferred csp: Packed YUY2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 320x240 => 320x240 Planar YV12
Selected video codec: [wmv9dmo] vfm:dmo (Windows Media Video 9 DMO)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
alsa-init: got device=0, subdevice=0
alsa-init: 1 soundcard found, using: default

kifagy
control-c -t nyomok

MPlayer interrupted by signal 2 in module: enable_cache

MPlayer interrupted by signal 2 in module: ao2_init

Mi lehet a baj?
A válaszokat előrre is köszi.

0000:00:00.0 Host bridge: Intel Corp. 82852/855GM Host Bridge (rev 01)
0000:00:00.1 System peripheral: Intel Corp. 855GM/GME GMCH Memory I/O Control Registers (rev 01)
0000:00:00.3 System peripheral: Intel Corp. 855GM/GME GMCH Configuration Process Registers (rev 01)
0000:00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 01)
0000:00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 01)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 83)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 03)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 03)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
0000:01:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (MOB) Ethernet Controller (rev 83)
0000:01:0a.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
0000:01:0b.0 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to Cardbus Bridge with ZV Support (rev 33)

Probald ki hang v. kep nelkul:

-ao null
vagy
-vo null

igy szukul a kor

-ao null -al működik, szóval a hangkártyámmal van valami baja

akkor probalkozz mas kimenettel.

-ao help

pl oss/arts/...

szuper esd vel megy köszi a segítséget

viszont, ha DVD-t akarok vele lejátszani:

$ mplayer -ao esd dvd://1
MPlayer 1.0pre6-3.3.5 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for Debian.

Linux RTC init error in ioctl (rtc_irqp_set 1024): Hozzáférés megtagadva
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : Nincs ilyen fájl vagy könyvtár
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Nincs ilyen fájl vagy könyvtár
Failed to open LIRC support.
You will not be able to use your remote control.
Playing dvd://1.
libdvdread: Using libdvdcss version 1.2.8 for DVD access
Reading disc structure, please wait...
There are 6 titles on this DVD.
There are 1 chapters in this DVD title.
There are 1 angles in this DVD title.

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000012b
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x000047f9
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x0000a8a0
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0001187e
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x000f00da
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x0011303a
libdvdread: Elapsed time 0
libdvdread: Found 3 VTS's
libdvdread: Elapsed time 0
DVD successfully opened.
MPEG-PS file format detected.
VIDEO: MPEG2 720x576 (aspect 2) 25,000 fps 8000,0 kbps (1000,0 kbyte/s)
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [liba52] AC3 decoding with liba52
AC3: 2.0 (stereo) 48000 Hz 192,0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 24000->192000 (192,0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
[AO ESD] latency: [server: 0,28s, net: 0,00s] (adjust 0,28s)
AO: [esd] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...

MPlayer interrupted by signal 11 in module: decode_audio
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.

En felpakolok egy csomo sdl-es cuccot az szokott segiteni a kulonfele kimeneti problemakon

[quote:2a970e4848="ProdyGee"]viszont, ha DVD-t akarok vele lejátszani:

$ mplayer -ao esd dvd://1
MPlayer 1.0pre6-3.3.5 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for Debian.

Linux RTC init error in ioctl (rtc_irqp_set 1024): Hozzáférés megtagadva
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : Nincs ilyen fájl vagy könyvtár
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Nincs ilyen fájl vagy könyvtár
Failed to open LIRC support.
You will not be able to use your remote control.
Playing dvd://1.
libdvdread: Using libdvdcss version 1.2.8 for DVD access
Reading disc structure, please wait...
There are 6 titles on this DVD.
There are 1 chapters in this DVD title.
There are 1 angles in this DVD title.

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000012b
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x000047f9
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x0000a8a0
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0001187e
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x000f00da
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x0011303a
libdvdread: Elapsed time 0
libdvdread: Found 3 VTS's
libdvdread: Elapsed time 0
DVD successfully opened.
MPEG-PS file format detected.
VIDEO: MPEG2 720x576 (aspect 2) 25,000 fps 8000,0 kbps (1000,0 kbyte/s)
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [liba52] AC3 decoding with liba52
AC3: 2.0 (stereo) 48000 Hz 192,0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 24000->192000 (192,0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
[AO ESD] latency: [server: 0,28s, net: 0,00s] (adjust 0,28s)
AO: [esd] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...

MPlayer interrupted by signal 11 in module: decode_audio
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.[/quote:2a970e4848]

Hali!

Próbáld meg "-vo xv" -vel! Vagy az előző analógiájára "-vo help", aztán válassz!

Üdv.: Tomyellow

Adódott egy kis gond az MPlayer telepítése után.
Nincs kép, csak hang.

A postomat nem ide szántam, hanem sokkal följebb, nemtom miért került ide, töröltem.

--
http://csuhai.hu

Szervusztok!
Frissen telepítettem forrásból hiba nélkül fordítva egy ACER Aspire 3103NLM laptopra az mplayer utsó változatát. Egy ATI Radeon Xpressz 1100-as videókártya van hozzá.
Telepítettem az ubuntu által felajánlott meghajtót a kártyához.
A probléma az, hogy mindössze két -vo opció van, ami elég kevés: x11 és xvidix. A kodekeknél kell esetleg állítani valamit? A gmplayerben a család kategóriában "egyik sem" van hangnál és képnél egyaránt.

Lehet, hogy a videókártyával van gond? Projektorra sem vetíti ki a képet.
Nagyon köszönöm az esetleges ötleteket.
Va

Rosszul fordítottad! A configure lefutása után láttad, hogy mik vannak engedélyezve, és mik nem, valszeg, csak ezek voltak (ezekhez voltak fent a megfelelő dev fájlok)! Szal, ne kinlódj vele, inkább tedd fel a binárist!

<= Powered By Ubuntu & Gentoo Linux =>

'Software is like sex: It's better when it's free!'
By Linus Torvalds

És mik a megfelelő dev fájlok? Az aktuális ubuntus mplayer csomag botrányos. A configura nem jelzett hibát, az nem jelenti azt, hogy nincsen csomaghiány?
Va

a libxv-dev (vagy hasonlo) meg valami mesa-dev csomag kene es akkor lesz -vo xv es -vo gl/gl2.

- Use the Source Luke ! -

Sziasztok!

Smplayert hasznalok video nezesre (avi). Az a gond, hogy nemelyik filmnel, sorozatnal tokeletesen mukodik, nemelyiknel pedig csuszik a hang a kephez kepest. Probalkoztam allitgatni mindent, amit az smplayerben talaltam (output driver, frame drop...), de egyik sem volt megfelelo. Nincs valakinek valami tippje, hogy mit tehetnek?

A gep amin probalkozom:
Ubuntu 8.10 64 bit
msi ex300: http://global.msi.eu/index.php?func=prodtmpspec&maincat_no=135&cat2_no=269&cat3_no=&prod_no=1538#menu

nekem is volt ilyen. Szerezz be egy friss SMplayer-t:
https://launchpad.net/~rvm/+archive/ppa

Aztan allitsd be a hard frame drop-ot, direct rendering-et, es a loop filter-t kapcsold ki h264-nal. Igy nalam nem csuszik. Regen csuszott azert valtottam VLC-re, de vegul SMplayer behozta a lemaradast s visszatertem.

koszonom, jo lett :)

SMPlayer alatt Performance -> Audio/Video Synchronization is segíthet.