WD5000AAKS - használhatatlan?

Üdv!

Van egy WD5000AAKS (WD Blue 500GB SATA2) típusú merevlemezem.
GPT + Ext4. Frissen formáztam, fstab-ban hozzáadtam teljesen alap beállítással.

UUID=xxx     /media/Data1     ext4   defaults  0 0

Na mármost bárhogy állítom be, bárhogy csatolom fel, akár Disks-szel, akár kézzel, akár bármit csinálok, használhatatlan. A S.M.A.R.T és a Disks szerint semmi baja, a HDSentinel 100%-nak írja.
Az adatokat időben átmentettem másik diszkre, azokkal nincs baj. (már egy ideje fsck ment bootoláskor)
A másik diszken jól vannak az adatok. De itt hiába formázom, nem jó semmilyen fájlrendszerrel. Nagyon érdekes anomáliákat produkál:
chown/chmod-tól függően a Nemo, még ha enyém is, nem tudta sokáig megnyitni. Kapott új csatolási pontot, akkor már megnyitotta. Aztán létrehozok rajta fájlokat, mappákat... és néha önkényesen írásvédettek lesznek a fájlok, vagy csak eltűntek. Évek óta használok linuxot, de ilyet még nem tapasztaltam. Valaki ötlet?
(előtte volt, hogy a systemd nem tudta csatolni, míg fstab-ból ki nem vettem)


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

# / (root) File system (SSD)
UUID=c8878059-3957-48d9-a912-510739390c1d 	            /		        ext4    noatime,errors=remount-ro   0	1

# EFI System Partition (SSD)
UUID=DB85-333D  					                    /boot/efi       vfat    umask=0077      		    0   1

# Home partition (Toshiba 500GB)
UUID=2258a3df-ba5c-4a41-a8ce-f356b39c6b4f	            /home		    ext4	defaults			        0	2

# Fast storage on SSD
UUID=12dbbe51-e6ff-4ec4-8678-30985f430c29 	            /media/Data2    ext4    noatime         		    0   2

# Torrent Drive
UUID=c05b3a16-3f9c-4ace-b2ea-73ec575a7064 	            /media/Torrents btrfs   defaults        		    0   2

# 16GB Swap partition
# UUID=b674dc41-0cbd-4a57-8106-ede3a6b3045a			    none    	    swap    defaults        			0   1

# Games storage
# UUID=86b6cba1-8613-4046-8ea7-67037268095b               /media/DataA    btrfs    defaults                   0   2
/dev/disk/by-uuid/7cd6cb0b-e2e3-4364-8631-f05d13e7646b /media/DataB auto nosuid,nodev,nofail,x-gvfs-show 0 0

Jól gondolom, hogy keresztet vethetek erre a diszkre? Ti hogy vadásznátok le a hiba okát?

Hozzászólások

Kiírsz rá bazi sok adatot, majd visszaolvasod, és megnézed, hogy a checksum stimmel-e. Mindezt mondjuk egy éjszakán keresztül, végtelen ciklusban. Könnyen lehet, hogy valami olyan elektronikai baja van, ami adatkorrupciót okoz. SATA kábel csere megvolt? Másik SATA portra átdugás?

Nem írtad, mennyi ideje van a lemez a gépben, de a fentiek mellett előfordulhat akár firmware inkompatibilitás is.
Én legutóbb egy 2TB-os lemezzel találkoztam, ami egyik gépben néhány MB/s-nál többet nem tudott, másik gépben, ill. látszólag azonos típusú, másik lemez az előbbi gépben is hozta a sebességet... és ott nem a SATA kábellel volt a gond.

Kipróbáltam egy másikat. Frissen formáztam utána, ezúttal gondoltam XFS. Beírtam fstabba, reboot. Ideáig minden fasza. Aztán rákattintottam az ikonjára és semmi. Ugyan az a hiba, mint tegnap. Minden más meghajtó működik, csak a Data #1 nem. (így neveztem el)
Ez most másik kábel.

Szerk.: Lehetséges, hogy ez valamilyen systemd-s baromság? Korábban a Disks-szel állítgattam a mountolást, de végül visszaállítottam mindent. Lehet, hogy a systemd mountolgatásában van a bibi?

Linux Mint 64-bit w/ Cinnamon

Hát jártam már némileg hasonló cipőben...
Talán hasznosítható belőle egy-két tanulság: https://hup.hu/node/120630
---
Régóta vágyok én, az androidok mezonkincsére már!

Nagyon jó leírás, hasznos, köszi. Egy dolgot nem értek, ezt ki tudnád fejteni, mi alapján jelentetted ki ezt?
"Az olvasást megismételve pontosan ugyanezt kapom vissza, viszont az írást megismételve más helyekre kerülnek a hibák".

Szóval, azt nem értettem többszöri olvasás után sem, hogy miböl gondoltad, hogy írásnál jött elö a hiba?

--
robyboy

Egyszerű, az idézett mondatban szerintem benne is van:
1. Csinálok egy írás tesztet.
2. Utána olvasás és compare. Van egy hibalistám.
3. Csinálok mégegyszer olvasás compare-t, ugyanazt a hibalistát kapom.
4. Csinálok egy második írás tesztet.
5. Megint olvasás, compare. Most megváltozott a hibalista.

Igencsak infinitezimális a valószínűsége, hogy bárhogy máshogy kijöjjön ilyen eredmény, minthogy a hibák fixen rá vannak írva a diszkre.

Azt már macerásabb megmagyarázni, hogy a memóriahiba miért érinti lényegesen nagyobb valószínűséggel az írást, mint az olvasást. Tippre leginkább a tesztelési módszer mellékterméke lehet. Írásnál a bemenő stream gyorsabban keletkezik, mint a diszk írni tudja, ezért a kernel több GB nagyságrendű puffert növeszt, ami jó eséllyel tartalmazni fogja a hibás memóriacímet. Olvasásnál megint a diszk a lassú, ezért az adat lassabban keletkezik, mint ahogy az ellenőrző fogyasztani tudja, ezért nem keletkeznek nagy pufferek.
---
Régóta vágyok én, az androidok mezonkincsére már!

>urunk 2000+17 esztendeje
>nem ZFS

hahahahahaa

>ext4
HAHAHAHAHAHA

Nos, úgy egy hete lett új alaplap. (MSI B250 PC MATE)
Eddig nem volt más baj. Aztán elkezdett fsck-t csinálni bootoláskor. Ekkor még ezen volt a /home. Féltve az adataim, gyorsan átmigráltam a diszk tartalmát a toshiba 500-as diszkemre. Aztán szépen megformáztam ezt, MBR-ről GPT, majd új ext4 partíció és végül csatoltam fstabból. Eztán átvettem chownnal a tulajdonjogot és chmod 0777-el szépen írhatóvá tettem. Itt kezdődtek a bibik.

Először bár megjelent az asztalon az ikonja, nem nyílt kattintásra. A többi igen. Ha chmodot hajtottam végre, utólagosan megnyílt. Aztán a csatolási pont felöl közelítettem. Felmásoltam egy játékot, próbaképp. Ugyanis játékos diszknek gondoltam még jó lesz. Ekkor lakat ikont mutatott a könyvtáron. Majd a fele cucc eltűnt belőle. Efféle nyalánkságokat szórt a rendszer. Folyamatos jogosultsághiba, majd I/O error is.

Linux Mint 64-bit w/ Cinnamon

Egyre inkább nemo bugnak tűnik... terminálból, MC-ből lazán másolok rá. Nemoban az oldalsávból nem tudom megnyitni sem, se hibaüzenet, semmi. Ha kikeresem a /media/Data1-et, akkor sem. Néha lakatot is mutat. A tulaja persze én vagyok. Rootként könnyedén tudok vele bármit csinálni persze, de nyilván nem így szeretném használni.

Szerk.:
Az a poén, hogy ha Disks-ben automata mountolást állítok, működik. Egyedül akkor szar, ha /media/Data1 van csatolási pontnak beállítva. Nem értem! >_< (vagy bárhol máshol a /media-ban)
Most /media/Data működik. Nem értem. Szerintem valahol eltárolt valami információt a /media/Data1 csatolási pontról, amikor az még az előző merevlemez volt, ami beragadt és emiatt van ez a hiba. Csak tudnám, mit kell keresni...

Linux Mint 64-bit w/ Cinnamon