[Megoldva] Mc hiba

 ( PP | 2015. december 15., kedd - 19:37 )

Sziasztok.

Felraktam a legfrissebb mc-t. Version: mc 4.8.15. Telepítés szépen le is zajlott, de indításnál a következő hibát dobja.

> +----------- Error ------------+
> | |
> | Unable to load 'default' skin. |
> | Default skin has been loaded |
> | |
> +--------------------------------+

Ennek ellenére elindul a program fekete fehérbe. De nem müködik megfelelöen. Tömörített file-at se tudom megnyítni. Probáltam a HOME könyvtárba törölni a config filet, hogy újra létrehozza. Megprobáltam újraforgatni is. Találkozott valaki ilyen problémával?

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Milyen OS, milyen módon lett felrakva, strace mit mutat, stb...

Lfs linux multilib.
Telepítés:
./configure --prefix=/usr \
--sysconfdir=/etc \
--enable-charset &&
make

make install &&
cp -v doc/keybind-migration.txt /usr/share/mc

strace nem mutat semmit nincs ilyen program fent.

A skinek elvileg a ${PREFIX}/share/mc/skins alatt vannak. Nálad van valami a /usr/share/mc/skins-ben? Konkrétan, van benne default.ini?

Ha nincs, akkor a make install valamiért nem pakolta oda a forrás-könyvtárból. Ha érteni akarod, hogy miért, akkor túrd meg a Makefile-okat. Ha csak a működés érdekel, akkor csak másold oda magadnak, oszt' jólvan.

Megtalálható az "/usr/share/mc/skins"-ben a default.ini file.

Hozzáférési jogok jók? (júzerből vagy root-ból próbálod?)

Nos, akkor hirtelen én is csak azt tudom javasolni, hogy tegyél fel egy strace-t, és nézd meg vele, hogy hol keresi valójában.

Mindegyik felhasználót probáltam. Mindegyiknél ugyan az a helyzett.

Megprobáltam, legyalulni az mc-t. A forrás könyvtárba kiadtam a "make uninstall" parancsot. Szépen le is futott, de az mc még mindig elindul. Megnéztem az /usr/bin- könyvtárba és ott már nincs bent az indító file-ok(mc, mcedit, mcview, mcdiff). Csak tudnám, hogy honnét indít.

whereis mc
find / -name mc

A make install ugye root joggal volt?


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Sikerült megoldani. /bin könyvtárba is bent volt. kitöröltem mindenhonnét útána újra felraktam és most jó. Köszi a segítséget.