Mogoldva * Debian/GNU Linox-on 11+év használat után nem tudok hálózatot csinálni

 ( mark7 | 2015. június 4., csütörtök - 0:54 )

Debian/GNU Linux-on 11+év használat után nem tudok hálózatot csinálni

MEGJ. Ezt rendszert kb 3+ éve használom, 99.99%-ban probléma mentesen, a wheezyt is frissíttetem már az előző verzióról

Ezt Win 7 alól írom, mivel csak itt van net

Biztos én vagyok a hülye, ha nem akkor az MS belülről kezdte szétverni a Debiant
A Rendszer

Debian/GNU Linux, 64bit, 3.2.x kernel, stable=wheezy, ablakkezelő XFCE4, de jó sok Gnome csomag is fent van,. ha ez segítség

A legutolsó KÉZI- mert már az automata frissítést se engedte - root-ként! apt-get update, apt-get upgrade után ez a helyzet

1: MINDEN!!! , SZABÁLYOSAN !!!!!!!!! VÉGREHAJTOTT - CTRL-ALT-DELETE consolból illetve X alóli ujraindítás - UTÁN az fsck.ext3 ? (ext3 a filerendszer) ellenőrzést hajt végre az engedélyem nélkül. Eddig ezt csak minden 26.-ik vagy 126-odik indítás után csinálta
De ez a kisebbik baj
A HDD 100%-ban bad sector mentes

2. 2003-ban és azóta ha gond volt, 2-3 paranccsal tudtam parancssorban router utáni internet kapcsolatot csinálni, most 3 napja nem tudok. 2003 -4 körül a legnagyobb gondom az volt hogy hány nap után tudok X -et hegeszteni a katódcsöves! monitoron, net az 11 másodperc alatt volt
Most sikerült elérni hogy már a loopback - lo - interface is eltűnt

A parancsok:

ifconfig = SEMMI kimenet
Még az lo interface is eltűnt, ilyet 11+ éve nem pipáltam, még Suse, UHU Linux és Red Hat alatt se

A parancsok (az apt-get update, apt-get upgrade után) , root - ként

ifconfig eth0 192.168.1.8 netmask 255.255.255.0
felváltva a

ifconfig eth0 192.168.1.8 up paranccsal

majd a

route add default gw 192.168.1.1 eth0

illetve

route add default gw 192.168.1.1

(192.168.1.1 a router IP-je)

Ezután "látszólag" van internet, legalábbis a 8.8.8.8-at tudom pingelni de hostnevet nem (hwsw.hu például)
A router felülete is bejön

/etc/resolf.conf tartalma (eddig üres volt , csak a

# Generated by Network Manager sor volt benne, de akor még az

etc/resolf.conf

tartalma

auto eth0
iface eth0 inet dhcp volt

De az apt-get upgrade LEGYALULTA a network-manager-gnome? csomagot meg kb 180 másik csomagot, de elvileg újra rakta szinte mindet az újabb verziókkal)

/etc/resolf.conf tartalma )most írtam bele kézzel) eddig nem kellett mivel az avahi? automatán beállította a hálózatot

192.168.1.1
208.67.222.222
Utóbbi az OpenDNS egyik szervere

/etc/network/interfaces fájl tartalma - most hogy idegességemben össze-vissza irkáltam, eddig

auto eth0
iface eth0 inet dhcp volt
(a wifi-t most hagyjuk egyenlőre)

MOST

auto eth0
iface eth0 inet static
address 192.168.1.7
netmask 255.255.255.0
gateway 192.168.1.1

Eddig idáig jutottam a fenti parancsok után

a 8.8.8.8-at és a 192.168.1.1-et - is ez a router - tudom pingelni tehát (szerintem) DNS feloldási hiba van

ping hwsw.hu sem megy
Böngészőből SEM megy egy oldal SEM, csak a router admin oldala

köszönöm a válaszokat

ui: az apt-get upgrade parancs kb 180 csomagot, küztük a gnome-core és egyéb - általam - létfontosságúnak tartott csomagot eltávolított majd ujrarakott, olyan ~310+MB méretben, közben többször rákérdezett bizonyos services-ek ujraindítására, amit engedélyeztem
Még egy megjegyzés, hátha itt a gond
A Budapesti Műszaki Egyetem - bme- szervereiről - amit eddig használtam - nem akarta letölteni az apt-get update a csomagokat ezért kényelmi szempontból rgy sorces.list generátorral állítottam elő az új /etc/apt/sources.list-et , úgy hogy az összes maint, contrib, security és non-free stb. , kivéve a 3th party csomagokat - csomagot bepipáltam, a szerver az ftp.hu.debian.org (99%-ék)

Előre is köszönöm a segítséget

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Milyen oprendszer alatt küzdesz?




Jó, jó, Debian, de melyik kiadás?
Ha netán Debian 8 (Jessie) lenne, akkor üdvözöld a systemD-t.

/etc/resolv.conf helyes formátuma szerintem:
nameserver 192.168.1.1
nameserver 208.67.222.222

Lehet én tudom rosszul, de kell bele a "nameserver".

+1

+2
(mert minden nameserver IP elé kell a "nameserver" szócska) - az már csak hab a tortán, hogy lassan 10-15 éve mindenhol megy a papolás, hogy nem az ifconfig / route, hanem az ip link / ip address / ip route parancsokat kellene használni Linuxon alapszintű hálózat felhúzására; persze ha van wifi pl., akkor kellhet még az iw / iwconfig és a wpa_supplicant is. Nyugodj meg, engem is zavar, de ha valaki nem használ egyéb *X rendszert, az nyugodtan átszokhat ezekre a modern eszközökre.

Kellene, de én sem azokat használom. Majd 10-15 év múlva én is átszokom rájuk. :)

--
Rózsár Gábor (muszashi)

Hamarabb, plö a debian jessie már nem mond semmit az ifconfigra.

Nekem (még?) igen. De lehet hogy csak azért mert upgrade volt. Bár kipróbáltam egy gépen ami úgy rémlik hogy már eleve Jessie netinstallból lett telepítve és azon is remek.

~# cat /etc/debian_version 
8.0
root@zsebi:~# ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:19:db:3d:93:c1  
          inet addr:10.34.32.21  Bcast:10.34.63.255  Mask:255.255.224.0
          inet6 addr: fe80::219:dbff:fe3d:93c1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3108954 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2283752 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1710104015 (1.5 GiB)  TX bytes:1890256012 (1.7 GiB)
          Interrupt:44 Base address:0x2000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:986 errors:0 dropped:0 overruns:0 frame:0
          TX packets:986 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:119815 (117.0 KiB)  TX bytes:119815 (117.0 KiB)

root@zsebi:~# dpkg -S $(which ifconfig)
net-tools: /sbin/ifconfig

Elnézést kérek, a nameserver valóban kimaradt
Késő - IS - volt:)

Így elsőre a /etc/network/interfaces -ben - ha NetworkManager van - csak az lo -nak kellene benne lennie.

Véletlenül a NetworkManager nem esett áldozatul a frissítésnek?

Próbáltad a dhclient eth0 parancsot? Milyen eredménnyel?

----
올드보이
http://molnaristvan.eu/

Szia

De igen, valamiért uninstallálás-ra került de most már visszatettem
Mostani upgrade után találkozok először systemd (hiba) üzenetekkel (systemd-logind) a konzolon. Az X-et kézzel indítom el
Mindenkinek köszönöm a segítséget, én voltam a hibás

Ha a grubban van lehetoseg a sysvinit kernelt bootolni, probald ki azt.

Anno egy nyari frissites ota (testing) bootkor megall a network felhuzasanal, orakig kepes ott kerregni. Bugreport volt rola (nem en voltam az elso), aztan a systemd/ifup kornyeken talaltak meg az okat. Nekem azota sem jo (vicces volt a boot: live cd, mount root, /etc/init.d/network a "exit 0" sorral kezdodott, aztan rendes boot es utana kivenni az exitet majd felepiteni a halozatot). Most mar szerencsere ott a sysvinit boot lehetosege, ha restart elott elflejtem beirni az exitet es megint nem bootol systemd-vel.

Csak otlet, nem biztos, hogy segit, de talan.

--
http://www.micros~1
Rekurzió: lásd rekurzió.

Egy clean install jobb lett volna (ugyebár /home, /opt, /usr/local, meg a többi külön partíción kellene lakjon), másrészt meg a fejlődés megállíthatatlan, éljen az automatizált felhasználóbarát mindent magától megoldó unix.
(Én most például a Slackware-en gondolkozom Debian helyett.)

-

Hiányzó firmware? Mi a vas?

Mindenkinek köszönöm a segítséget
Wheezy, 64bit , Linux E7 3.2.0-4-amd64 #1 SMP Debian 3.2.68-1+deb7u1 x86_64 GNU/Linux
systemd viszont már van, ezzel összefügghet az hogy minden induláskor lefut az fsck, szabályos leállítás, ujraindítás után is? Felette azt írja hogy rosszul jár a hw clock (Fixed) - jól jár az óra, max 30 másodperc az eltérés, eddig nem számított. Valamint userként nem tudom mountolni a többi partíciót a Lemezkezelő palimpsest-el . Eddig tudtam, root jelszó beadása után. Felhasználói csoportoknál semmit sem módosítottam. Kézi mountolásnál pedig a ilyen furcsaságot csinál (már régen kézzel létrehoztam az /mnt alatt az /sda1 , sda2, sda3 könyvtárakat, oda eddig tudtam mountolni
Most a mount /dev/sda1 /mnt/sda1 parancs után az addig /sda1 könyvtár ?sda -vá alakul, piros színben, belelépve látszanak az (ntfs) könyvtár és filenevek, pirossal, mindegyik előtt egy ? -jel és 0 byte a méret, az összesnem a dátuma 1970 Jan 1. M Commanderrel nem tudok belépni a könyvtárakba

kösz

Az óra nekem is meghülyült jessie-n, amit főleg akkor veszek észre, ha sshfs-re dolgozok. Állandóan elállítódik, és a make észreveszi a clock skew-t. Ha ntp-vel szinkronizálok, akkor jó egy ideig. Aztán lineárisan elcsúszik.

Most ki fogtok röhögni de az előbb vettem észre hogy már a jessie a stable verzio
A sorces.list -ben pedig még a wheezy van megadva:)
Ezért kavarodhatott meg teljesen
Most olvasom hogy már áprilisban kiadták
A haverom szólhatott volna
Bocsika és elnézést hogy feleslegesen fárasztottam a válaszolókat