MPlayer, gcc 4, SUSE 10, liba52

 ( Nagyimami | 2005. október 18., kedd - 15:25 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

[quote:604bd8a94c="Nagyimami"]Kösz a linket, Ice. Elolvastam, jól hangzik. Most húzom lefelé az MPlayer RPM-et, csak nagyon lassú. Ma este kipróbálom (munkahelyről netezek, otthon sajnos nincs internet), és holnap megírom a tapasztalatokat.

Üdv,[/quote:604bd8a94c]
A függőségekre vigyázz. Ha nincs otthon neted, ez okozhat problémát.
Pl.: lame, w32codec-all és még nem tudom mi.

Na igen, erre nem is gondoltam... Köszi, Macskajancsi.

A Suse 10-es mplayer fordítási gondját Kemenczy Karcsi is írta (igaz Ő 64 biten próbálkozott vele), és érzésem szerint sok jóra ne számítsunk amíg rendes bugreport->ptach->CVS változás nem lesz. Kerülő megoldásként még a VLC playerre rápróbálhatsz, nekem 9.2-n ment szépen.
Kicsit más téma de nekem a 10-esnél az tűnt fel hogy nagyon sok csomi nincs benne (jdictionary, dosbox...) és nagyon úgy tűnik h az FTP szervereken sincsen olyan forrás amiben ezek fent lennének. Ez vajh azt jelenti hogy mellőzve lettek, avagy csak _jelenleg_ nem tölthetőek még le? :?:

[quote:156ed918a3="Ice"]http://www.thejemreport.com/mambo/content/view/178/42/[/quote:156ed918a3]

Bizony nagyon jó a link, köszi!
Én is leszenvedtem a csomagokat és minden tökéletesen működik!

Gábor

[quote:2b53bc0f04="MrCrowley"]
Kicsit más téma de nekem a 10-esnél az tűnt fel hogy nagyon sok csomi nincs benne (jdictionary, dosbox...) és nagyon úgy tűnik h az FTP szervereken sincsen olyan forrás amiben ezek fent lennének. Ez vajh azt jelenti hogy mellőzve lettek, avagy csak _jelenleg_ nem tölthetőek még le? :?:[/quote:2b53bc0f04]
A gyári kétrétegű dvd-n rajta van.
1. Vagy vársz, amíg felrakják a netre,
2. Vagy letöltöd a full dvd-t
http://www.knetdome.com/bt/?torrent=suse100
3. Vagy megkeresed itt:
http://rpm.pbone.net/
(suse other-t jelölj be.)
A jDictionary pl. ugyanaz, mint az előző verzióban.

Köszi. Ezekkel a csomagokkal azt hiszem ráérek. Ami feltétlenül kell azt a régiből felteszem.

Sziasztok!

(Előre is bocs a hosszú üzenet miatt.)

Nemrégiben felraktam a SUSE 10-et, új telepítést végeztem. Fel szerettem volna rakni az mplayert is forrásból (1.0pre7try2), de elküldött a fenébe azzal, hogy ő nem hajlandó a 2.95-ös gcc-vel lefordulni. A SUSE persze nem 2.95-ös, hanem 4.0.2(-prerelease valami) gcc-vel jött. Arra gondoltam, hogy kipróbálom a --disable-gcc-checking opciót, ezzel a configure rendesen lefutott, de a fordítás során a libavcodec résznél hibával leállt. A hibák lényege az volt, hogy nem tudja lefordítani az MMX[2]-es, SSE[2]-es, 3DNow, stb. részeket.
Arra gondoltam, hogy felrakok egy 3.x-es gcc-t, ezt meg is tettem. 3.4.4-est raktam fel forrásból, külön, a /opt/gcc-3.4.4 könyvtárba, majd a configure szkriptnek megadtam a -cc=/opt/gcc-3.4.4/bin/gcc opciót. Le is fordult, aminek nagyon örültem, de kiderült, hogy korán, ugyanis:
- az mplayer néha minden ok nélkül leállt lejátszás közben, de semmilyen hibaüzenetet nem adott, csak 97-99%-ban megette a procit, viszont a kép és hang megállt
- az mencoder TV műsor felvételekor nem "folyamatosan" dolgozik, hanem "másfél másodperces részletekben", azaz a számláló minden kb. 1.5 mp felvett anyag után áll kb. 1 mp-et, és ez az effektus a felvett anyagon is érezhető, de csak a képen, a hang folyamatos

Ezek után, elégedetlenül az eredménnyel, letöltöttem a CVS verziót (2005. okt. 15-én), ami az ffmpeg-es libavutil és libavcodec hozzáadása után le is fordult (anélkül is, csak nem volt lavc támogatás), és jól le is játszik/fel is vesz mindent. Az egyetlen gondom az vele, hogy az AC3-as hanggal rendelkező DVD-k esetében hibával leáll, el sem kezdi a lejátszást. A hiba Segmentation Fault (11) a decode_audio fv-ben, de csak akkor, ha a liba52-es kodek játszaná le a hangot, más AC3 kodekkel ill. -ao null-lal próbálkozva nincs hiba, de hang sincs (ami a -ao null kivételével nem normális dolog).

Most tehát ott tartok, hogy a gcc-3.4.4-gyel forított 1.0pre7try2 verziót használom DVD lejátszására, ami néha ugyan kiakad, de kibírható; más videók lejátszására ill. TV műsor felvételére pedig a gcc-4.0.2-vel fordított CVS MPlayert.

Tudom, hogy már ez is egy megoldás, de azért zavar a dolog, mert az eddigiekben nem kellett ilyensmihez folyamodnom. Ha esetleg másnak hasonló tapasztalatai vannak, vagy netalántán tud valami megoldást, az ne kíméljen :)

(a gép: AMD Athlon XP 1700+, 512MB RAM, OpenSUSE 10.0, SUSE-féle 2.6.13 kernel)

Üdv,

http://www.thejemreport.com/mambo/content/view/178/42/

Érdekes fejlemény: kíváncsiságból a CVS verziónál a configure szkriptnek megadtam az --enable-debug (vagy vmi ilyesmi) opciót is, hátha többet megtudok arról, hogy miért is száll el 11-es szignállal, ha AC3-as hangot kell lejátszania. Az érdekesség a dologban az, hogy az így lefordított mplayer már nem produkálja a fenti hibát, azaz (eddigi tapasztalataim szerint) tökéletesen működik.

Kösz a linket, Ice. Elolvastam, jól hangzik. Most húzom lefelé az MPlayer RPM-et, csak nagyon lassú. Ma este kipróbálom (munkahelyről netezek, otthon sajnos nincs internet), és holnap megírom a tapasztalatokat.

Üdv,