HUP csak IP címen...

 ( Nagyapa | 2005. július 30., szombat - 21:38 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Sziasztok!

Üdv. Hunger, snq-, Congo... és a többi "Nagy Arc"-nak is :D

Egy érdekes dolgot tapasztalok már vagy 2 napja:

Az internetet a Freestart-hoz, vagy az Index-hez való betárcsázással érem el egy 56K-s modemmel. Viszont az a probléma merült fel, hogy a http://hup.hu/ (vagyis jelen oldal) mostmár sem a FreeStart sem az Index használatával nem jön be a szokott módon, vagyis a http://hup.hu/ beírásával. Csak és kizárólag a [color=blue:835d4dc910][b:835d4dc910]195.228.252.138[/b:835d4dc910][/color:835d4dc910] IP cím beírásával érhető el
Először csak a FreeStart-on próbálkozva jött be az alábbi sor a Hungarian Unix Portál kezdőlapja helyett:

[color=red:835d4dc910][b:835d4dc910]/usr/bin/perl: error while loading shared libraries: libm.so.6: cannot open shared object file: Error 23[/b:835d4dc910][/color:835d4dc910]

Felettébb érdekfeszítő a dolog.

A "Hab a tortán" az, hogy mostmár az Index-en keresztül elérve a web-et is ez az üzenet fogad a HUP helyett.

Megkönnyítem a dolgot: SEMMILYEN tűzfal nincs a PC-n, sem előtte!

De! Tovább megyek a dologgal!

FreeBSD alatt is próbálkoztam elérni a HUP-ot. Ott meg ez jön be:
[color=red:835d4dc910][b:835d4dc910]
/usr/bin/perl: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: Error 23[/b:835d4dc910][/color:835d4dc910]

Valami azt súgja: "A hiba NEM az Ön készülékében van!"

Node, akkor hol?

Tud valaki magyarázatot rá?
:?:

U.i.: a böngésző az Opera 8.01 és a FreeBSD alatt az Opera 7.54-el néztem

Esetleg egy operátol fűggetlen böngészővel probáltad?
Lehet egy edig rejtözködő opera hibára akadtál. Vagy valami másra.
invitel felölsimán működik.

glibcdet piszkaltad?
/usr/lib/libm.so az megvan? :wink:

Nem lehet, hogy a háromszázezeeee... harmincezeeee láthatatlan port okozza? :D Kérem kapcsolja ki.

ldconfig-ot próbáltad már? Nekem párx gyógyír volt a rendszerem hülyeségeire :)

valóban érdekes hiba :)
perlnek furcsa lenne ha bármi köze lenne az operához, de végülis, semmi sem elképzelhetetlen.
én nem használok operát, de esetleg valami alap pluginról nem lehet szó? ami default benne van az operában, perlt használ és... lekéri a domain ip címét ezt a perl scriptet felhasználva valami oknál fogva.. (azaz, ahelyett, hogy a C-s libet használná fel)?
akármi legyen is a gond egyébként, a probléma ugyanaz marad - hová lett a libm és a libcrypt?
nyomj egy "ldd /usr/bin/perl"-t és kapsz egy listát, azon látnod kell mely shared libeket használ a perl (nálam a libm és libcrypt is része ennek, tehát valszeg nálad is), amellett pedig meg fogja mutatni azt is melyek azok amelyeket megtalálta és melyek azok amelyeket _nem_.
emellett pedig próbáld másik browserrel is persze.

[quote:e8380ec728="8192Joco"]Esetleg egy operátol fűggetlen böngészővel probáltad?
Lehet egy edig rejtözködő opera hibára akadtál. Vagy valami másra.
invitel felölsimán működik.[/quote:e8380ec728]

Üdv.

A Mozilla 1.2.1 fentmaradt a rendszeremen és ez behozza gond nélkül.
Közben az Opera 8.01 helyett a 8.02 build 1272-őt tettem fel és ennél sem jön be a HUP.
A Mozillával mindíg.....

[quote:e8f174d430="vmiklos"]glibcdet piszkaltad?
/usr/lib/libm.so az megvan? :wink:[/quote:e8f174d430]

Üdv.

Az /usr/lib/libm.so megvan az ls szerint.
Viszont amint írtam FreeBSD alatt is hasonló szituáció van.
Tehát "Operaközeli" hiba lehet, vagy nem is tudom...

[quote:4887f5ef44="Beanie"]Nem lehet, hogy a háromszázezeeee... harmincezeeee láthatatlan port okozza? :D Kérem kapcsolja ki.[/quote:4887f5ef44]

Szerintem ezért kár volt hosszászólni :-(
Aztán majd jön Hunger és a többiek és addíg ragozzák a kérdést míg bebizonyítják, hogy nem értek semmit sem a
windowshoz
és jobb ha képzem magam, s elvégzem az ECDL vizsgát, hogy fel tudjam telepíteni ezután a
"PC-BSD" -t :D

Nos! Szóval nem a [b:4887f5ef44]port[/b:4887f5ef44]-on kellene elverni a [color=red:4887f5ef44] port[/color:4887f5ef44]

Ja, és a [i:4887f5ef44]ports collection[/i:4887f5ef44]-t se keverjük ide......

[quote:e66423533e="wry"]valóban érdekes hiba :)
perlnek furcsa lenne ha bármi köze lenne az operához, de végülis, semmi sem elképzelhetetlen.
én nem használok operát, de esetleg valami alap pluginról nem lehet szó? ami default benne van az operában, perlt használ és... lekéri a domain ip címét ezt a perl scriptet felhasználva valami oknál fogva.. (azaz, ahelyett, hogy a C-s libet használná fel)?
akármi legyen is a gond egyébként, a probléma ugyanaz marad - hová lett a libm és a libcrypt?
nyomj egy "ldd /usr/bin/perl"-t és kapsz egy listát, azon látnod kell mely shared libeket használ a perl (nálam a libm és libcrypt is része ennek, tehát valszeg nálad is), amellett pedig meg fogja mutatni azt is melyek azok amelyeket megtalálta és melyek azok amelyeket _nem_.
emellett pedig próbáld másik browserrel is persze.[/quote:e66423533e]

Üdv.
Köszi a tippet.
Kiadtam a parancsot, amely nekem is sokat segített eddíg --pl. a forráskódból való programfordítások előtt a meglévő régebbi verziójú binárisok szükségleteinek "vizsgálatánál"-- és most az alábbiakat kaptam:

ldd /usr/bin/perl
libnsl.so.1 => /lib/libnsl.so.1 (0x4002c000)
libdl.so.2 => /lib/libdl.so.2 (0x40041000)
libm.so.6 => /lib/libm.so.6 (0x40045000)
libc.so.6 => /lib/libc.so.6 (0x40068000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x40188000)
libutil.so.1 => /lib/libutil.so.1 (0x401b9000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Látszólag minden a helyén van.

[quote:a0864f7c01="Panther"]ldconfig-ot próbáltad már? Nekem párx gyógyír volt a rendszerem hülyeségeire :)[/quote:a0864f7c01]

Üdv.

Még nem próbáltam, de érdekelnének a "részletek", vagyis, hogy milyen tipped van esetleg.

Köszi :)

[quote:a3f9b25099="Nagyapa"]Még nem próbáltam, de érdekelnének a "részletek", vagyis, hogy milyen tipped van esetleg.[/quote:a3f9b25099]

Ehm, nem tudom, mire gondolsz. Az ldconfig csak begyorstárazza, hogy melyik lib hol van (nekem pl bootoláskor az ssh, stb stb nem indult el, de pl bash, su ment, így ki tudtam adni). Paraméterek nélkül kell kiadni (esetleg -v, hogy lásd is, mit csinál). No de ahogy elnézem, megtalálta lib-eket, szóval ezzel nem lehet gond.

Amennyit elmondtál, az alapján a hiba különösen érdekes, mert a függőségek rendben vannak => mennie [i:a3f9b25099]kellene[/i:a3f9b25099]...

[quote:47b78f12c0="vmiklos"]glibcdet piszkaltad?
/usr/lib/libm.so az megvan? :wink:[/quote:47b78f12c0]

Szia Miklós!

Végül is működik a dolog. :D
A Te ötleted hozott megoldást, ugyanis "szemrevételeztem" a libm.so-t "közelről". :)

Ugyebár ez egy szimbólikus link, ami nálam úgy "festett", hogy a /lib könyvtár alatt van a libm.so.6 és az /usr/lib/ alatt lelhető fel a libm.so
Namost! Ez egy egyszerű esetnek látszik ám mégsem volt az. Mégpedig:

A /usr/lib/libm.so szimbólikus link két könyvtárszinttel feljebb mutatott, vagyis így nézett ki: ../../libm.so és így nem működött a "dolog" pedig "létező" linknek nézett ki.

Gondoltam egyet és létrehoztam egy linket a /lib/libm.so.6-ra és így most jó!
:) :D

Már internetkapcsolat nélkül is látható volt az eredmény ugyanis nem az jött ki hibaüzenetként amit a fórum kezdéseként idéztem, hanem egy felbukkanó ablak jött elő és ott "Hálózati probléma" felirat.
Pedig [b:47b78f12c0]eddig[/b:47b78f12c0] netkapcsolat nélkül is az /usr/bin/perl..... üzenete jött elő

Ezért a jelek szerint elképzelhetően az Opera a felbukkanó ablakokhoz amelyek a hibaüzeneteket írják ki használja a perlt?

Másra nem tudok gondolni.
Mindenesetre az opera binárist az ldd-vel "faggatva" szükségletként előjött, hogy kell neki a libm.so.6 is.....

Érdekes szituáció volt, de a lényeg, hogy megoldódott :-P

[quote:16b70d16cf="Panther"][quote:16b70d16cf="Nagyapa"]Még nem próbáltam, de érdekelnének a "részletek", vagyis, hogy milyen tipped van esetleg.[/quote:16b70d16cf]

Ehm, nem tudom, mire gondolsz. Az ldconfig csak begyorstárazza, hogy melyik lib hol van (nekem pl bootoláskor az ssh, stb stb nem indult el, de pl bash, su ment, így ki tudtam adni). Paraméterek nélkül kell kiadni (esetleg -v, hogy lásd is, mit csinál). No de ahogy elnézem, megtalálta lib-eket, szóval ezzel nem lehet gond.

Amennyit elmondtál, az alapján a hiba különösen érdekes, mert a függőségek rendben vannak => mennie [i:16b70d16cf]kellene[/i:16b70d16cf]...[/quote:16b70d16cf]

Szia!
Az ldconfig lefut a bootolás során [b:16b70d16cf]minden[/b:16b70d16cf] alkalommal ugyanis az /etc/ld.so.cache fájlt ez a parancs hozza létre.

Node, mostmár megy :-P

[quote:3390ba7b14="Nagyapa"]Szia!
Az ldconfig lefut a bootolás során [b:3390ba7b14]minden[/b:3390ba7b14] alkalommal ugyanis az /etc/ld.so.cache fájlt ez a parancs hozza létre.

Node, mostmár megy :-P[/quote:3390ba7b14]

:)

elvileg a süsűmön is le kellett volna futnia. boot runlevel-ben benne van, mégis utána lehaltak a so-kat (vagy bizonyos so-kat) használó programok. Az elmúlt másfél hónapban 2x volt ilyen nekem. Ez is érdekes viselkedés :)

[quote:86052951e6="Panther"][quote:86052951e6="Nagyapa"]Szia!
Az ldconfig lefut a bootolás során [b:86052951e6]minden[/b:86052951e6] alkalommal ugyanis az /etc/ld.so.cache fájlt ez a parancs hozza létre.

Node, mostmár megy :-P[/quote:86052951e6]

:)

elvileg a süsűmön is le kellett volna futnia. boot runlevel-ben benne van, mégis utána lehaltak a so-kat (vagy bizonyos so-kat) használó programok. Az elmúlt másfél hónapban 2x volt ilyen nekem. Ez is érdekes viselkedés :)[/quote:86052951e6]

Üdv.
Valóban érdekes.
Én is SuSE Linuxot használok, ám ez valahol a SuSE 7.1-8.1 között van, ugyanis egy SuSE 7.1-et telepítettem 2001 májusban és ezt frissítgettem. Pl. a glibc.rpm-et a SuSE 8.1-esére ugyanis bizonyos újabb programok hiányolták, nomeg a gcc-t a hozzávaló "segéd" csomagokkal, és a KDE-t stb. stb.......
De az "alap" a SuSE 7.1 és elvagyok vele. Még eszembe sem jutott pl. SuSE 9.3-ra váltani.

Szia!

A hiba okát nem tudom, de ezt a jelenséget tapasztaltam én is egy barátom gépén, csütörtök éjjel.
Azon a gépen UHU 1.1 fut, és szintén Freestartos betárcsázós kapcsolat. A libcryptes hiabüzenetet adta az Opera, a Mozilla és a Konqueror is, 3-4 címmel próbáltam.
A links-szel próbálva a "Betöltési hiba, hiba a csatorna olvasása közben", wgettel próbálva az "HIBA -1: Rosszul formázott állapot vonal" hibaüzenetet kaptam.
Mindeközben ftp site-okat el lehetett érni, a jabber működött, ssh-val be tudtam lépni a gépre.
Kb. másfél óra múlva, anélkül, hogy bármin változtattunk volna, még újratárcsázás sem volt, a probléma megszűnt.
Szombaton kaptam egy mailt a barátomtól, hogy újra előjött a hiba. Hát nem tudom, de szerintem a szolgáltatónál nem stimmel vmi.

[quote:2edb0b2d6a="Nagyapa"]Üdv. Hunger, snq-, Congo... és a többi "Nagy Arc"-nak is :D [/quote:2edb0b2d6a]

hejj Mester Ur, udv ujra a Klubban! :) hianyoljuk a flame topikokat; gentoo vs debian, akarmi vs C# es akarmi vs windows temaban mindig megtalalsz:)

btw sok szerencset a fenti problema megoldasaban

[quote:74dec310f0="snq-"][quote:74dec310f0="Nagyapa"]Üdv. Hunger, snq-, Congo... és a többi "Nagy Arc"-nak is :D [/quote:74dec310f0]

hejj Mester Ur, udv ujra a Klubban! :) hianyoljuk a flame topikokat; gentoo vs debian, akarmi vs C# es akarmi vs windows temaban mindig megtalalsz:)

btw sok szerencset a fenti problema megoldasaban[/quote:74dec310f0]

Üdv.

Sajnos, sajnos rossz hírem van :cry:
A továbbiakban is hiányozni fogok a "Nagy Arcoknak" főképp a "Flame topic"-okban. Nomeg a gentoo, debian stb.-ben is, merthogy egyiket sem használom.

A másik rossz hírem :cry: "mesterem", hogy olyasvalaki volt ötletadó a hiba felderítésében és megoldásában (ez által), aki [b:74dec310f0][color=blue:74dec310f0]nem nagy arc[/b:74dec310f0][/color:74dec310f0] a flame topicban, sokkalta inkább a [b:74dec310f0][color=red:74dec310f0]a hozzáértésben[/b:74dec310f0][/color:74dec310f0] és biz' a ez az ami számít.

Mindazonáltal lészen egy jó hírem is! Elmondanám vala, hogy ha olvastad volna tán az első oldal alját, akkor mán olvastad vón vala, hogy mög lett oldva a problema :-)

Ennyi.
Maradok Tisztelettel és Üdv. a "Nagy Arcz"-oknak :)

Aproposz: Van eladó domború tükör melyben a nagy arczok még nagyobbnak látszanak
8O :) :o :D :lol:

[quote:73e01646c2="croach"]Szia!

A hiba okát nem tudom, de ezt a jelenséget tapasztaltam én is egy barátom gépén, csütörtök éjjel.
Azon a gépen UHU 1.1 fut, és szintén Freestartos betárcsázós kapcsolat. A libcryptes hiabüzenetet adta az Opera, a Mozilla és a Konqueror is, 3-4 címmel próbáltam.
A links-szel próbálva a "Betöltési hiba, hiba a csatorna olvasása közben", wgettel próbálva az "HIBA -1: Rosszul formázott állapot vonal" hibaüzenetet kaptam.
Mindeközben ftp site-okat el lehetett érni, a jabber működött, ssh-val be tudtam lépni a gépre.
Kb. másfél óra múlva, anélkül, hogy bármin változtattunk volna, még újratárcsázás sem volt, a probléma megszűnt.
Szombaton kaptam egy mailt a barátomtól, hogy újra előjött a hiba. Hát nem tudom, de szerintem a szolgáltatónál nem stimmel vmi.[/quote:73e01646c2]

Szevasz! :P

Amint az előző oldalon olvasható, nálam megoldódott a probléma és azóta is megy a "dolog". Szerintem ha van mód, akkor nem ártana másik oprendszerrel (más Linux disztribúció, Free- PC-BSD) megpróbálni.

Az sem lehetetlen, hogy a szolgáltató ooldalon van valami, bár a névfeloldás nem csak a HUP-nál nem működött nekem és az Indexes "netkapcsolat" esetében is "bejött a hibapont"

Node, jó próbálkozást 8) Hátha sikerül neked is.

[quote:e24df6ca67="Nagyapa"]Aproposz: Van eladó domború tükör melyben a nagy arczok még nagyobbnak látszanak
8O :) :o :D :lol:[/quote:e24df6ca67]

Az meglepne. Persze ha a domborusag merteke negativ...

[quote:0ded9e65c2="BandiG"][quote:0ded9e65c2="Nagyapa"]Aproposz: Van eladó domború tükör melyben a nagy arczok még nagyobbnak látszanak
8O :) :o :D :lol:[/quote:0ded9e65c2]

Az meglepne. Persze ha a domborusag merteke negativ...[/quote:0ded9e65c2]

Hi!
Ez egy speciális "varázstükör" amelyben az egyszerű lovászfiú is őrgrófnak látja magát...
Vagyis mindenki aki belenéz azt látja magáról amilyennek szeretné ha látnák a kivülállók.
Például Bill Gates ha belenézne, akkor egy talpig feddhetetlen, jószívű, szerény embert látna, aki egyáltalán nem nagyravágyó és emellett a nyilt forrás közösség barátja, aki a windowsok és office-ok százezreit osztogatja szét a szegényebb országok között. S mindezt emberbaráti szeretetből, hogy lássák milyen bőkezű adakozó...

[quote:980ac99488="Nagyapa"]Például Bill Gates (...) aki a windowsok és office-ok százezreit osztogatja szét a szegényebb országok között. S mindezt emberbaráti szeretetből, hogy lássák milyen bőkezű adakozó...[/quote:980ac99488]

Most is ezt teszi: szemet húny a warezelés felett. Illetve: csak majdnem. A frissítésnél be kell írni egy extra sort, és akkor már minden ok... Ráadásul tudtommal Gates csak a tulaj, nem az igazgató...

[quote:fa85562694="Panther"][quote:fa85562694="Nagyapa"]Például Bill Gates (...) aki a windowsok és office-ok százezreit osztogatja szét a szegényebb országok között. S mindezt emberbaráti szeretetből, hogy lássák milyen bőkezű adakozó...[/quote:fa85562694]

Most is ezt teszi: szemet húny a warezelés felett. Illetve: csak majdnem. A frissítésnél be kell írni egy extra sort, és akkor már minden ok... Ráadásul tudtommal Gates csak a tulaj, nem az igazgató...[/quote:fa85562694]

Hmmmm....

De, ugye nem ez lenne az ideális, avagy a "megálmodott" mondhatni a "Szép új világ" modellje?
:?